Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > Capturing and Editing Video > Avisynth Usage

Reply
 
Thread Tools Search this Thread Display Modes
Old 15th March 2010, 02:21   #21  |  Link
osgZach
Registered User
 
Join Date: Feb 2009
Location: Waterloo, WI - USA
Posts: 649
Quote:
Originally Posted by Zarxrax View Post
A pretty nasty bug has been found. You are unable to use the arrow keys or home/end etc to move around the text, because these keys always change focus to the video.
I didn't cause this bug, it already exists in the original source code.
I'll try to learn Python and fix it.
Are they defined in a config somewhere as being bound to functions that do editing on the video?

Just thinking out loud here.. (I haven't even used the program before) cause I wonder if its a simple routine to not allow those keys to reset the focus or something when eidting text, or if they need to not be bound as editing keys for video in the first place.

In either case, sounds like something someone should mention to the wxforms/wxpython people, if its a bug with the Win32 interface it should fall on them to fix it.

However I am interested in learning how it interfaces to load/display video in the first place.. Does it use Avisynth wrapper? Is that part well documented? I'm interested in it for a project of my own.. But if it doesn't pan out I may be able to contribute the fruits of that effort to AvsP in some form.. Mainly for dealing with Hybrid Anime content.

Also may want to consider porting it to Python 3.x branch now since its the most recent.. It may or may not be difficult depending on what syntax changes need to be made, but I'm betting there will be some advantages to that.. If I can find time to sit down and "get into" this project, maybe I will assess the possibility of moving it over.

Last edited by osgZach; 15th March 2010 at 02:28.
osgZach is offline   Reply With Quote
Old 15th March 2010, 13:18   #22  |  Link
Gavino
Avisynth language lover
 
Join Date: Dec 2007
Location: Spain
Posts: 3,373
Quote:
Originally Posted by osgZach View Post
However I am interested in learning how it interfaces to load/display video in the first place.. Does it use Avisynth wrapper?
It uses the Avisynth library interface via a wrapper to the C functions - see source files avisynth.py and pyavs.py.
Gavino is offline   Reply With Quote
Old 15th March 2010, 15:20   #23  |  Link
XadoX
Registered User
 
XadoX's Avatar
 
Join Date: Feb 2002
Posts: 187
Great News
XadoX is offline   Reply With Quote
Old 15th March 2010, 16:29   #24  |  Link
osgZach
Registered User
 
Join Date: Feb 2009
Location: Waterloo, WI - USA
Posts: 649
Thanks Gavino, will look inside those.. it's all GPL'ed right? I remember some uproar-ish thread here about someone making an Avisynthwrapper or something like that, but wanting to charge money for it.
osgZach is offline   Reply With Quote
Old 16th March 2010, 00:54   #25  |  Link
mel2000
Registered User
 
Join Date: Jun 2007
Posts: 50
I have AviSynth 2.57a installed. I get the following error when I launched v2.0.3 of AvsPmod.exe.

[Mon Mar 15 18:24:44 2010]
Traceback (most recent call last):
File "run.py", line 6, in <module>
File "AvsP.pyo", line 11359, in main
File "wx\_core.pyo", line 7978, in __init__
File "wx\_core.pyo", line 7552, in _BootstrapApp
File "AvsP.pyo", line 11349, in OnInit
File "AvsP.pyo", line 3368, in __init__
File "AvsP.pyo", line 3901, in getOptionsDict
File "ntpath.pyo", line 270, in isdir
TypeError: coercing to Unicode: need string or buffer, int found

Any recommendations for a solution appreciated.
mel2000 is offline   Reply With Quote
Old 16th March 2010, 01:26   #26  |  Link
Zarxrax
Registered User
 
Zarxrax's Avatar
 
Join Date: Dec 2001
Location: Concord, NC
Posts: 1,168
@mel2000: I'll release a new build soon that is compiled differently. Let me know if that helps or not, after I release it. I think it might.

@others:
After AvsP 2.0.2 was released, qwerpoi released a bugfix patch, that fixed a few bugs which are mentioned here: http://forum.doom9.org/showthread.ph...59#post1059559
I have been trying to look into these bugs to see if I could fix them as well, but, I can't actually reproduce any of the bugs (or even figure out the exact details of some of them). Does anyone have any information about them?
Zarxrax is offline   Reply With Quote
Old 16th March 2010, 11:03   #27  |  Link
XadoX
Registered User
 
XadoX's Avatar
 
Join Date: Feb 2002
Posts: 187
Somehow the arrow keys are not working for me as they should.
While pressing up or down the programm always starts the preview windows und tries to skip through the video. But I want to move through the test file.
XadoX is offline   Reply With Quote
Old 16th March 2010, 12:17   #28  |  Link
Alex_ander
Registered User
 
Alex_ander's Avatar
 
Join Date: Apr 2008
Location: St. Petersburg, Russia
Posts: 335
Quote:
Originally Posted by XadoX View Post
While pressing up or down... But I want to move through the test file.
Why not left/right?
Alex_ander is offline   Reply With Quote
Old 16th March 2010, 12:20   #29  |  Link
XadoX
Registered User
 
XadoX's Avatar
 
Join Date: Feb 2002
Posts: 187
If I am in text editing mode I want to use the arrow keys for navigation through the text file.
While in videopreview mode the arrow keys have to navigate through the video.
XadoX is offline   Reply With Quote
Old 16th March 2010, 16:25   #30  |  Link
Zarxrax
Registered User
 
Zarxrax's Avatar
 
Join Date: Dec 2001
Location: Concord, NC
Posts: 1,168
Quote:
Originally Posted by XadoX View Post
Somehow the arrow keys are not working for me as they should.
While pressing up or down the programm always starts the preview windows und tries to skip through the video. But I want to move through the test file.
Did you not read the thread? It will be fixed soon
Zarxrax is offline   Reply With Quote
Old 17th March 2010, 02:06   #31  |  Link
Zarxrax
Registered User
 
Zarxrax's Avatar
 
Join Date: Dec 2001
Location: Concord, NC
Posts: 1,168
Ok here is version 2.0.4

Code:
Changes:
- Fixed arrow keys not working in the text area
- Fixed icon not appearing in vista/7
- Fixed custom function definitions not being saved (bug existed in avsp 2.0.2) [this fix may introduce a new bug]
- Included MSVCP71.dll, which may be needed on some systems
- Added some additional default file extension templates
- Added some macros

Last edited by Zarxrax; 10th April 2010 at 18:12.
Zarxrax is offline   Reply With Quote
Old 17th March 2010, 04:53   #32  |  Link
mel2000
Registered User
 
Join Date: Jun 2007
Posts: 50
Quote:
Originally Posted by Zarxrax View Post
@mel2000: I'll release a new build soon that is compiled differently. Let me know if that helps or not, after I release it. I think it might.
Thanks Zarxrax. Unfortunately I got the same errors after installing 2.0.4. However, since 2.0.2 is working adequately, I'm still grateful.
mel2000 is offline   Reply With Quote
Old 17th March 2010, 06:33   #33  |  Link
levi
Registered User
 
Join Date: Mar 2003
Posts: 116
thx for taking this up, I love it too & will test it out
levi is offline   Reply With Quote
Old 17th March 2010, 06:36   #34  |  Link
Zarxrax
Registered User
 
Zarxrax's Avatar
 
Join Date: Dec 2001
Location: Concord, NC
Posts: 1,168
Quote:
Originally Posted by mel2000 View Post
Thanks Zarxrax. Unfortunately I got the same errors after installing 2.0.4. However, since 2.0.2 is working adequately, I'm still grateful.
Hmmm, that's really odd that it doesn't work for you. What version of windows are you using? Are you launching it from the exe?
Zarxrax is offline   Reply With Quote
Old 17th March 2010, 06:59   #35  |  Link
XadoX
Registered User
 
XadoX's Avatar
 
Join Date: Feb 2002
Posts: 187
Quote:
Originally Posted by Zarxrax View Post
Did you not read the thread? It will be fixed soon
In that case I think I have to say the truth: No
I am sorry.
XadoX is offline   Reply With Quote
Old 18th March 2010, 11:07   #36  |  Link
XadoX
Registered User
 
XadoX's Avatar
 
Join Date: Feb 2002
Posts: 187
Feature Request:

Better interaction between DGdecNV (in that case DGMultiSource) and AvsPmod.

While working with DGSource and the Cuvid-Server everything works fine. If I am using DGMultiSource instead AvsPmod often crashes.

Maybe its more a feature request for DGdecNV?
XadoX is offline   Reply With Quote
Old 18th March 2010, 15:22   #37  |  Link
Zarxrax
Registered User
 
Zarxrax's Avatar
 
Join Date: Dec 2001
Location: Concord, NC
Posts: 1,168
Quote:
Originally Posted by XadoX View Post
Better interaction between DGdecNV (in that case DGMultiSource) and AvsPmod.

While working with DGSource and the Cuvid-Server everything works fine. If I am using DGMultiSource instead AvsPmod often crashes.

Maybe its more a feature request for DGdecNV?
Sorry, I don't own a license to that software.
Can anyone else confirm that it doesn't work in AvsP?
Zarxrax is offline   Reply With Quote
Old 18th March 2010, 23:18   #38  |  Link
nautilus7
Registered User
 
nautilus7's Avatar
 
Join Date: Jan 2006
Location: Athens, Greece
Posts: 1,498
Yes, I experience the *exact* same problem mentioned by XadoX. It only happens with DGmultiSource and only with the "previous frame" button at random times.

Last edited by nautilus7; 18th March 2010 at 23:23.
nautilus7 is offline   Reply With Quote
Old 18th March 2010, 23:45   #39  |  Link
Zarxrax
Registered User
 
Zarxrax's Avatar
 
Join Date: Dec 2001
Location: Concord, NC
Posts: 1,168
Quote:
Originally Posted by nautilus7 View Post
Yes, I experience the *exact* same problem mentioned by XadoX. It only happens with DGmultiSource and only with the "previous frame" button at random times.
Seems like a strange problem. Does it happen in avsp 2.0.2? What about other apps like virtualdub?
What exactly happens when it crashes? Is there an error message?
Zarxrax is offline   Reply With Quote
Old 19th March 2010, 00:25   #40  |  Link
sjakke
Registered User
 
sjakke's Avatar
 
Join Date: May 2003
Location: Bikini Space Planet
Posts: 78
I'm not an avsp user. But I have to give you a thumbs up for taking initiative. And it's a good way to start learning some python
__________________
What do you think rubber ducky? Quack. Quack. My thoughts exactly.
sjakke is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 06:25.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.