Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > Video Encoding > MPEG-4 Encoder GUIs

Reply
 
Thread Tools Search this Thread Display Modes
Old 12th November 2009, 07:36   #1  |  Link
epow0317
Holic
 
Join Date: Sep 2009
Posts: 34
i have difficulty in encoding videos to approriate iPod format

my operation system is windows xp 32bit.
and i used megui(version 0.3.1.1051) in encoding videos.
also, encoding setting i used is [x264: Device-iPod].

but, when i excuted it thorugh the QuickTime,
it doesn't work at all.
it says Invalid Public Movie Atom was Found in the Movie.

i have went through this before.
the cause of this situation was Frame rate.
but, situation lately happend seems to be diffrent form previous that of it.

i'm wondering if you could solve this problem.
please, help me.
the details of encoded video are here.

============================================
ID : 1
Format : AVC
Format/Info : Advanced Video Codec
Format profile : Baseline@L1.3
Format settings, CABAC : NO
Format settings, ReFrames : 5 Frame
Codec ID : avc1
Codec ID/Info : Advanced Video Coding
Bit rate mode : vbr
Bit rate : 1 500 Kbps
Maximum bit rate : 4 557 Kbps
Width : 640 pixel
Height : 272 pixel
Display aspect ratio : 2.35
Frame rate mode : fixed
Frame rate : 23.976 fps
Resolution : 24 bit
Colorimetry : 4:2:0
Scan type : progressive
Bits/(Pixel*Frame) : 0.359
Stream size : 1.28 GiB (100%)
Writing library : x264 core 68 r1183M f21daff
Encoding settings : cabac=0 / ref=5 / deblock=1:0:0 / analyse=0x1:0x131 / me=umh / subme=6 / psy_rd=1.0:0.0 / mixed_ref=1 / me_range=12 / chroma_me=1 / trellis=0 / 8x8dct=0 / cqm=0 / deadzone=21,11 / chroma_qp_offset=-2 / threads=3 / nr=0 / decimate=1 / mbaff=0 / bframes=0 / keyint=250 / keyint_min=25 / scenecut=40 / rc=2pass / bitrate=1500 / ratetol=1.0 / qcomp=0.60 / qpmin=16 / qpmax=51 / qpstep=4 / cplxblur=20.0 / qblur=0.5 / vbv_maxrate=768 / vbv_bufsize=768 / ip_ratio=1.40 / aq=1:1.00
Encoded date : UTC 2009-11-11 04:09:31
Tagged date : UTC 2009-11-11 06:06:12
============================================
epow0317 is offline   Reply With Quote
Old 12th November 2009, 10:36   #2  |  Link
raisinberry777
Registered User
 
Join Date: Feb 2009
Posts: 13
Max bitrate has to be 1500, I'm fairly sure. Also, make sure the audio is AAC-LC, not AAC-HE
raisinberry777 is offline   Reply With Quote
Old 12th November 2009, 11:40   #3  |  Link
Lyle_JP
Unreasonable User
 
Lyle_JP's Avatar
 
Join Date: Nov 2003
Posts: 203
Your bitrate is double what you set the vbv_maxrate and vbv_bufsize to. It's a wonder it encoded. As I recall, vbv_bufsize should be set to 2000 and vbv_maxtrate needs to be set to 2500 (this works with any video iPod with the latest firmware). Bitrate is probably overkill at 1500. 1000 works on most material, with 1200 for bitrate-hungry stuff. Also, you can be at level 3, 1.3 is too low.
Lyle_JP is offline   Reply With Quote
Old 12th November 2009, 11:56   #4  |  Link
epow0317
Holic
 
Join Date: Sep 2009
Posts: 34
how can i modify Max-bitrate?

Quote:
Originally Posted by raisinberry777 View Post
Max bitrate has to be 1500, I'm fairly sure. Also, make sure the audio is AAC-LC, not AAC-HE
u said i should modify Max-bitrate.
so, i have tried to find anything concerned with it.
there's no textbox i could control about Max-bitrate.

but, Megui has both VBV Buffer Size and VBV Maximum Bitrate.
are they related to this situation?
how can i control the Max-Bitrate?

Please, Help me.
Oh! also, i'm not good at english.
so please, understand me.
thanks :-)
epow0317 is offline   Reply With Quote
Old 12th November 2009, 12:04   #5  |  Link
epow0317
Holic
 
Join Date: Sep 2009
Posts: 34
Thanks for your attemting! but..

Quote:
Originally Posted by Lyle_JP View Post
Your bitrate is double what you set the vbv_maxrate and vbv_bufsize to. It's a wonder it encoded. As I recall, vbv_bufsize should be set to 2000 and vbv_maxtrate needs to be set to 2500 (this works with any video iPod with the latest firmware). Bitrate is probably overkill at 1500. 1000 works on most material, with 1200 for bitrate-hungry stuff. Also, you can be at level 3, 1.3 is too low.
i tried what you said to me.
but, when i attempt to control VBV Maximum Bitrate to 2500.
Megui warned me "Sorry, the selected profile exceeds the AVC Level you have specified Maximum Bitrate is too high"

In fact, i encoded [the trailer of Twilight: New Moon] through the same profile.
but, it completely works in QuickTime.
why this situation affect to special case?
please, help me.
epow0317 is offline   Reply With Quote
Old 12th November 2009, 13:56   #6  |  Link
TwoToad
Registered User
 
TwoToad's Avatar
 
Join Date: Oct 2005
Posts: 74
Why do you use the iPod profile instead of the iPod5.5 profile? The 5.5 profile supports a max of 1500 bitrate, but I'm not sure what the regular iPod profile can support.

I encode for iPod all the time, I'm not sure if I'm good at explaining though... I'll try...

1st I change the 5.5G profile to have a bitrate of 1500... For the audio profile I use Nero AAC: NDAAC - iPod - Good and change it to Constant Bitrate @ 128kps. (I also check the Apply Dynamic Range Compression box to increase the volume)

When making the Avisynth script, if the movie is animorphic I check the Clever anamorphic encoding to resize to mod 16. Crop. Resize down to 640 x ??? (as long as the first number is 640 you are ok). Do anything else you need to in the script (deinterlace, filters, etc...)

So back at the main screen of megui, make sure your avs is loaded, use the iPod 5.5G settings, load your audio and use the iPod Good settings.

Then I hit AutoEncode, select MP4, then in the Device drop down box I select iPod, then select No Target Size and finally click Queue...

After the encode is finished, I've discovered that MeGUI forgets to pass to mp4box the correct aspect ratio for anamorphic videos and so I end up re-muxing with YAMB to set the aspect ratio back to 16:9...

Anyway, thats just what I do to make them work.

I have in the past been able to add chapters and soft subtitles, but I've found that those only work with the iPod Touch/iPhone (and not on my iPod 5.5G)
TwoToad is offline   Reply With Quote
Old 12th November 2009, 20:00   #7  |  Link
b66pak
Registered User
 
b66pak's Avatar
 
Join Date: Aug 2008
Location: The Land Of Dracula (Romania - EU)
Posts: 934
@epow0317...start megui go to options>settings and check "Force Video File Extension for QT compatibility"...this will solve the QT "Invalid Public Movie Atom was Found in the Movie" problem...
_
b66pak is offline   Reply With Quote
Old 12th November 2009, 22:25   #8  |  Link
Lyle_JP
Unreasonable User
 
Lyle_JP's Avatar
 
Join Date: Nov 2003
Posts: 203
Quote:
Originally Posted by epow0317 View Post
i tried what you said to me.
but, when i attempt to control VBV Maximum Bitrate to 2500.
Megui warned me "Sorry, the selected profile exceeds the AVC Level you have specified Maximum Bitrate is too high"
Did you change the level to 3.0 from 1.3 like I suggested?

Here's the line I use for iPod videos. I get videos that, when played back and upscaled to HD on my PS3, look as good as the DVD source (and yes, they play back perfectly on iPods too):
--profile baseline --level 3 --preset fast --pass 2 --bitrate ???? --stats ".stats" --thread-input --deblock 0:0 --no-cabac --b-bias 0 --scenecut 40 --ref 1 --qpmin 16 --vbv-bufsize 2000 --vbv-maxrate 2500 --rc-lookahead 50 --aq-mode 1 --aq-strength 1.0 --merange 12 --me umh --subme 6 --partitions p8x8,b8x8,i4x4,p4x4 --no-8x8dct --trellis 0 --psy-rd 1.0:0 --no-mixed-refs --no-fast-pskip --output "output" "input"

It's essentially the iPod5.5g profile, but with some tweaks I added. The bitrate is source dependent, with reasonable values being anywhere from 800-1200 depending on the complexity of the source material. Movies with a lot of static shots, or night-time sequences require less; heavy noise, grain, and or movement require more. I just completed a 688x386 iPod video of "The Shining", which compressed perfectly at only 900 kbps.

Last edited by Lyle_JP; 12th November 2009 at 22:41.
Lyle_JP is offline   Reply With Quote
Old 13th November 2009, 10:15   #9  |  Link
epow0317
Holic
 
Join Date: Sep 2009
Posts: 34
Thank you!

Quote:
Originally Posted by b66pak View Post
@epow0317...start megui go to options>settings and check "Force Video File Extension for QT compatibility"...this will solve the QT "Invalid Public Movie Atom was Found in the Movie" problem...
_
i'm encoding video in the way you told me.
I guess it will be played completely.
Anyway, thank you for helping me.
epow0317 is offline   Reply With Quote
Old 13th November 2009, 12:42   #10  |  Link
epow0317
Holic
 
Join Date: Sep 2009
Posts: 34
oh..dear..

Quote:
Originally Posted by b66pak View Post
@epow0317...start megui go to options>settings and check "Force Video File Extension for QT compatibility"...this will solve the QT "Invalid Public Movie Atom was Found in the Movie" problem...
_
i have just finished encoding video in the way you suggested me.
but, situation occured again...

what should i do?
should i change AVC Level to 3.0?
oh, my god..
it drives me crazy.
help!
epow0317 is offline   Reply With Quote
Old 13th November 2009, 13:03   #11  |  Link
epow0317
Holic
 
Join Date: Sep 2009
Posts: 34
i'm encoding video now..

Quote:
Originally Posted by Lyle_JP View Post
Did you change the level to 3.0 from 1.3 like I suggested?

Here's the line I use for iPod videos. I get videos that, when played back and upscaled to HD on my PS3, look as good as the DVD source (and yes, they play back perfectly on iPods too):
--profile baseline --level 3 --preset fast --pass 2 --bitrate ???? --stats ".stats" --thread-input --deblock 0:0 --no-cabac --b-bias 0 --scenecut 40 --ref 1 --qpmin 16 --vbv-bufsize 2000 --vbv-maxrate 2500 --rc-lookahead 50 --aq-mode 1 --aq-strength 1.0 --merange 12 --me umh --subme 6 --partitions p8x8,b8x8,i4x4,p4x4 --no-8x8dct --trellis 0 --psy-rd 1.0:0 --no-mixed-refs --no-fast-pskip --output "output" "input"

It's essentially the iPod5.5g profile, but with some tweaks I added. The bitrate is source dependent, with reasonable values being anywhere from 800-1200 depending on the complexity of the source material. Movies with a lot of static shots, or night-time sequences require less; heavy noise, grain, and or movement require more. I just completed a 688x386 iPod video of "The Shining", which compressed perfectly at only 900 kbps.
Finally, i changed AVC Level to 3.0.
also, i changed Profile to iPod 5.5 Profile.
and now, i'm encoding video.

by the way, can AVC Level 3.0 be played on iPod Touch 1G?
epow0317 is offline   Reply With Quote
Old 13th November 2009, 15:56   #12  |  Link
epow0317
Holic
 
Join Date: Sep 2009
Posts: 34
oh, my god...

Quote:
Originally Posted by Lyle_JP View Post
Did you change the level to 3.0 from 1.3 like I suggested?

Here's the line I use for iPod videos. I get videos that, when played back and upscaled to HD on my PS3, look as good as the DVD source (and yes, they play back perfectly on iPods too):
--profile baseline --level 3 --preset fast --pass 2 --bitrate ???? --stats ".stats" --thread-input --deblock 0:0 --no-cabac --b-bias 0 --scenecut 40 --ref 1 --qpmin 16 --vbv-bufsize 2000 --vbv-maxrate 2500 --rc-lookahead 50 --aq-mode 1 --aq-strength 1.0 --merange 12 --me umh --subme 6 --partitions p8x8,b8x8,i4x4,p4x4 --no-8x8dct --trellis 0 --psy-rd 1.0:0 --no-mixed-refs --no-fast-pskip --output "output" "input"

It's essentially the iPod5.5g profile, but with some tweaks I added. The bitrate is source dependent, with reasonable values being anywhere from 800-1200 depending on the complexity of the source material. Movies with a lot of static shots, or night-time sequences require less; heavy noise, grain, and or movement require more. I just completed a 688x386 iPod video of "The Shining", which compressed perfectly at only 900 kbps.
it occurs again...
what should i do..........

i encoded two video as a same way.
one is twilight new moon trailer.
the other is twilight movie.

trailer works perfectly, but twilight movie
doesn't work...

please, please, please help me.!!!!!!!!!!!!

-baseline 3.0, bitrate 1000, vbv buffer 1500, max bitrate 1500, Reference Frame 5

Last edited by epow0317; 13th November 2009 at 15:59.
epow0317 is offline   Reply With Quote
Old 13th November 2009, 19:13   #13  |  Link
b66pak
Registered User
 
b66pak's Avatar
 
Join Date: Aug 2008
Location: The Land Of Dracula (Romania - EU)
Posts: 934
could you post the log for the nonworking movie?..you will find it in "Program Files\megui\logs\" folder...
_
b66pak is offline   Reply With Quote
Old 14th November 2009, 03:33   #14  |  Link
epow0317
Holic
 
Join Date: Sep 2009
Posts: 34
here it is..

Quote:
Originally Posted by b66pak View Post
could you post the log for the nonworking movie?..you will find it in "Program Files\megui\logs\" folder...
_
one of the profile is here.

[Information] Log
-[Information] Versions
--[NoImage] MeGUI Version : 0.3.1.1051
--[NoImage] OS : Windows XP Professional x86 SP3 (5.1.196608.2600)
--[NoImage] Framework used : 2.0 SP1 (2.0.50727.3603)
-[Information] Hardware
--[NoImage] CPU : AMD Processor model unknown
-[Information] Log for job1 (video, Twilight 720P.avs -> )
--[Information] [2009-11-13 9:00:05] Started handling job
--[Information] [2009-11-13 9:00:05] Preprocessing
--[NoImage] Job commandline: "C:\Program Files\megui\tools\x264\x264.exe" --profile baseline --pass 1 --bitrate 1000 --stats "Twilight 720P.stats" --level 3 --ref 1 --no-mixed-refs --bframes 0 --no-cabac --subme 2 --trellis 0 --partitions none --qpmin 16 --vbv-bufsize 1500 --vbv-maxrate 1500 --me dia --merange 20 --threads 2 --thread-input --sar 1:1 --output NUL "Twilight 720P.avs"
--[Information] [2009-11-13 9:00:05] Encoding started
--[NoImage] Standard output stream
--[NoImage] Standard error stream
---[NoImage] avis [info]: 640x272 @ 23.98 fps (175273 frames)
---[NoImage] x264 [info]: using SAR=1/1
---[NoImage] x264 [info]: using cpu capabilities: MMX2 SSE2Fast FastShuffle SSEMisalign LZCNT
---[NoImage] x264 [info]: profile Baseline, level 3.0
---[NoImage]
---[NoImage] x264 [info]: slice I:2027 Avg QP:18.47 size: 22424
---[NoImage] x264 [info]: slice P:173246 Avg QP:20.93 size: 5089
---[NoImage] x264 [info]: mb I I16..4: 27.2% 0.0% 72.8%
---[NoImage] x264 [info]: mb P I16..4: 7.8% 0.0% 0.0% P16..4: 75.0% 0.0% 0.0% 0.0% 0.0% skip:17.2%
---[NoImage] x264 [info]: final ratefactor: 19.69
---[NoImage] x264 [info]: coded y,uvDC,uvAC intra:57.7% 61.9% 23.6% inter:34.4% 31.2% 3.0%
---[NoImage] x264 [info]: kb/s:1014.6
---[NoImage] encoded 175273 frames, 56.19 fps, 1014.67 kb/s
--[Information] [2009-11-13 9:52:11] Postprocessing
---[Information] Deleting intermediate files
--[Information] [2009-11-13 9:52:13] Job completed
-[Information] Log for job2 (video, Twilight 720P.avs -> Twilight 720P.mp4)
--[Information] [2009-11-13 9:52:14] Started handling job
--[Information] [2009-11-13 9:52:14] Preprocessing
--[NoImage] Job commandline: "C:\Program Files\megui\tools\x264\x264.exe" --profile baseline --pass 2 --bitrate 1000 --stats "Twilight 720P.stats" --level 3 --ref 5 --bframes 0 --no-cabac --subme 6 --trellis 0 --partitions p8x8,b8x8,i4x4 --no-8x8dct --qpmin 16 --vbv-bufsize 1500 --vbv-maxrate 1500 --me umh --merange 20 --threads 2 --thread-input --sar 1:1 --output "Twilight 720P.mp4" "Twilight 720P.avs"
--[Information] [2009-11-13 9:52:24] Encoding started
--[NoImage] Standard output stream:
--[NoImage] Standard error stream
---[NoImage] avis [info]: 640x272 @ 23.98 fps (175273 frames)
---[NoImage] x264 [info]: using SAR=1/1
---[NoImage] x264 [info]: using cpu capabilities: MMX2 SSE2Fast FastShuffle SSEMisalign LZCNT
---[NoImage] x264 [warning]: target: 1000.00 kbit/s, expected: 943.75 kbit/s, avg QP: 22.3075
---[NoImage] x264 [info]: profile Baseline, level 3.0
---[NoImage] mp4 [info]: initial delay 0 (scale 2500000)
---[NoImage]
---[NoImage] x264 [info]: slice I:2027 Avg QP:19.25 size: 20939
---[NoImage] x264 [info]: slice P:173246 Avg QP:20.80 size: 4733
---[NoImage] x264 [info]: mb I I16..4: 19.7% 0.0% 80.3%
---[NoImage] x264 [info]: mb P I16..4: 0.7% 0.0% 2.0% P16..4: 50.2% 22.0% 10.4% 0.0% 0.0% skip:14.7%
---[NoImage] x264 [info]: coded y,uvDC,uvAC intra:75.5% 72.6% 47.9% inter:27.0% 32.6% 3.6%
---[NoImage] x264 [info]: ref P L0 72.0% 13.2% 8.0% 3.6% 3.2%
---[NoImage] x264 [info]: kb/s:943.8
---[NoImage] encoded 175273 frames, 27.75 fps, 943.85 kb/s
--[Information] Final statistics
---[NoImage] Video Bitrate Desired: 1000 kbit/s
---[NoImage] Video Bitrate Obtained (approximate): 944 kbit/s
--[Information] [2009-11-13 11:38:04] Postprocessing
---[Information] Deleting intermediate files
----[Information] [2009-11-13 11:38:04] Successfully deleted Twilight 720P.stats
--[Information] [2009-11-13 11:38:04] Job completed
epow0317 is offline   Reply With Quote
Old 14th November 2009, 08:16   #15  |  Link
epow0317
Holic
 
Join Date: Sep 2009
Posts: 34
perhaps...

Quote:
Originally Posted by b66pak View Post
could you post the log for the nonworking movie?..you will find it in "Program Files\megui\logs\" folder...
_
Perhaps,,,
Can QT really find out Invalid Movie Atom?
Profile doesn't contain anything that causes error.
oh, dear..
epow0317 is offline   Reply With Quote
Old 14th November 2009, 18:18   #16  |  Link
b66pak
Registered User
 
b66pak's Avatar
 
Join Date: Aug 2008
Location: The Land Of Dracula (Romania - EU)
Posts: 934
@epow0317...man you did not do what i instruct you to do!!!

Quote:
start megui go to options>settings and check "Force Video File Extension for QT compatibility"...this will solve the QT "Invalid Public Movie Atom was Found in the Movie" problem...
_

P.S. this is the proof:
Quote:
--output "Twilight 720P.mp4" "Twilight 720P.avs"
why are you asking for help if you don't follow the instructions?
_

P.S.2 if you still have the .mp4 demux it to raw (using mp4box) then remux the .h264 to .mp4 again...this will solve the problem...
_

Last edited by b66pak; 14th November 2009 at 18:22.
b66pak is offline   Reply With Quote
Old 15th November 2009, 02:46   #17  |  Link
epow0317
Holic
 
Join Date: Sep 2009
Posts: 34
listen please,,

Quote:
Originally Posted by b66pak View Post
@epow0317...man you did not do what i instruct you to do!!!


_

P.S. this is the proof:


why are you asking for help if you don't follow the instructions?
_

P.S.2 if you still have the .mp4 demux it to raw (using mp4box) then remux the .h264 to .mp4 again...this will solve the problem...
_
[proof]: http://hosting.ohseon.com/aemalf/proof.bmp

I've already done it before.
But, i think megui doesn't apply this option.

After i checked it, The commandline is still
"program --profile baseline --pass 2 --bitrate 1500 --stats ".stats" --level 1.3 --ref 5 --bframes 0 --no-cabac --subme 6 --trellis 0 --partitions p8x8,b8x8,i4x4,p4x4 --no-8x8dct --qpmin 16 --vbv-bufsize 768 --vbv-maxrate 768 --me umh --merange 32 --thread-input --output "output" "input" "

>> STILL output "output" "input"

Megui seems to ignore this option. what can i do..?
>> Should i do something special after i check it?
Should i upgrade megui to latest version ?
What version do you use?

Last edited by epow0317; 15th November 2009 at 04:09.
epow0317 is offline   Reply With Quote
Old 15th November 2009, 09:26   #18  |  Link
epow0317
Holic
 
Join Date: Sep 2009
Posts: 34
ok, i'll try ps.2

Quote:
Originally Posted by b66pak View Post
@epow0317...man you did not do what i instruct you to do!!!


_

P.S. this is the proof:


why are you asking for help if you don't follow the instructions?
_

P.S.2 if you still have the .mp4 demux it to raw (using mp4box) then remux the .h264 to .mp4 again...this will solve the problem...
_
Demux, and then Remux?
Ok! i'll try!

Thanks for your undying help!
epow0317 is offline   Reply With Quote
Old 15th November 2009, 13:55   #19  |  Link
epow0317
Holic
 
Join Date: Sep 2009
Posts: 34
works great!

Quote:
Originally Posted by b66pak View Post
@epow0317...man you did not do what i instruct you to do!!!


_

P.S. this is the proof:


why are you asking for help if you don't follow the instructions?
_

P.S.2 if you still have the .mp4 demux it to raw (using mp4box) then remux the .h264 to .mp4 again...this will solve the problem...
_
it works great!
thanks!!!
epow0317 is offline   Reply With Quote
Old 15th November 2009, 19:03   #20  |  Link
b66pak
Registered User
 
b66pak's Avatar
 
Join Date: Aug 2008
Location: The Land Of Dracula (Romania - EU)
Posts: 934
do this:

1. prepare the audio: it should be .aac, .mp4 or .m4a;
2. load the .avs script in megui;
3. select the desired iPod profile;
4. hit "autoencode" (make sure that options>settings>"Force Video File Extension for QT compatibility" is checked
5. select the bitrate or final size and check "add additional content";
6. add the audio;
7. start the queue!
_
b66pak is offline   Reply With Quote
Reply

Tags
ipod, megui

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 10:34.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2017, vBulletin Solutions Inc.