Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > Video Encoding > New and alternative video codecs

Reply
 
Thread Tools Search this Thread Display Modes
Old 17th October 2009, 17:19   #8741  |  Link
SamuriHL
Registered User
 
SamuriHL's Avatar
 
Join Date: May 2004
Posts: 3,768
http://pastebin.com/pastebin.php?dl=d352fe952

No change my friend.
SamuriHL is offline   Reply With Quote
Old 17th October 2009, 17:41   #8742  |  Link
albain
Media Control author
 
Join Date: Dec 2006
Location: Paris
Posts: 1,014
Something's wrong i don't see the new fields that i added in the traces
albain is offline   Reply With Quote
Old 17th October 2009, 17:42   #8743  |  Link
SamuriHL
Registered User
 
SamuriHL's Avatar
 
Join Date: May 2004
Posts: 3,768
Not sure. I can try again once the movie's done. Assuming we don't lose power again.

EDIT: Just checked and it was definitely using the latest one you uploaded.

Last edited by SamuriHL; 17th October 2009 at 17:44.
SamuriHL is offline   Reply With Quote
Old 17th October 2009, 17:44   #8744  |  Link
albain
Media Control author
 
Join Date: Dec 2006
Location: Paris
Posts: 1,014
Sorry again, I really need some cafeine : I posted the same build as before

Here is the right one
albain is offline   Reply With Quote
Old 17th October 2009, 17:45   #8745  |  Link
SamuriHL
Registered User
 
SamuriHL's Avatar
 
Join Date: May 2004
Posts: 3,768
Ok, will try again once my movie's done. Thanks!
SamuriHL is offline   Reply With Quote
Old 17th October 2009, 18:08   #8746  |  Link
SamuriHL
Registered User
 
SamuriHL's Avatar
 
Join Date: May 2004
Posts: 3,768
Yea, um, the receiver noticed but went to PCM mode and output no audio.

http://pastebin.com/pastebin.php?dl=d86f51dc
SamuriHL is offline   Reply With Quote
Old 17th October 2009, 18:13   #8747  |  Link
albain
Media Control author
 
Join Date: Dec 2006
Location: Paris
Posts: 1,014
If I have time I will make a tool to scan the media types accepted by the audio driver
albain is offline   Reply With Quote
Old 17th October 2009, 18:20   #8748  |  Link
albain
Media Control author
 
Join Date: Dec 2006
Location: Paris
Posts: 1,014
This time the log output is what I expected
but this still does not work.

What about AC3 and EAC3 ?
albain is offline   Reply With Quote
Old 17th October 2009, 18:22   #8749  |  Link
SamuriHL
Registered User
 
SamuriHL's Avatar
 
Join Date: May 2004
Posts: 3,768
AC3 pauses every frame so it's got this nice skipping thing going on but does bitstream, and as we determined earlier, EAC3 doesn't bitstream on my card with this driver.
SamuriHL is offline   Reply With Quote
Old 17th October 2009, 18:29   #8750  |  Link
Andy o
Registered User
 
Join Date: Mar 2009
Posts: 928
Can the MPC audio renderer be used for something other than bitstreaming, like WASAPI exclusive mode with decoded LPCM? Seems not to be connecting here with MPC-HC 1300.
Andy o is offline   Reply With Quote
Old 17th October 2009, 18:58   #8751  |  Link
mrcorbo
Registered User
 
Join Date: Jan 2005
Posts: 169
Quote:
Originally Posted by SamuriHL View Post
AC3 pauses every frame so it's got this nice skipping thing going on but does bitstream, and as we determined earlier, EAC3 doesn't bitstream on my card with this driver.
Same as above when running DebugView and again silent when not running DebugView (though this time bitstream is not even detected).

http://pastebin.com/m7d768882
mrcorbo is offline   Reply With Quote
Old 17th October 2009, 21:17   #8752  |  Link
tal.aloni
Registered User
 
Join Date: Sep 2008
Posts: 496
Guys,
I got the green light from albain, so I commited my OSD modifications.

please let me know if there's any issue with the new patch, I won't rest until everything is in order. (sorry for resetting your OSD settings, it was unavoidable)

here is the patch that has been commited: (almost nothing has changed from beta 2)

http://iknowu.net/files/public/ffdsh...SD-Beta3.patch

Tal Aloni
tal.aloni is offline   Reply With Quote
Old 17th October 2009, 21:30   #8753  |  Link
albain
Media Control author
 
Join Date: Dec 2006
Location: Paris
Posts: 1,014
Quote:
Originally Posted by Andy o View Post
Can the MPC audio renderer be used for something other than bitstreaming, like WASAPI exclusive mode with decoded LPCM? Seems not to be connecting here with MPC-HC 1300.
Sure, I have the specs for that too. It is easier to implement than compressed stream. But after that TrueHD and EAC3 (and maybe DTS HD with a little luck) will work


@Tal
Thank you, I will make the needed adaptations of Media Control
albain is offline   Reply With Quote
Old 17th October 2009, 22:09   #8754  |  Link
Andy o
Registered User
 
Join Date: Mar 2009
Posts: 928
Thanks for the confirmation, I'll have to figure how to make MPC use the renderer. I've registered it, do I need to move the file to the system folder or something as well?
Andy o is offline   Reply With Quote
Old 17th October 2009, 22:11   #8755  |  Link
SamuriHL
Registered User
 
SamuriHL's Avatar
 
Join Date: May 2004
Posts: 3,768
No, you have to add it in the external filters and set it to prefer.
SamuriHL is offline   Reply With Quote
Old 18th October 2009, 00:15   #8756  |  Link
STaRGaZeR
4:2:0 hater
 
Join Date: Apr 2008
Posts: 1,307
Quote:
Originally Posted by tal.aloni View Post
Guys,
I got the green light from albain, so I commited my OSD modifications.

please let me know if there's any issue with the new patch, I won't rest until everything is in order. (sorry for resetting your OSD settings, it was unavoidable)

here is the patch that has been commited: (almost nothing has changed from beta 2)

http://iknowu.net/files/public/ffdsh...SD-Beta3.patch

Tal Aloni
Great work Tal.
__________________
Specs, GTX970 - PLS 1440p@96Hz
Quote:
Originally Posted by Manao View Post
That way, you have xxxx[p|i]yyy, where xxxx is the vertical resolution, yyy is the temporal resolution, and 'i' says the image has been irremediably destroyed.
STaRGaZeR is offline   Reply With Quote
Old 18th October 2009, 09:25   #8757  |  Link
Andy o
Registered User
 
Join Date: Mar 2009
Posts: 928
Quote:
Originally Posted by SamuriHL View Post
No, you have to add it in the external filters and set it to prefer.
I did try that, but couldn't find it. I could find it on the output list though, but it doesn't connect just by selecting it there. I'll get it eventually.
Andy o is offline   Reply With Quote
Old 18th October 2009, 11:00   #8758  |  Link
albain
Media Control author
 
Join Date: Dec 2006
Location: Paris
Posts: 1,014
I have found a new bug : I am happy when I find a bug because this means that we can move forwad

It was not very clear but stream size must be referenced in bytes instead of bits for HD formats otherwise there is not enough room to write it. So it couldn't work at all

Here is the new link

Quote:
Originally Posted by Andy o View Post
I did try that, but couldn't find it. I could find it on the output list though, but it doesn't connect just by selecting it there. I'll get it eventually.
It means that the format is refused by the mpc renderer and MPC reverts to directsound. If you get dbgview you will probably see this refusal.

The renderer is for now at development state : LPCM is not implemented, there are dropouts, and it is compiled in debug mode with many debug traces so it is slow and gives jitter.
Last thing but not the least, depending on the audio card/GPU and the driver, the official media types are refused by some and accepted by some others, so an additional layer will be added to try several types for each audio format.
For example :
if input format is TrueHD, try official MS true hd type, then try arcsoft one (for the xonar), and powerdvd one (for the auzentech)...
Maybe this can be avoided by passing LPCM type all the time and doing what we want whatever the format is.

Last edited by albain; 18th October 2009 at 11:26.
albain is offline   Reply With Quote
Old 18th October 2009, 11:59   #8759  |  Link
Skinleech
A.K.A Mangoat
 
Join Date: Nov 2002
Posts: 203
Here is my log, using the latest beta & the rebuilt audio renderer from post #8744. The clip played in MPC, but I got no sound, my receiver showed multichannel.

I still get no audio pin in Graphstudio so can't try that way.

Code:
00000000	0.00000000	[1696] CMpcAudioRenderer::CheckMediaType	
00000001	0.00007912	[1696] Media Type Structure	
00000002	0.00007912	[1696]  Format type : FORMAT_WaveFormatEx	
00000003	0.00007912	[1696]  	
00000004	0.00012300	[1696] Sub type : MEDIASUBTYPE_PCM	
00000005	0.00012300	[1696]  	
00000006	0.00016860	[1696] 	
00000007	0.00016860	[1696]  WAVEFORMATEXTENSIBLE :	
00000008	0.00016860	[1696]  subFormat : MEDIASUBTYPE_PCM	
00000009	0.00016860	[1696]  	
00000010	0.00021440	[1696] 	
00000011	0.00021440	[1696]  wSamplesPerBlock : 16 	
00000012	0.00021440	[1696] Valid bits per sample : 16	
00000013	0.00021440	[1696]  	
00000014	0.00025440	[1696] 	
00000015	0.00025440	[1696]  WAVEFORMATEX :	
00000016	0.00025440	[1696]  wFormatTag : 	
00000017	0.00029284	[1696] WAVE_FORMAT_EXTENSIBLE	
00000018	0.00034960	[1696] 	
00000019	0.00034960	[1696] cbSize : 22 	
00000020	0.00034960	[1696] nAvgBytesPerSec : 576000 	
00000021	0.00034960	[1696] Channels : 6 	
00000022	0.00034960	[1696] Bits per sample : 16 	
00000023	0.00034960	[1696]  Samples per second : 48000 	
00000024	0.00034960	[1696]  nBlockAlign : 12	
00000025	0.00034960	[1696]  	
00000026	0.00042140	[1696] CMpcAudioRenderer::CheckAudioClient	
00000027	0.00043644	[1696] CMpcAudioRenderer::GetDefaultAudioDevice	
00000028	0.00132908	[1696] CMpcAudioRenderer::CreateAudioClient	
00000029	0.00156732	[1696] CMpcAudioRenderer::CreateAudioClient success	
00000030	0.00389696	[1696] CMpcAudioRenderer::CheckMediaType WASAPI client refused the format	
00000031	0.00407508	[1696] CMpcAudioRenderer::CheckMediaType	
00000032	0.00412780	[1696] Media Type Structure	
00000033	0.00412780	[1696]  Format type : 	
00000034	0.00412780	[1696]  	
00000035	0.00416940	[1696] Sub type : 	
00000036	0.00416940	[1696]
Skinleech is offline   Reply With Quote
Old 18th October 2009, 12:09   #8760  |  Link
Skinleech
A.K.A Mangoat
 
Join Date: Nov 2002
Posts: 203
New log with Xonar driver version 1775, which also updated the slim firmware from 1.10HD to 1.11HD - no idea what's changed. Log looks the same though.

Code:
00000000	0.00000000	[1320] CMpcAudioRenderer::CheckMediaType	
00000001	0.00031080	[1320] Media Type Structure	
00000002	0.00031080	[1320]  Format type : FORMAT_WaveFormatEx	
00000003	0.00031080	[1320]  	
00000004	0.00035516	[1320] Sub type : MEDIASUBTYPE_PCM	
00000005	0.00035516	[1320]  	
00000006	0.00040052	[1320] 	
00000007	0.00040052	[1320]  WAVEFORMATEXTENSIBLE :	
00000008	0.00040052	[1320]  subFormat : MEDIASUBTYPE_PCM	
00000009	0.00040052	[1320]  	
00000010	0.00044612	[1320] 	
00000011	0.00044612	[1320]  wSamplesPerBlock : 16 	
00000012	0.00044612	[1320] Valid bits per sample : 16	
00000013	0.00044612	[1320]  	
00000014	0.00048596	[1320] 	
00000015	0.00048596	[1320]  WAVEFORMATEX :	
00000016	0.00048596	[1320]  wFormatTag : 	
00000017	0.00052568	[1320] WAVE_FORMAT_EXTENSIBLE	
00000018	0.00058232	[1320] 	
00000019	0.00058232	[1320] cbSize : 22 	
00000020	0.00058232	[1320] nAvgBytesPerSec : 576000 	
00000021	0.00058232	[1320] Channels : 6 	
00000022	0.00058232	[1320] Bits per sample : 16 	
00000023	0.00058232	[1320]  Samples per second : 48000 	
00000024	0.00058232	[1320]  nBlockAlign : 12	
00000025	0.00058232	[1320]  	
00000026	0.00062584	[1320] CMpcAudioRenderer::CheckAudioClient	
00000027	0.00066744	[1320] CMpcAudioRenderer::GetDefaultAudioDevice	
00000028	0.00150780	[1320] CMpcAudioRenderer::CreateAudioClient	
00000029	0.00175144	[1320] CMpcAudioRenderer::CreateAudioClient success	
00000030	0.00537300	[1320] CMpcAudioRenderer::CheckMediaType WASAPI client refused the format	
00000031	0.00562496	[1320] CMpcAudioRenderer::CheckMediaType	
00000032	0.00569360	[1320] Media Type Structure	
00000033	0.00569360	[1320]  Format type : 	
00000034	0.00569360	[1320]  	
00000035	0.00575496	[1320] Sub type : 	
00000036	0.00575496	[1320]
Skinleech is offline   Reply With Quote
Reply

Tags
ffdshow, ffdshow tryouts, ffdshow-mt, ffplay, icl

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 13:11.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2017, vBulletin Solutions Inc.