Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > General > Audio encoding

Reply
 
Thread Tools Search this Thread Display Modes
Old 25th November 2008, 22:32   #7141  |  Link
bigotti5
Spielberger
 
bigotti5's Avatar
 
Join Date: Feb 2005
Posts: 837
Quote:
Ok, good to know. But how is it done with 60i video and movie content? I guess with 60i video there are also always 2 fields for one PTS timestamp? So I'd have to use 33.366ms, right?
Imho yes
Quote:
How about movies with pulldown flags? 41.70833ms or 33.366ms?
Never 41.70833
Frame duration in pulldowned videos is always 33.366 ms.
bigotti5 is offline   Reply With Quote
Old 25th November 2008, 22:52   #7142  |  Link
madshi
Registered Developer
 
Join Date: Sep 2006
Posts: 8,757
Quote:
Originally Posted by bigotti5 View Post
Imho yes
Ok, thanks. Will fix that problem in the next build.
madshi is offline   Reply With Quote
Old 26th November 2008, 12:29   #7143  |  Link
bigotti5
Spielberger
 
bigotti5's Avatar
 
Join Date: Feb 2005
Posts: 837
I did a test counting video frames and audio frames in one of my cam files.

Video frames: 1495 (2990 fields) = 59.800 sec | eac3to: 2988 = 59.760 sec
Audio frames: 1869 = 59.808 | eac3to: 1868 = 59.776

eac3to reports 28 ms overlapping

Concatenating this clip e.g five times results in 14948 fields reported by eac3to (2988*5 = 14940)
bigotti5 is offline   Reply With Quote
Old 26th November 2008, 12:50   #7144  |  Link
madshi
Registered Developer
 
Join Date: Sep 2006
Posts: 8,757
Quote:
Originally Posted by bigotti5 View Post
I did a test counting video frames and audio frames in one of my cam files.

Video frames: 1495 (2990 fields) = 59.800 sec | eac3to: 2988 = 59.760 sec
Audio frames: 1869 = 59.808 | eac3to: 1868 = 59.776

eac3to reports 28 ms overlapping

Concatenating this clip e.g five times results in 14948 fields reported by eac3to (2988*5 = 14940)
Hmmmm... eac3to can not be sure whether the last PES packets are complete (some streams have wrong length information in the headers, so eac3to is ignoring the length field in the PES headers). Because of that reason the last video and audio frame is currently ignored. However, if you concatenate multiple m2ts files via "+" in the command line, the last video and audio frame in each file should NOT be ignored. In other words: I don't understand why eac3to behaves that way. Can you (once again) upload that sample you tested with? Thanks!
madshi is offline   Reply With Quote
Old 26th November 2008, 13:16   #7145  |  Link
bigotti5
Spielberger
 
bigotti5's Avatar
 
Join Date: Feb 2005
Posts: 837
Quote:
Because of that reason the last video and audio frame is currently ignored.
If so it should report 16 ms (59.760 <-> 59.776)

edit:
Quote:
via "+" in the command line, the last video and audio frame in each file should NOT be ignored.
then 14948 is correct

Last edited by bigotti5; 26th November 2008 at 13:35.
bigotti5 is offline   Reply With Quote
Old 26th November 2008, 13:35   #7146  |  Link
madshi
Registered Developer
 
Join Date: Sep 2006
Posts: 8,757
Quote:
Originally Posted by bigotti5 View Post
If so it should report 16 ms (59.760 <-> 59.776)
Well, the current eac3to build adds 20ms to the last video PTS for PAL interlaced content when concatenating 2 clips (as I said, will be fixed in the next build). So I'd expect eac3to to report 36ms. Don't know why it ends up with 28ms. How long is that clip you're talking about? Can you upload it for me to check out?
madshi is offline   Reply With Quote
Old 26th November 2008, 14:03   #7147  |  Link
bigotti5
Spielberger
 
bigotti5's Avatar
 
Join Date: Feb 2005
Posts: 837
Misunderstanding.....16 ms is for the single file.
Concatenating does not ignore each last frame, 8 ms will be correct - adding 20 ms results in 28 ms.
So next build will fix this, thx.

Here is the sample (75 mb)
bigotti5 is offline   Reply With Quote
Old 26th November 2008, 14:30   #7148  |  Link
madshi
Registered Developer
 
Join Date: Sep 2006
Posts: 8,757
Quote:
Originally Posted by bigotti5 View Post
Misunderstanding.....16 ms is for the single file.
Concatenating does not ignore each last frame, 8 ms will be correct - adding 20 ms results in 28 ms.
So next build will fix this, thx.

Here is the sample (75 mb)
Yep, eac3to reports 2988 frames for the single file and 5978 (= 2990 + 2988) frames, if I use "sample.mts+sample.mts". So it works as intended. And my latest (work in progress) sources report 8ms for each overlap...
madshi is offline   Reply With Quote
Old 27th November 2008, 14:57   #7149  |  Link
cavediver
Registered User
 
Join Date: Sep 2008
Posts: 29
I have figured out how to mux seemlessly branched blu-ray's to mkv using eac3to and how to create truehd, pcm and ac3 audio tracks with eac3to. But what I haven't figured out is how to put them all back together into an mkv. I've tried using both Haali and Mkvtoolnix to put both the video file and audio files into an mkv, but both indicate that the pcm and thd+ac3 audio files are not supported media files. I've been successful using tsmuxer to put the files back together, but the truehd tracks won't play in my PCH A-110 even after remuxing with txremux. So, how do I put all of the files I've created using eac3to into an mkv container?
cavediver is offline   Reply With Quote
Old 27th November 2008, 16:03   #7150  |  Link
mikeathome
Registered User
 
Join Date: Nov 2001
Posts: 425
Downsampling AAC

Hi,
might have been reported already, did not read thru all 358 posts ;-)

Downsampling 6ch AAC to 2 ch AAC did not work for me. Created a 6ch ACC instead (= did nothing)

CMDLine: eac3to 6ch.aac 2ch.aac -down2

Am I missing something?

mike
mikeathome is offline   Reply With Quote
Old 27th November 2008, 18:15   #7151  |  Link
jmonier
Registered User
 
Join Date: Oct 2008
Posts: 160
Quote:
Originally Posted by cavediver View Post
I have figured out how to mux seemlessly branched blu-ray's to mkv using eac3to and how to create truehd, pcm and ac3 audio tracks with eac3to. But what I haven't figured out is how to put them all back together into an mkv. I've tried using both Haali and Mkvtoolnix to put both the video file and audio files into an mkv, but both indicate that the pcm and thd+ac3 audio files are not supported media files. I've been successful using tsmuxer to put the files back together, but the truehd tracks won't play in my PCH A-110 even after remuxing with txremux. So, how do I put all of the files I've created using eac3to into an mkv container?
As I understand it, mkv does not support pcm or thd. For a lossless audio stream you need to convert them to flac. Or you can convert them to straight ac3.
jmonier is offline   Reply With Quote
Old 27th November 2008, 18:45   #7152  |  Link
Skinleech
A.K.A Mangoat
 
Join Date: Nov 2002
Posts: 203
Hhhm. I've not seen this message before, using Arcsoft to decode:

Code:
M2TS, 1 video track, 2 audio tracks, 4 subtitle tracks, 2:03:59
1: Chapters, 10 chapters
2: h264/AVC, 1080p24 /1.001 (16:9)
3: AC3, English, 5.1 channels, 640kbps, 48khz
4: DTS Master Audio, English, 7.1 (strange setup) channels, 24 bits, 48khz
   (core: DTS, 5.1 channels, 24 bits, 1509kbps, 48khz)
5: Subtitle (PGS), Swedish
6: Subtitle (PGS), Danish
7: Subtitle (PGS), Norwegian
8: Subtitle (PGS), Finnish
Creating file "f:\sin.txt"...
CAUTION: Decoding this track with ArcSoft results in low volume.
[a04] Extracting audio track number 4...
[v02] Extracting video track number 2...
[v02] Muxing video to Matroska...
[a04] Decoding with ArcSoft DTS Decoder...
[a04] Encoding FLAC with libFlac...
[a04] Creating file "f:\sin.flac"...
[a04] The last DTS frame is incomplete and thus gets skipped.
[a04] The original audio track has a constant bit depth of 24 bits.
Added fps value to MKV header.
Video track 2 contains 178367 frames.
eac3to processing took 57 minutes, 10 seconds.
Done.
Sonic doesn't apply that error message, but I can only get 5.1 channels via that. Any idea? Thanks in advance.
Skinleech is offline   Reply With Quote
Old 27th November 2008, 19:35   #7153  |  Link
madshi
Registered Developer
 
Join Date: Sep 2006
Posts: 8,757
Quote:
Originally Posted by cavediver View Post
both indicate that the pcm and thd+ac3 audio files are not supported media files.
MKV doesn't support TrueHD (yet?). You can use either FLAC or PCM. MKV does support PCM, but muxing it with mkvtoolnix only works through WAV. So you need to ask eac3to to create a WAV file and then mux that with mkvtoolnix. I don't know if mkvtoolnix can handle WAV files bigger than 2GB (4GB), though.

Quote:
Originally Posted by mikeathome View Post
Downsampling 6ch AAC to 2 ch AAC did not work for me. Created a 6ch ACC instead (= did nothing)
That's a bug. Will be fixed in the next build. For now you can work around it by first doing "eac3to source.ac3 temp.wav -down2 -full" and then in an extra step "eac3to temp.wav dest.aac".

Quote:
Originally Posted by Skinleech View Post
I've not seen this message before
Just do a search on this thread for the very warning message and you'll find the explanation you're looking for. (And maybe next time you can do that before posting... )
madshi is offline   Reply With Quote
Old 27th November 2008, 19:44   #7154  |  Link
Skinleech
A.K.A Mangoat
 
Join Date: Nov 2002
Posts: 203
Quote:
Originally Posted by madshi View Post
Just do a search on this thread for the very warning message and you'll find the explanation you're looking for. (And maybe next time you can do that before posting... )
Thanks. I did try searching, and it only brought up the 7000+ reply thread, not the posts related to the error.

I'll try again.

EDIT: Got it now; for some reason I didn't have the 'search this thread' option before, but it's there now.

Last edited by Skinleech; 27th November 2008 at 19:46.
Skinleech is offline   Reply With Quote
Old 27th November 2008, 21:21   #7155  |  Link
itsancho
Registered User
 
Join Date: Jan 2004
Location: Sofia, Bulgaria
Posts: 29
Quote:
Originally Posted by madshi View Post
MKV doesn't support TrueHD (yet?). You can use either FLAC or PCM. MKV does support PCM, but muxing it with mkvtoolnix only works through WAV. So you need to ask eac3to to create a WAV file and then mux that with mkvtoolnix. I don't know if mkvtoolnix can handle WAV files bigger than 2GB (4GB), though.
yep!
Quote:
2008-05-15 Moritz Bunkus <moritz@bunkus.org>

* mkvmerge: new feature: Improved support for WAV files bigger
than 4 GB which only contain a single DATA chunk and a wrong
length field for this DATA chunk (e.g. eac3to creates such files).
and i'm waiting for TrueHD support, too...

Last edited by itsancho; 27th November 2008 at 21:24.
itsancho is offline   Reply With Quote
Old 27th November 2008, 21:23   #7156  |  Link
Jeff Flowerday
Registered User
 
Join Date: Aug 2008
Location: Calgary, AB
Posts: 150
Question for madshi or anyone smart like him:

SD DVDs with a mpeg2 video stream that is a combination of progressive and interlaced. I've seen it numerous times when I try to strip the pulldown flag. Just wondering what's going on, is there an acutal frame rate change? I assumed DVDs were all progressive on the source by nature.
Jeff Flowerday is offline   Reply With Quote
Old 27th November 2008, 21:37   #7157  |  Link
gillie
Registered User
 
Join Date: Oct 2007
Posts: 13
No video on .ts files processed with eac3to

Hoping someone can help.
I've been using the following process to produce .ts files of Blu-Ray rips which I can then play via my TVix M6500 "media streamer".

1. Rip Blu-ray disc to hard disk with AnyDVD HD
2. Use eac3to to extract video to .mkv and the audio to .dts or .ac3
3. Use tsMuxeR GUI to create .ts file container the video and audio streams

This process has worked fine for weeks but has now started creating a .ts file which has either no video playback or corrupted video playback. The audio is fine.

If I use tsMuxeR to extract the video and audio directly from the Blu-ray hard disk copy then the .ts file works okay. But using this method I'm unable to modify the audio output. My preference is to extract the lossless audio stream to DTS using eac3to and Surcode DTS encoder.

If I use MKVmerge to create a .mkv file of the same streams the output is fine, but my TviX box is rubbish with large .mkv files with high bit rates so this isn't an option for me.

Also tried using eac3to to extract the video to an elementary stream (.h264) then tsmuxed the streams into a .ts file and all works fine.

Looking at the mediainfo details for the .ts files which don't work it looks like something odd is going on. The "duration" of the .ts file is twice what it should be. But the individual .mkv and .dts files both have the correct duration. Think it may be the latest versions of eac3to which are producing odd .mkv files.

Would welcome anyones thoughts on this one.
gillie is offline   Reply With Quote
Old 27th November 2008, 22:36   #7158  |  Link
xkodi
Registered User
 
Join Date: Aug 2002
Posts: 221
so, the studios are now using the DTS-HD MA 7.1 tracks with the "strange setup" on real movies too and not only on some BD demos.
xkodi is offline   Reply With Quote
Old 27th November 2008, 22:40   #7159  |  Link
madshi
Registered Developer
 
Join Date: Sep 2006
Posts: 8,757
Quote:
Originally Posted by Jeff Flowerday View Post
SD DVDs with a mpeg2 video stream that is a combination of progressive and interlaced. I've seen it numerous times when I try to strip the pulldown flag. Just wondering what's going on, is there an acutal frame rate change? I assumed DVDs were all progressive on the source by nature.
This is a complicated topic. MPEG2 streams can be encoded as separate interlaced fields or as frames. A frame doesn't have to be progressive. It's very much possible to encode two interlaced fields in one frame. So even if an MPEG2 stream consists of frames, it can still be interlaced in nature. Now on top of that you can build the MPEG2 bitstream in such a way that only 24 frames per second are actually encoded, but the stream still plays at 60i, because there are flags in the stream which tell the decoder which fields are supposed to be repeated to do the 48i -> 60i pulldown.

In real life you can not trust the DVD bitstream encoding. You can not trust MPEG2 broadcasts, either. Both often switch between all the various bitstream encoding formats (60 interlaced fields, 30 frames, 24 frames with pulldown flags). Even if you have a stream with 24 frames and pulldown flags throughout the whole DVD, you still cannot always trust that everything is progressive. It's still possible that the wrong fields were encoded together into frames or that the pulldown flags are plain wrong. Because of this a good DVD player usually ignores all this stuff and simply decodes the stream as 60i and then uses a real video processing chip (e.g. HQV Reon) to figure out which of the fields belong together by analyzing the actual image content of all the fields.

So IMHO DVDs should never be treated as being progressive - unless you know for a fact that they are encoded perfectly.

Quote:
Originally Posted by gillie View Post
Looking at the mediainfo details for the .ts files which don't work it looks like something odd is going on. The "duration" of the .ts file is twice what it should be. But the individual .mkv and .dts files both have the correct duration.
If the individual mkv and dts files seem to work correct on their own then why do you think the problem has anything to do with eac3to? It seems that the files produced by eac3to work perfectly fine on their own, but the TS file produced by tsMuxeR does not. So this looks like a tsMuxeR bug to me. And that's going to be my stance - unless you can find some evidence that something is wrong with the MKV and/or audio files produced by eac3to.

Quote:
Originally Posted by xkodi View Post
so, the studios are now using the DTS-HD MA 7.1 tracks with the "strange setup" on real movies too and not only on some BD demos.
It seems so. I'm not sure how many different movies are out there with such tracks, but at least one movie is. Unfortunately I'm not in a position to fix this. It's technically too complicated. The only proper solution would be for people who have licensed ArcSoft and who own such a problematic 7.1 Blu-Ray disc to report the problem to ArcSoft and ask them for a DTS-HD decoder fix.
madshi is offline   Reply With Quote
Old 27th November 2008, 23:10   #7160  |  Link
rica
Registered User
 
Join Date: Mar 2008
Posts: 2,021
gillie ,
Haali and TSMuxer do not like VC1mkvs.
If your final container will be a TS, i'd advise this way:

Demux vc1 and audio with eac3to and remux to ts with TSMuxer.


If your final container will be an mkv, i'd advise this way:

Demux vc1 and audio with eac3to.
Open your vc1 with TSMuxer and remux into a ts container.
Convert ts to mkv with Graphstudio:
Code:
Haali splitter > Haali matroska muxer
Open this mkv file with MkvMergeGui and remux it with audio into an mkv.

(MkvMerge gui doesn't recognize raw vc1; so you have to convert it to mkv.
Haali splitter doesn't recognize vc1; so you have to convert it to ts)
rica is offline   Reply With Quote
Reply

Tags
eac3to

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 02:51.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.