Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > Hardware & Software > Software players

Closed Thread
 
Thread Tools Search this Thread Display Modes
Old 2nd November 2008, 12:49   #4581  |  Link
LigH
German doom9/Gleitz SuMo
 
LigH's Avatar
 
Join Date: Oct 2001
Location: Germany, rural Altmark
Posts: 6,721
The more I read of new MPC-HC features and private builds, the more I wonder why just SourceForge does not provide regularly updated releases...
__________________

New German Gleitz board
MediaFire: x264 | x265 | VPx | AOM | Xvid
LigH is offline  
Old 2nd November 2008, 15:06   #4582  |  Link
Miryan
Registered User
 
Join Date: Sep 2007
Location: Hungary
Posts: 87
Quote:
Originally Posted by LigH View Post
The more I read of new MPC-HC features and private builds, the more I wonder why just SourceForge does not provide regularly updated releases...
Because the developers does not upload the files to sforge, because of the early stage of the program.
Miryan is offline  
Old 2nd November 2008, 16:24   #4583  |  Link
Keiyakusha
契約者
 
Keiyakusha's Avatar
 
Join Date: Jun 2008
Posts: 1,576
Quote:
Originally Posted by Casshern View Post
to Haxor2099:
WinXP + DXVA + VMR9 -> leads to sporadic garbled video, jumping frames and corruption. It it not clear whether the bug is in Microsofts VMR9 (for XP), ATIs Catalyst driver or is an initialisation issue, but its a "known" bug.
Known solutions: Use VMR7 Windowless or upgrade to VISTA

regards,

Casshern

Using EVR custom on XP - isn't solution for ATI? For me on XP SP3 and nvidia card it works.

Last edited by Keiyakusha; 2nd November 2008 at 16:28.
Keiyakusha is offline  
Old 2nd November 2008, 16:58   #4584  |  Link
alexins
MPC-BE DEV
 
alexins's Avatar
 
Join Date: Mar 2008
Location: Slovenija
Posts: 584
Media Player Classic HomeCinema (x86), svn 853
Media Player Classic HomeCinema (x64), svn 853

Supported languages: CN, CZ, DE, ES, FR, HU, IT, KR, PL, RU, SK, TR, UA

Changes log

FIXED : support for H264 interlaced video for DXVA decoder.
__________________
Win11 x64, i7 8700K 5Ghz, ASUS MAXIMUS X HERO, G.Skill (2x8GB) Trident Z F4-3600C16D-16GTZ, RX 5700,TV Philips 43PUS6703/12, Zappiti 4K HDR
Media Player Classic - BE x86/x64. Team of developers.
alexins is offline  
Old 2nd November 2008, 17:51   #4585  |  Link
raynor
Registered User
 
raynor's Avatar
 
Join Date: May 2007
Posts: 42
Quote:
Originally Posted by LigH View Post
The more I read of new MPC-HC features and private builds, the more I wonder why just SourceForge does not provide regularly updated releases...
Add my vote for another "regular" SourceForge release soon ...
It's time to spread the goodness
raynor is offline  
Old 2nd November 2008, 19:22   #4586  |  Link
haxor2099
Yoo!
 
haxor2099's Avatar
 
Join Date: Apr 2008
Posts: 21
Quote:
Originally Posted by Keiyakusha View Post
Using EVR custom on XP - isn't solution for ATI? For me on XP SP3 and nvidia card it works.
EVR mode doesnt allow DXVA as far I remember....

at least on XP...
haxor2099 is offline  
Old 2nd November 2008, 19:37   #4587  |  Link
Kado
Otaku
 
Kado's Avatar
 
Join Date: Sep 2006
Location: Portugal
Posts: 576
@alexins , Casimir
DXVA is broken in MPC HC rev853, every h264 DXVA compatible video produces green screen, even the Haruhi video I provided that is DXVA compatible.
MPC HC rev 849 does not have this issue.

Vista SP1 32bit
9800GTX 180.43
DirectX August 2008
__________________
In the school, the three guys met. Their relation had been changed in the season, and turned into three love stories.
Kado is offline  
Old 2nd November 2008, 20:19   #4588  |  Link
Casimir666
Registered User
 
Join Date: Jan 2007
Posts: 455
Quote:
Originally Posted by Kado View Post
@alexins , Casimir
DXVA is broken in MPC HC rev853, every h264 DXVA compatible video produces green screen, even the Haruhi video I provided that is DXVA compatible.
MPC HC rev 849 does not have this issue.

Vista SP1 32bit
9800GTX 180.43
DirectX August 2008
Is it fixed with this build ?
http://rapidshare.com/files/16003197...1_854.rar.html
__________________
Tired of tearing?
Try this Media Player Classic mod : http://mpc-hc.sourceforge.net
Casimir666 is offline  
Old 2nd November 2008, 20:30   #4589  |  Link
Keiyakusha
契約者
 
Keiyakusha's Avatar
 
Join Date: Jun 2008
Posts: 1,576
Quote:
Originally Posted by haxor2099 View Post
EVR mode doesnt allow DXVA as far I remember....

at least on XP...
So... when I set EVR custom and enable h264/AVC (DXVA) checkbox, MPC-HC uses some other renderer?
Keiyakusha is offline  
Old 2nd November 2008, 20:39   #4590  |  Link
Kado
Otaku
 
Kado's Avatar
 
Join Date: Sep 2006
Location: Portugal
Posts: 576
Quote:
Originally Posted by Casimir666 View Post
Yes it is!

@Keiyakusha
No, it just don't use DXVA but use EVR CP, you see DXVA has some rules in order to work like limited reference frames, etc, in your video but you can always force DXVA utilization but I don't remember the registry setting, maybe Casimir does remember?

This is a nice sample to test DXVA, Haruhi video.

[EDIT]Remember that forcing DXVA will result in unexpected behavior like green screen , macroblocks, etc, also even when DXVA is forced the renderer must support DXVA (forcing just bypasses the DXVA rules) and if you're using XP you must use VMR9 renderless, overlay mixer, etc, but with overlay mixer the internal subtitle renderer does not work. Use CTRL + J to see the status.[/EDIT]
__________________
In the school, the three guys met. Their relation had been changed in the season, and turned into three love stories.

Last edited by Kado; 2nd November 2008 at 20:47.
Kado is offline  
Old 2nd November 2008, 20:57   #4591  |  Link
Snowknight26
Registered User
 
Join Date: Aug 2007
Posts: 1,429
With r849 and a 1080i 25fps stream, the H.264 decoder would output NV12 to the renderer (EVR), play it back at 50fps, and would drop 50% of the frames, effectively making it 1080p 25fps stream because of my video card's deinterlacing.
With r853, the H.264 decoder outputs NV12 to the renderer, plays it back at 25fps (dropping 0% of the frames), but it still displayed as interlaced.

Small sample: http://www.stfcc.org/misc/00000.cut.m2ts

Last edited by Snowknight26; 2nd November 2008 at 21:06.
Snowknight26 is offline  
Old 2nd November 2008, 21:23   #4592  |  Link
Shinigami-Sama
Solaris: burnt by the Sun
 
Shinigami-Sama's Avatar
 
Join Date: Oct 2004
Location: /etc/default/moo
Posts: 1,923
Quote:
Originally Posted by Keiyakusha View Post
So... when I set EVR custom and enable h264/AVC (DXVA) checkbox, MPC-HC uses some other renderer?
it just doesn't use dxva
__________________
Quote:
Originally Posted by benjust View Post
interlacing and telecining should have been but a memory long ago.. unfortunately still just another bizarre weapon in the industries war on image quality.
Shinigami-Sama is offline  
Old 2nd November 2008, 21:29   #4593  |  Link
alexins
MPC-BE DEV
 
alexins's Avatar
 
Join Date: Mar 2008
Location: Slovenija
Posts: 584
Media Player Classic HomeCinema (x86), svn 855

Supported languages: CN, CZ, DE, ES, FR, HU, IT, KR, PL, RU, SK, TR, UA

Changes log

Fix : broken DXVA with nVidia boards.
__________________
Win11 x64, i7 8700K 5Ghz, ASUS MAXIMUS X HERO, G.Skill (2x8GB) Trident Z F4-3600C16D-16GTZ, RX 5700,TV Philips 43PUS6703/12, Zappiti 4K HDR
Media Player Classic - BE x86/x64. Team of developers.
alexins is offline  
Old 2nd November 2008, 22:34   #4594  |  Link
Mercury_22
Registered User
 
Join Date: Dec 2007
Posts: 1,138
Quote:
Originally Posted by alexins View Post
Media Player Classic HomeCinema (x86), svn 855

Supported languages: CN, CZ, DE, ES, FR, HU, IT, KR, PL, RU, SK, TR, UA

Changes log

Fix : broken DXVA with nVidia boards.
Can you compile a 64-bit too ? and standalone filters x64 ? PLEASE !
__________________
Intel UHD Graphics 750; Win 10 22H2
Mercury_22 is offline  
Old 2nd November 2008, 23:36   #4595  |  Link
Keiyakusha
契約者
 
Keiyakusha's Avatar
 
Join Date: Jun 2008
Posts: 1,576
Quote:
Originally Posted by Shinigami-Sama View Post
it just doesn't use dxva
Then why CPU load is around 3% on 1080p and it says "DXVA mode: H264 bitstream decoder, no FGT"? Because it uses some other renderer "Video Renderer" instead.
Keiyakusha is offline  
Old 3rd November 2008, 00:18   #4596  |  Link
Shinigami-Sama
Solaris: burnt by the Sun
 
Shinigami-Sama's Avatar
 
Join Date: Oct 2004
Location: /etc/default/moo
Posts: 1,923
Quote:
Originally Posted by Keiyakusha View Post
Then why CPU load is around 3% on 1080p and it says "DXVA mode: H264 bitstream decoder, no FGT"? Because it uses some other renderer "Video Renderer" instead.
maybe its just ATI specific that it doesn't work in EVR then
__________________
Quote:
Originally Posted by benjust View Post
interlacing and telecining should have been but a memory long ago.. unfortunately still just another bizarre weapon in the industries war on image quality.
Shinigami-Sama is offline  
Old 3rd November 2008, 03:26   #4597  |  Link
IanD
Registered User
 
Join Date: Jun 2003
Location: Australia
Posts: 190
Quote:
Originally Posted by alexins View Post
Media Player Classic HomeCinema (x86), svn 855

Fix : broken DXVA with nVidia boards.
With previous MPC-HC revisions, BBC HD played with Nvidia 8600GT XP and DXVA enabled, resulted in constant jumping backwards of forward motion.

With r855, motion is generally now smooth, however it jumps back and pixelates briefly, consistently, every 4 seconds.

If I disable DXVA in MPC-HC and use the internal decoder, motion is perfectly smooth but CPU usage is 5x greater.

It's not dependent on screen refresh (does it at 72/75Hz) or IVTC enabled/disabled or Haali/internal splitter or the renderer.

DXVA is getting better, but there are still some pervasive incompatibilities with Nvidia.
IanD is offline  
Old 3rd November 2008, 03:44   #4598  |  Link
haxor2099
Yoo!
 
haxor2099's Avatar
 
Join Date: Apr 2008
Posts: 21
Quote:
Originally Posted by Shinigami-Sama View Post
maybe its just ATI specific that it doesn't work in EVR then
maybe Keiyasha as a DXVA2 enabled hardware, such as the ATI 4XXX series.
Im on a HD3870 (of the first revisions )
from Sapphire.


ill do a few more tests with EVR...

*edit*
using latest version of HomeCinema and various EVR options, and nope, it just doesnt work on my ATI

Last edited by haxor2099; 3rd November 2008 at 03:51.
haxor2099 is offline  
Old 3rd November 2008, 05:00   #4599  |  Link
Keiyakusha
契約者
 
Keiyakusha's Avatar
 
Join Date: Jun 2008
Posts: 1,576
Quote:
Originally Posted by haxor2099 View Post
maybe Keiyasha as a DXVA2 enabled hardware, such as the ATI 4XXX series.
Im on a HD3870 (of the first revisions )
from Sapphire.


ill do a few more tests with EVR...

*edit*
using latest version of HomeCinema and various EVR options, and nope, it just doesnt work on my ATI
Sorry for bad English... I'm afraid we not completely understand each other.

Well, as I said for first time, I have nvidia card and "works EVR+DXVA+XP on ATI or not" - I don't know, this is my question.

If you sure that with nvidia card (+last drivers) + XP SP3 + .NET 3.5 + EVRcustom in settings + DXVA in transform filters ==> DXVA shouldnt be used, then what happens to me? Or it actually works, or MPC-HC uses another renderer without any notifying. If it is normal behavior - then sorry again, because its not described anywhere in settings.
Keiyakusha is offline  
Old 3rd November 2008, 06:07   #4600  |  Link
Aleksoid1978
Registered User
 
Aleksoid1978's Avatar
 
Join Date: Apr 2008
Location: Russia, Vladivostok
Posts: 2,780
To ALL about icons :
First: If someone does not want to use icons from the library, you can simply delete mpciconlib.dll;
Two: I made mpciconlib.dll and include all icons in project, each icon corresponds to a specific type on page Formats (each format may include several extensions).
Here is a list and order types :

("wmv"), _T("wmv wmp wm asf")
("wma"), _T("wma")
("avi"), _T("avi")
("wav"), _T("wav")
("mpg"), _T("mpg mpeg mpe m1v m2v mpv2 mp2v ts tp tpr pva pss m2ts m2t mts evo")
("mpa"), _T("mpa mp2 m1a m2a")
("dvdf"), _T("vob ifo")
("dvda"), _T("ac3 dts")
("mp3"), _T("mp3")
("mid"), _T("mid midi rmi")
("ivf"), _T("ivf")
("aiff"), _T("aif aifc aiff")
("au"), _T("au snd")
("ogm"), _T("ogm ogv")
("ogg"), _T("ogg oga")
("cda"), _T("cda")
("flic"), _T("fli flc flic")
("d2v"), _T("d2v")
("mp4"), _T("mp4 m4v hdmov 3gp 3gpp")
("aac"), _T("m4a m4b aac")
("mkv"), _T("mkv")
("mka"), _T("mka")
("bik"), _T("smk bik")
("ratdvd"),_T("ratdvd")
("roq"), _T("roq")
("rm"), _T("rm ram rpm rmm")
("ra"), _T("ra")
("rt"), _T("rt rp smi smil")
("drc"), _T("drc")
("dsm"), _T("dsm dsv dsa dss")
("mpc"), _T("mpc")
("flac"), _T("flac")
("alac"), _T("alac")
("flv"), _T("flv")
("swf"), _T("swf")
("mov"), _T("mov qt amr 3g2 3gp2")
("jpeg"), _T("jpeg jpg bmp gif pic png dib tiff tif")
("pls"), _T("asx m3u pls wvx wax wmx mpcpl")
("other"),_T("divx vp6 rmvb amv")

(list and order are taken from source)

for sample, in anybody want change icon for .AVI - need replace avi.ico in project OR open mpciconlib.dll in Resource Hacker(or a similar program for editing resources) and replace icon in resource, INDEX 2(index begin from 0(zero))
__________________
AMD Ryzen 5 3600 /GIGABYTE B450 Gaming X /AMD Radeon R9 16Gb@3200 /Kingston 500Gb M.2 /RTX 4060 /Samsung U28R550UQI /OLED Philips 55OLED707 /Yamaha RX-V471 + NS-555 + NS-C444 + NS-333 + YST-SW215
Aleksoid1978 is offline  
Closed Thread

Tags
dxva, h264, home cinema, media player classic, mpc-hc

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 22:33.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2024, vBulletin Solutions Inc.