Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > Hardware & Software > Software players

Closed Thread
 
Thread Tools Search this Thread Display Modes
Old 19th May 2008, 11:24   #1981  |  Link
baadnewz
Registered User
 
Join Date: May 2008
Posts: 7
can some one compile the lastest build in 64 bit?
__________________
Windows 7 x64 , C2D e8400 @ 4.2 GHz, Scythe SCMN-1100, Gigabyte GA-P35-DS3, Mushkin 4x 2GB XP2-6400, 2x500 GB WD, 1x160 WD, His ICEQ 4670, DELL 228WPF + Samsung 32 Inch,Xonar D1
baadnewz is offline  
Old 19th May 2008, 11:35   #1982  |  Link
tetsuo55
MPC-HC Project Manager
 
Join Date: Mar 2007
Posts: 2,317
Quote:
Originally Posted by Aleksoid1978 View Post
i suggest to change it a little bit in the FfmpegContext.c :
if (((nWidth > 720) && (cur_sps->ref_frame_count > (1024*MAX_DPB_41/(nWidth*nHeight*1.5)))) || // HD content, level 4.1
((nWidth <= 720) && (cur_sps->ref_frame_count > (1024*MAX_DPB_31/(nWidth*nHeight*1.5))))) // SD content, level 3.1
return 2; // Too much ref frames

ON

if (((nWidth > 720) && (cur_sps->level_idc == 41) && (cur_sps->ref_frame_count > (1024*MAX_DPB_41/(nWidth*nHeight*1.5)))) || // HD content, level 4.1
((nWidth <= 720) && (cur_sps->level_idc == 31) && (cur_sps->ref_frame_count > (1024*MAX_DPB_31/(nWidth*nHeight*1.5))))) // SD content, level 3.1
return 2; // Too much ref frames

Because do checking ref_frame_count for Level 4.1 and 3.1, but level_idc do not check.

I have many .mkv where ref_frame_count it's ok for Level 4.1, but Level in here is 5.1 and DXVA NOT WORK

Level is ignored on purpose, for better compatibility with mislabeled files, however we should eventually start using this and forcing people to use the correct level_idc in their h264 stream headers
tetsuo55 is offline  
Old 19th May 2008, 13:52   #1983  |  Link
Kado
Otaku
 
Kado's Avatar
 
Join Date: Sep 2006
Location: Portugal
Posts: 575
@casimir666
After some tests mpc hc rev 517 seems to play fewer streams with dxva in comparison to rev 514. Also cyberlink's h264 decoder
works with dxva quite well.

@us1111
Use "Override aspect ratio" to 16:9 or stretch to window. Both are in "View=>Video Frame"

@MarcioAB
You have to be aware that built-in DXVA in mpc is only for h264 video streams so something like "ffdshow+DivX" will never have hardware accelerated video.
Block all filters that open h264 video in mpc extrenal filters then in the internal filters go to transform filters then h264/avc (dxva) check it and double click it, uncheck "enable ffmpeg" and check "enable dxva", that way mpc will show video if the stream can be used by dxva only.

Also mpc only supports dxva2 for h264 meaning that only vista + evr/evr custom presenter will have hw accel video. The dxva in mpc seems to be more compatible with ATI cards rather than NVIDIA ones.

This was using mpc hc rev 514.

Example of a hw accel video:
__________________
In the school, the three guys met. Their relation had been changed in the season, and turned into three love stories.
Kado is offline  
Old 19th May 2008, 16:47   #1984  |  Link
raynor
Registered User
 
raynor's Avatar
 
Join Date: May 2007
Posts: 42
Quote:
Originally Posted by _xxl View Post
@ All
I would like to do a list with all known bugs and issues for MPC-HC and add it to my first post.
Please send me a pm or post it on this thread.
-The colors are "washed-out" with Vista SP1 + EVR-Custom
raynor is offline  
Old 19th May 2008, 17:18   #1985  |  Link
MarcioAB
Registered User
 
MarcioAB's Avatar
 
Join Date: Nov 2005
Posts: 157
Thank you Kado. Working now. Not exactly sure what fixed it. Any way, if I keep ffdshow merit as "ffdshow default", ffdshow will came in anyway. If I decrease the merit (to "prefered" for example), ffdshow will not came in anymore and so MPC filter will came in alone. Yesterday I had no video on that condition, but today it's working.

Quick comments:

Quote:
Originally Posted by Kado View Post
@MarcioAB: Block all filters that open h264 video in mpc extrenal filters ...
Ok, but I never had filters over there (in the external filters).

Quote:
Originally Posted by Kado View Post
then in the internal filters go to transform filters then h264/avc (dxva) check it ...
Ok, but H264/AVC and "enable DXVA" was always checked.

Quote:
Originally Posted by Kado View Post
uncheck "enable ffmpeg"
Hum ... no place to check/uncheck ffmpeg. Using MPC HomeCinema v 1.1.0.0

Quote:
Originally Posted by Kado View Post
Also mpc only supports dxva2 for h264 meaning that only vista + evr/evr custom presenter will have hw accel video.
Hum, XP SP3 over here and working well. 25% cpu usage with MPC-hc with DXVA turned off and only 2% cpu usage with DXVA turned on.

Quote:
Originally Posted by Kado View Post
The dxva in mpc seems to be more compatible with ATI cards rather than NVIDIA ones.
Ok, but GeForce 8600GTS here and working well.
MarcioAB is offline  
Old 19th May 2008, 17:20   #1986  |  Link
tetsuo55
MPC-HC Project Manager
 
Join Date: Mar 2007
Posts: 2,317
I have found a problem with the DXVA selection.

Casimir if i am not mistaken you have added the Pixel Aspect ratio check? It will have to be removed as i have not yet encountered any files with wierd PAR that did not work with DXVA

Please see this example:

http://www.avsforum.com/avs-vb/showp...&postcount=171

EDIT:

It does seemt that the par aspect ratio might not be a problem after all, Please comment out the check until further and more detailed proof is presented

Last edited by tetsuo55; 19th May 2008 at 17:27. Reason: Read the source
tetsuo55 is offline  
Old 19th May 2008, 17:40   #1987  |  Link
MatMaul
Registered User
 
Join Date: Apr 2004
Posts: 402
Quote:
Originally Posted by Kado View Post
@casimir666
After some tests mpc hc rev 517 seems to play fewer streams with dxva in comparison to rev 514. Also cyberlink's h264 decoder
works with dxva quite well.
the only change is to reject non level 3.1 SD streams, but if DXVA can decode level 4.1 for SD too we can remove it.
MatMaul is offline  
Old 19th May 2008, 18:04   #1988  |  Link
MarcioAB
Registered User
 
MarcioAB's Avatar
 
Join Date: Nov 2005
Posts: 157
I think I found the issue with my "no video" yesterday: 5 Reference frames - DXVA seems to not work with 5 Ref frames, only 4 or less.

All the other x264 parms seems to be no problem. Well ... I need to re-encode many things. Before that, is there any other x264 parms restriction ?

Thank you.
MarcioAB is offline  
Old 19th May 2008, 18:06   #1989  |  Link
Casimir666
Registered User
 
Join Date: Jan 2007
Posts: 455
Quote:
Originally Posted by Kado View Post
@casimir666
After some tests mpc hc rev 517 seems to play fewer streams with dxva in comparison to rev 514. Also cyberlink's h264 decoder
works with dxva quite well.
Do you mean it play with "No DXVA" or it didn't play at all?

Quote:
Originally Posted by tetsuo55 View Post
Casimir if i am not mistaken you have added the Pixel Aspect ratio check? It will have to be removed as i have not yet encountered any files with wierd PAR that did not work with DXVA
There is a check on SAR field present in H264 header, but you are right 90% of my samples with weird SAR works with DXVA. Only one is correctly blacklist by this test, so I aggree with you it should be removed.
__________________
Tired of tearing?
Try this Media Player Classic mod : http://mpc-hc.sourceforge.net
Casimir666 is offline  
Old 19th May 2008, 18:06   #1990  |  Link
djrh
Registered User
 
Join Date: Feb 2008
Posts: 8
I have a problem opening a stream from DVBDream in MPC HC (in XP 32bit).

It worked fine up until 3-4 days ago, but all of a sudden it stopped working. DVBDream will bring up MPC, but it will remain at "Opening" and no video will come up. MPC would use 50% CPU, and the only way to stop it is to kill it in task manager.

I deleted the registry sttings for MPC and reinstalled DVBDream, however, I still have the same problem. Note that I have dualboot with Vista, and MPC plays all the stream fine in Vista.

This is the command line in DVBDREam:
/add "udp://127.0.0.1:1234" /play

Same things happen if I do File- Open - udp://127.0.0.1:1234

anyone?

Last edited by djrh; 19th May 2008 at 18:09.
djrh is offline  
Old 19th May 2008, 19:48   #1991  |  Link
Motenai Yoda ^.^
Registered User
 
Join Date: Jan 2008
Location: Italy
Posts: 10
mirror mpc 518
http://www.mediafire.com/?uuzdy1mgdh9

can someone build an p4/p5 optimized version?
Motenai Yoda ^.^ is offline  
Old 19th May 2008, 20:31   #1992  |  Link
chros
Registered User
 
chros's Avatar
 
Join Date: Mar 2002
Posts: 1,001
Quote:
Originally Posted by _xxl View Post
@ All
I would like to do a list with all known bugs and issues for MPC-HC and add it to my first post.
Please send me a pm or post it on this thread.
http://forum.doom9.org/showthread.ph...85#post1124285

Thanks
chros is offline  
Old 19th May 2008, 20:31   #1993  |  Link
Casimir666
Registered User
 
Join Date: Jan 2007
Posts: 455
Quote:
Originally Posted by baadnewz View Post
can some one compile the lastest build in 64 bit?
I have uploaded r517 for x64 here : http://www.zshare.net/download/12268144e4b3a2b2/
__________________
Tired of tearing?
Try this Media Player Classic mod : http://mpc-hc.sourceforge.net
Casimir666 is offline  
Old 19th May 2008, 21:53   #1994  |  Link
Kado
Otaku
 
Kado's Avatar
 
Join Date: Sep 2006
Location: Portugal
Posts: 575
@casimir666
Using xxl build rev 518 the files are played with dxva again but with your build rev 517 mpc failed to render the video, only audio was played because I disabled ffmpeg and left dxva enabled, the internal ffmpeg decoder decoded the video properly. Basically it played with "no DXVA" with your build.

Also check this situation (corrupted video):
mpc hc internal dxva
mpc dxva via cyberlink's decoder

@MarcioAB
Use recent builds. Compiled builds here and changelog here.
__________________
In the school, the three guys met. Their relation had been changed in the season, and turned into three love stories.
Kado is offline  
Old 19th May 2008, 22:18   #1995  |  Link
Casimir666
Registered User
 
Join Date: Jan 2007
Posts: 455
Quote:
Originally Posted by Kado View Post
Also check this situation (corrupted video):
mpc hc internal dxva
mpc dxva via cyberlink's decoder
It's a known bug for nVidia cards
__________________
Tired of tearing?
Try this Media Player Classic mod : http://mpc-hc.sourceforge.net
Casimir666 is offline  
Old 19th May 2008, 22:56   #1996  |  Link
Aleksoid1978
Registered User
 
Aleksoid1978's Avatar
 
Join Date: Apr 2008
Location: Russia, Vladivostok
Posts: 1,829
Here 4 short sample where ref_num it is ok for Level 4.1, but file encoded with level 5.1 and when open it, we have "20 fps bug" :

http://www.tosei.ru/isoft/pirates_sample.mkv
http://www.tosei.ru/isoft/shooter_sample.mkv
http://www.tosei.ru/isoft/sw_2_sample.mkv
http://www.tosei.ru/isoft/x3_sample.mkv

Maybe other parameters must see, not only ref_num ???

P.S. - ref_num see here - http://www.avsforum.com/avs-vb/showthread.php?t=972503

Last edited by Aleksoid1978; 19th May 2008 at 23:36.
Aleksoid1978 is online now  
Old 19th May 2008, 23:38   #1997  |  Link
MatMaul
Registered User
 
Join Date: Apr 2004
Posts: 402
build for testing purpose only, which will try to decode with DXVA everything.
http://www.etud.insa-toulouse.fr/~mv..._r518_TEST.zip

@people with DXVA cards, please test this two samples to see if SD decoding is limited to level 3.1 or level 4.1
http://www.etud.insa-toulouse.fr/~mv...pc-hc/SD31.mp4
http://www.etud.insa-toulouse.fr/~mv...pc-hc/SD41.mp4

and also please test the samples provided by Aleksoid1978 and report your findings.
MatMaul is offline  
Old 20th May 2008, 01:38   #1998  |  Link
ericab
Registered User
 
Join Date: Apr 2008
Posts: 86
Quote:
Originally Posted by MatMaul View Post
build for testing purpose only, which will try to decode with DXVA everything.
http://www.etud.insa-toulouse.fr/~mv..._r518_TEST.zip

@people with DXVA cards, please test this two samples to see if SD decoding is limited to level 3.1 or level 4.1
http://www.etud.insa-toulouse.fr/~mv...pc-hc/SD31.mp4
http://www.etud.insa-toulouse.fr/~mv...pc-hc/SD41.mp4

and also please test the samples provided by Aleksoid1978 and report your findings.
hello;
i just tried your test build with a 720p mkv, and the internal MPCHC decoder, and it works!....

kinda..

it says "H.264 bitstream decoder, No FGT", whatever that means, but its only a black screen; video, or audio. it just wont play. it sits there on "Play" and the time doesnt move fwd. im using vmr9 renderless.
ericab is offline  
Old 20th May 2008, 01:42   #1999  |  Link
Kado
Otaku
 
Kado's Avatar
 
Join Date: Sep 2006
Location: Portugal
Posts: 575
@MatMaul
Your test build triggers Execute Disable on my system crashing mpc but xxl rev 518 works and decodes with dxva only the sd3.1 file, the sd4.1 cannot be rendered.
Cyberlink's pdvd8 h264 decoder decodes both with dxva.
With Aleksoid1978 files 2 play corrupted and other 2 play fine with dxva (nvidia).

@ericab
Try build rev 518 hosted here. Also use evr/evr custom presenter.
"H.264 bitstream decoder, No FGT" means that the gpu is decoding the video.
__________________
In the school, the three guys met. Their relation had been changed in the season, and turned into three love stories.

Last edited by Kado; 20th May 2008 at 01:46.
Kado is offline  
Old 20th May 2008, 02:02   #2000  |  Link
Aleksoid1978
Registered User
 
Aleksoid1978's Avatar
 
Join Date: Apr 2008
Location: Russia, Vladivostok
Posts: 1,829
Quote:
Originally Posted by Kado View Post
@MatMaul
With Aleksoid1978 files 2 play corrupted and other 2 play fine with dxva (nvidia).
What file play fine with dxva ??? MPC-HC Decode or Cyberlink ???
Vista or XP ???

Because I play all 4 file on XP, on Cyberlink 7 h264 - DXVA use, but "20fps bug"

P.S. Video - Palit 8800GT 512Mb

Also at evening check on VIsta ...
Aleksoid1978 is online now  
Closed Thread

Tags
dxva, h264, home cinema, media player classic, mpc-hc

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 12:04.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2017, vBulletin Solutions Inc.