Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > Video Encoding > MPEG-4 AVC / H.264

Closed Thread
 
Thread Tools Search this Thread Display Modes
Old 7th June 2007, 19:10   #341  |  Link
Guest
Guest
 
Join Date: Jan 2002
Posts: 21,924
Quote:
Originally Posted by klinika View Post
Installed the vcredist, nada, didn't do anything. No duplicate libavcodecs except the one in ffdshow dir, and that's nowhere near any PATH variables. And test.264 crashes dgavcindex on open too.
Please rename that one, reboot, and try again.
Guest is offline  
Old 7th June 2007, 19:11   #342  |  Link
Guest
Guest
 
Join Date: Jan 2002
Posts: 21,924
Quote:
Originally Posted by xc3ll View Post
Hi neuron2, I tried your program, but get an this error:

[h264 @ 0100700C]Internal error, IDCT permutation not set

when I try encoding w/meGUI, source is a bd disc.
Are you sure it is H.264 and not VC1? If so, please post a source stream fragment that I can use to duplicate the issue.
Guest is offline  
Old 7th June 2007, 20:02   #343  |  Link
Inventive Software
Turkey Machine
 
Join Date: Jan 2005
Location: Lowestoft, UK (but visit lots of places with bribes [beer])
Posts: 1,953
Also be well aware that you have to demux the video stream from the BD files. DGAVCIndex only accepts raw .264 files.
__________________
On Discworld it is clearly recognized that million-to-one chances happen 9 times out of 10. If the hero did not overcome huge odds, what would be the point? Terry Pratchett - The Science Of Discworld
Inventive Software is offline  
Old 8th June 2007, 00:27   #344  |  Link
klinika
Registered User
 
Join Date: Mar 2004
Location: Tampere
Posts: 51
Quote:
Originally Posted by neuron2 View Post
Please rename that one, reboot, and try again.
I'm sorry to say it didn't change a thing... Tried even moving the whole thing to c partition's root, just in case, but that didn't change anything either. Can't think of anything else really, except if there'd be an easy way to debug it.
klinika is offline  
Old 8th June 2007, 01:02   #345  |  Link
Inventive Software
Turkey Machine
 
Join Date: Jan 2005
Location: Lowestoft, UK (but visit lots of places with bribes [beer])
Posts: 1,953
The link to the VC redist neuron posted earlier, try the SP1 update on top of it and see if that helps or not.
__________________
On Discworld it is clearly recognized that million-to-one chances happen 9 times out of 10. If the hero did not overcome huge odds, what would be the point? Terry Pratchett - The Science Of Discworld
Inventive Software is offline  
Old 8th June 2007, 05:05   #346  |  Link
Guest
Guest
 
Join Date: Jan 2002
Posts: 21,924
Is anyone else having this issue with Alpha 6?
Guest is offline  
Old 8th June 2007, 07:47   #347  |  Link
Revgen
Registered User
 
Join Date: Sep 2004
Location: Near LA, California, USA
Posts: 1,543
^ I'll try it tomorrow after I'm done encoding.
__________________
Pirate: Now how would you like to die? Would you like to have your head chopped off or be burned at the stake?

Curly: Burned at the stake!

Moe: Why?

Curly: A hot steak is always better than a cold chop.
Revgen is offline  
Old 8th June 2007, 08:24   #348  |  Link
G_M_C
Registered User
 
Join Date: Feb 2006
Posts: 1,076
Quote:
Originally Posted by neuron2 View Post
Is anyone else having this issue with Alpha 6?
I havent been able to get to testing out this new version. I'll do some testing tonight on a new project.

But my first thought is this (i'm at work right now,so forgive me if i make some mistake in my reasoning );
When i remember correctly the previous versions came with 2(3) separate DLL's. It was advised that you put those DLL's in your
"windows/system" directory. Cant i be that you have forgotten to remove the old DLL's from your "windows/system" directory xc3ll ?

Last edited by G_M_C; 8th June 2007 at 10:52.
G_M_C is offline  
Old 8th June 2007, 08:29   #349  |  Link
ToS_Maverick
x264 Tester
 
Join Date: Dec 2005
Location: Austria, near Vienna
Posts: 223
Quote:
Originally Posted by neuron2 View Post
Is anyone else having this issue with Alpha 6?
I havent been able to test it either, but i've some PAFF streams on my disk, who i'd love to test for you, with a new version
ToS_Maverick is offline  
Old 8th June 2007, 09:20   #350  |  Link
canTsTop
Registered User
 
canTsTop's Avatar
 
Join Date: Apr 2007
Location: Lithuania
Posts: 120
Quote:
Originally Posted by neuron2 View Post
Is anyone else having this issue with Alpha 6?
hello, i get same error like klinika. here is my error log

http://rapidshare.com/files/35905893/error.txt.html
canTsTop is offline  
Old 8th June 2007, 09:23   #351  |  Link
klinika
Registered User
 
Join Date: Mar 2004
Location: Tampere
Posts: 51
Quote:
Originally Posted by Inventive Software View Post
The link to the VC redist neuron posted earlier, try the SP1 update on top of it and see if that helps or not.
Good catch, but it didn't work either..
klinika is offline  
Old 8th June 2007, 09:32   #352  |  Link
klinika
Registered User
 
Join Date: Mar 2004
Location: Tampere
Posts: 51
Quote:
Originally Posted by canTsTop View Post
hello, i get same error like klinika. here is my error log

http://rapidshare.com/files/35905893/error.txt.html
Ah, of course! Dr. Watson to the rescue I have it disabled by default and forgot all about it.

Last edited by klinika; 8th June 2007 at 09:40.
klinika is offline  
Old 8th June 2007, 20:49   #353  |  Link
Revgen
Registered User
 
Join Date: Sep 2004
Location: Near LA, California, USA
Posts: 1,543
I've had no problems with this new version.

Then again I don't have any AVC source from Blu-Ray or HD-DVD.
__________________
Pirate: Now how would you like to die? Would you like to have your head chopped off or be burned at the stake?

Curly: Burned at the stake!

Moe: Why?

Curly: A hot steak is always better than a cold chop.
Revgen is offline  
Old 8th June 2007, 21:40   #354  |  Link
Guest
Guest
 
Join Date: Jan 2002
Posts: 21,924
Quote:
Originally Posted by klinika View Post
Ah, of course! Dr. Watson to the rescue I have it disabled by default and forgot all about it.
Can you get me a Dr. Watson dump as well then, please?
Guest is offline  
Old 8th June 2007, 23:22   #355  |  Link
canTsTop
Registered User
 
canTsTop's Avatar
 
Join Date: Apr 2007
Location: Lithuania
Posts: 120
here is my Dr Watson dump
http://rapidshare.com/files/36034597/Dr_Watson.7z.html
canTsTop is offline  
Old 9th June 2007, 00:43   #356  |  Link
Guest
Guest
 
Join Date: Jan 2002
Posts: 21,924
Quote:
Originally Posted by canTsTop View Post
Thank you.

Can you please try this debug DLL and give me a Dr Watson dump using that? Thanks.

http://neuron2.net/guest/libavcodec.zip
Guest is offline  
Old 9th June 2007, 01:23   #357  |  Link
klinika
Registered User
 
Join Date: Mar 2004
Location: Tampere
Posts: 51
Quote:
Originally Posted by neuron2 View Post
Can you get me a Dr. Watson dump as well then, please?
Uh oh, well I quite suddenly decided to upgrade mobo & cpu, and no more crashing. But the FAULT text (or whatever it read) in the debug log was at the same spot. Sorry for not being able to be of further help in the issue I do hope it gets solved for everyone's benefit though, and more importantly, thank you for the immensely useful program!
klinika is offline  
Old 9th June 2007, 05:11   #358  |  Link
Guest
Guest
 
Join Date: Jan 2002
Posts: 21,924
Quote:
Originally Posted by klinika View Post
Uh oh, well I quite suddenly decided to upgrade mobo & cpu
What was your processor before and after, please?
Guest is offline  
Old 9th June 2007, 05:14   #359  |  Link
Kurth
Registered User
 
Kurth's Avatar
 
Join Date: Mar 2006
Posts: 51
Any .264 file that I try to open on DGAVCIndex Alpha 6 crashes I found that the problem is the libavcodec.dll that come inside the dgavcdec100a6.zip
I copied my libavcodec.dll from the FFDshow directory and pasted it on the DGAVCIndex.exe directory and now the Alpha 6 version works fine.
The libavcodec.dll that you made have problems you should check it.
Kurth is offline  
Old 9th June 2007, 05:34   #360  |  Link
Guest
Guest
 
Join Date: Jan 2002
Posts: 21,924
Quote:
Originally Posted by Kurth View Post
The libavcodec.dll that you made have problems you should check it.
I guess you missed the last several posts, where I am attempting to debug libavcodec.dll.
Guest is offline  
Closed Thread

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 20:57.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2017, vBulletin Solutions Inc.