Welcome to Doom9's Forum, THE in-place to be for everyone interested in DVD conversion.

Before you start posting please read the forum rules. By posting to this forum you agree to abide by the rules.

 

Go Back   Doom9's Forum > Video Encoding > MPEG-4 AVC / H.264

Closed Thread
 
Thread Tools Search this Thread Display Modes
Old 27th May 2007, 02:41   #321  |  Link
Guest
Guest
 
Join Date: Jan 2002
Posts: 21,924
Ok, thank you kweek. I've duplicated it and will fix it for the next alpha release.

EDIT: The JM reference software has some paths limited to 100 characters!

Last edited by Guest; 27th May 2007 at 02:53.
Guest is offline  
Old 27th May 2007, 11:48   #322  |  Link
G_M_C
Registered User
 
Join Date: Feb 2006
Posts: 1,076
Looked back at the test i did, i saw a (cosmetic ?) slight error.

The test-file is in 23.976 fps, but the programm-bar of DGAVCIndex reports 23.98 fps. The .dga opens as 23.976 though, so it is probably just cosmetic.
G_M_C is offline  
Old 27th May 2007, 12:28   #323  |  Link
hajj_3
Registered User
 
Join Date: Mar 2004
Posts: 739
Does the latest alpha support dvb-s2 h264 .ts files?? if not please can you add it.

here is a clip for you to test with to get it working, its a dvb-s2 h264 .ts file recorded from discovery channel in sweden:

http://www.sendspace.com/file/hwr40h (58mb)
hajj_3 is offline  
Old 27th May 2007, 12:33   #324  |  Link
G_M_C
Registered User
 
Join Date: Feb 2006
Posts: 1,076
Quote:
Originally Posted by hajj_3 View Post
Does the latest alpha support dvb-s2 h264 .ts files?? if not please can you add it.

here is a clip for you to test with to get it working, its a dvb-s2 h264 .ts file recorded from discovery channel in sweden:

http://www.sendspace.com/file/hwr40h (58mb)
Please read the earlier posts. It isnt supported yet, it only works with RAW H264 files.

You'll have to demux it, and hope it isnt encoded in PAFF, because that's not yet supported either.
G_M_C is offline  
Old 27th May 2007, 13:20   #325  |  Link
hajj_3
Registered User
 
Join Date: Mar 2004
Posts: 739
i see. hope its supported soon, europe has had dvb-s2 .ts for quite a while now, dgavc and videoredo dont support it yet, its a real shame as the quality it fantastic!

keep up the great work neuron!
hajj_3 is offline  
Old 30th May 2007, 18:56   #326  |  Link
lucassp
Registered User
 
Join Date: Jan 2007
Location: Romania, Timisoara
Posts: 223
does DGAVCIndex work with AVISynth 2.5.7 MT 0.7?

Last edited by lucassp; 30th May 2007 at 19:06.
lucassp is offline  
Old 1st June 2007, 14:33   #327  |  Link
Raere
Registered User
 
Join Date: Sep 2004
Posts: 44
I just wanted to thank you neuron2 for this awesome plug-in, it's just what I needed for my latest projects. Keep up the good work!
Raere is offline  
Old 2nd June 2007, 12:43   #328  |  Link
Guest
Guest
 
Join Date: Jan 2002
Posts: 21,924
Quote:
Originally Posted by lucassp View Post
does DGAVCIndex work with AVISynth 2.5.7 MT 0.7?
I don't know. Please report your results.
Guest is offline  
Old 2nd June 2007, 12:50   #329  |  Link
Guest
Guest
 
Join Date: Jan 2002
Posts: 21,924
Version 1.0.0 alpha 6

* Fixed broken GOP stepping after play/preview.

* Title bar FPS indication now has three places after the decimal point.

* A "Finished!" popup now appears at the end of the Save Project operation.

* Fixed an uninitialized variable in DGAVCDecode that could cause crashes in some circumstances.

* Redesigned the whole decoder DLL situation (read the help text carefully before using alpha 6):

- Now only one decoder DLL is required (libavcodec.dll).
- The decoder DLL is stripped down to include just AVC decoding.
- The decoder DLL must be placed in the same directory as DGAVCIndex.exe. The path is automatically passed to DGAVCDecode.dll in the DGA file.
- The decoder DLL project is buildable in Visual Studio 2005, allowing for direct tracing/debugging.
- The decoder DLL is derived from the ffdshow_tryouts project.

http://neuron2.net/dgavcdec/dgavcdec100a6.zip

I think I'll add transport stream support next, and then tackle PAFF.

Last edited by Guest; 2nd June 2007 at 12:54.
Guest is offline  
Old 2nd June 2007, 22:55   #330  |  Link
lucassp
Registered User
 
Join Date: Jan 2007
Location: Romania, Timisoara
Posts: 223
Quote:
Originally Posted by neuron2 View Post
I don't know. Please report your results.
using Alpha 5: the first pass works fine but the second pass hangs after the first few frames, the timer goes on and the fps drops to zero.

using Alpha 6: it crashes right after I hit the start button.
lucassp is offline  
Old 3rd June 2007, 02:44   #331  |  Link
Guest
Guest
 
Join Date: Jan 2002
Posts: 21,924
>AVISynth 2.5.7 MT 0.7

Since I have never heard of this, you should find out who made it and talk to them about it.

And I have no idea what you are talking about with first pass and second pass.
Guest is offline  
Old 3rd June 2007, 08:57   #332  |  Link
lucassp
Registered User
 
Join Date: Jan 2007
Location: Romania, Timisoara
Posts: 223
Quote:
Originally Posted by neuron2 View Post
>AVISynth 2.5.7 MT 0.7

Since I have never heard of this, you should find out who made it and talk to them about it.

And I have no idea what you are talking about with first pass and second pass.
AVISynth 2.5.7 MT 0.7 is the multithreaded version of AVISynth 2.5.7 made by tsp (http://forum.doom9.org/showthread.php?t=94996). The "first pass" and "second pass" are the x264 encoding passes of this AVS file:

Code:
SetMTMode(2,0)
DGAVCDecode_AVCSource("D:\Codecs\test.dga",deblock=false)
LanczosResize(960,544)
lucassp is offline  
Old 6th June 2007, 09:00   #333  |  Link
hajj_3
Registered User
 
Join Date: Mar 2004
Posts: 739
Quote:
Originally Posted by neuron2 View Post

I think I'll add transport stream support next, and then tackle PAFF.
yay, finally dvb-s2 .TS support coming:PPPPPPPP

thankyou!!!!!!!
hajj_3 is offline  
Old 7th June 2007, 13:52   #334  |  Link
klinika
Registered User
 
Join Date: Mar 2004
Location: Tampere
Posts: 51
Darn it, alpha 6 crashes on everything I try to open with it, and the error popup points out libavcodec in futile effort to shift the blame. But happily, alpha 5 works like a charm. Running regular xp32.
klinika is offline  
Old 7th June 2007, 14:24   #335  |  Link
Guest
Guest
 
Join Date: Jan 2002
Posts: 21,924
Quote:
Originally Posted by klinika View Post
Darn it, alpha 6 crashes on everything I try to open with it, and the error popup points out libavcodec in futile effort to shift the blame. But happily, alpha 5 works like a charm. Running regular xp32.
What does the popup say exactly? Did you follow the instructions for installation?
Guest is offline  
Old 7th June 2007, 15:46   #336  |  Link
klinika
Registered User
 
Join Date: Mar 2004
Location: Tampere
Posts: 51
Quote:
Originally Posted by neuron2 View Post
What does the popup say exactly? Did you follow the instructions for installation?
Well, the whole alpha 6 archive is on its own in one dir, libavcodec and all. I mean, is there something more, have I overlooked something?

The popup says nothing useful:

AppName: dgavcindex.exe AppVer: 0.0.0.0 ModName: libavcodec.dll
ModVer: 0.0.0.0 Offset: 00028bb2

Can't seem to select or copy any of the detailed information, but it's available, just need to know which parts of it would be needed. I wouldn't rule out reformatitis just yet though. There's nothing seemingly wrong with the files I tried, they're encoded with recent version of x264 using basic options and play just fine.

Last edited by klinika; 7th June 2007 at 15:57.
klinika is offline  
Old 7th June 2007, 15:56   #337  |  Link
Guest
Guest
 
Join Date: Jan 2002
Posts: 21,924
Make a screenshot of the popup and post that.

Also, search your entire system for libavcodec.dll and let me know if there is another one than the one that sits with DGAVCIndex.exe.

Also, post a link to a fragment of a stream that causes this problem. Does it happen with the file test.264 that is included in:

http://neuron2.net/dgavcdec/dgavcdec100a2.zip

Last edited by Guest; 7th June 2007 at 15:59.
Guest is offline  
Old 7th June 2007, 16:08   #338  |  Link
Guest
Guest
 
Join Date: Jan 2002
Posts: 21,924
Oh, and install this:

http://www.microsoft.com/downloads/d...displaylang=en

Let me know the result.
Guest is offline  
Old 7th June 2007, 16:56   #339  |  Link
klinika
Registered User
 
Join Date: Mar 2004
Location: Tampere
Posts: 51
Installed the vcredist, nada, didn't do anything. No duplicate libavcodecs except the one in ffdshow dir, and that's nowhere near any PATH variables. And test.264 crashes dgavcindex on open too.

Here's a link to a 5s clip I encoded just for this, which I'm sure you'll find working perfectly on your end, but crashes on mine.

Here's a pertinent screenshot, along with the Amazing Error Popup That Refuses To Be Copied, which I meant before (there's info about every dll loaded in memory there if one scrolls down, and down, and down):



The offset, address, and code stays the same whatever clip I try to open. If that means anything.

I'm acutely aware that no one else has reported similar problems, and I'm not sure if it's worth the effort to investigate as it most probably is an isolated case of conflict somewhere in the bowels of my pc. At least such it would seem to be. Still, alpha 5 works, and with a bit of luck, the next alpha works too But it sure is a perplexing problem

Last edited by klinika; 7th June 2007 at 17:02.
klinika is offline  
Old 7th June 2007, 17:44   #340  |  Link
xc3ll
Registered User
 
Join Date: Feb 2007
Posts: 32
Hi neuron2, I tried your program, but get an this error:

[h264 @ 0100700C]Internal error, IDCT permutation not set

when I try encoding w/meGUI, source is a bd disc.
xc3ll is offline  
Closed Thread

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 23:56.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2017, vBulletin Solutions Inc.