PDA

View Full Version : Really strange situation!!!


Keyper7
11th August 2005, 01:28
Hi, hereís a problem I have never encountered before: I was given an avi file, an anime in fact. When I tried to play it though it would show black (blank) frames among with those in the file. I donít know if this description is clear. It would show frames of the file and black frames, one after the other. When I opened it with VirtualDubMod (1.5.10, build 2439) it would look perfectly fine. The preview showed no flaw whatsoever. At the time (please bear with me) the info would give a FourCC of DIV3, AKA, it would suggest that it was DivX 3 material. By the way, the avi file had a date of creation Monday, August the 18th, 2003. Rather old but not too old. I tried to de-activate the ffdshow filter for Divx3 material, the PowerDVD decoder was activated instead, no change. I tried to create a new avi by Direct Streaming only the file. No change. I installed the official DivX 5.1 decoder (yeah, I know it wasnít the latest but I was bored to download the latest plus it was newer that the file itself so who cares?). Again no change, I uninstalled DivX 5.1 and rebooted the system. At this point the windows explorer could no longer show a thumbnail of the file (it did before). I tried to re-encode it to XviD but the encoder refused returning an error. I opened the info tab again. Now here comes the strange part: I donít know why or how but when I opened it again the FourCC code no longer said DIV3!!! It instead read MP43, AKA Microsoft MPEG-4 Video Codec V3!!! However, GSpot (v2.21: 04) still read in the Video Src Type: 4cc: DIV3!!! By the way, in GSpotís Video section stat read that Codec was misconfigured. When I clicked for info it seemed that it had DivX Decoder Filter twice, no doubt one was from PowerDVD and the other from DivX 5.1, they must have screwed up each other letting only 3ivx D4 Video Decoder to properly function. This is important for the next part. When again I disabled ffdshow the problem was resolved!!! Why? Because with PowerDVDís decoder screwed, Neroís DVD Decoder was used instead and apparently could function correctly. However, the setting I disabled on ffdshow was for the DivX 3 format, not MP43. I forgot to mention that the reason XviD could not re-encode the material was because the video was 640x477; how they could (or would) use a dimension of 477 is beyond me. Now letís go back to the Direct Streamed only file I created. Again it had a FourCC code of MP43 only this time GSpot agreed. The windows explorer could create a thumbnail for it; it still couldnít for the original file. I tried to play it but it still showed the same problem. I opened ffdshow again and this time I disabled decoding for MP43 material, re-enabling the decoding of DivX 3 material. I was correct, this time it played correctly. Now hereís one last peculiarity: GSpot said that the Decoder used was Mpeg43 Decode DMO, not Nero DVD Decoder (which was used for the original file). At this point the video Stat window showed 4 compatible codecs: Microsoft MPEG-4 Video Codec V3, 3ivx D4 Video Decoder, Microsoft MPEG-4 Video Decompressor and Mpeg43 Decode DMO. Does anyone have encountered anything even remotely similar to this and if so, know why or how it happened? Oh, and why ffdshow couldnít correctly play it in either case? Because I donít quite know where this post belongs to I posted it on several forums, really sorry for the inconvenience. Could the administrators please move the wrong posts to the correct forum or lock them? Thanks again.

unskinnyboy
11th August 2005, 01:43
:readrule:

1) Blatant disregard of forum rules. You cross-posted 3 times. Breaks rule #8.

2) You were "given" an avi file? Please see Rule #6.

3) Are you in an essay-writing competition? Half-way thru your story, I got a migraine headache.

Rest assured, you will get zero help.

Keyper7
11th August 2005, 01:58
Thanks, man, rule #8: Hence "really sorry for the inconvenience. Could the administrators please move the wrong posts to the correct forum or lock them?"
Rule #6: Yes, GIVEN a Japanese non-licensed file that never came through the net but instead passed hands (or disks) until the author no longer was known.
Oh, and if you could find a better, shorter and more efficient way of describing the afore mentioned problem I'd love to see you try.

djan
11th August 2005, 02:08
Man, space your text with lines, try to push enter button sometimes. We can't read it, it breaks head. Delete yourself your multiposts, it's not difficult.

bond
11th August 2005, 02:16
striked for rule 8 and 6 and 9

next time read the rules before you post on a forum, they are there for a reason...