View Full Version : Ifoupdate - wrong time in chapters

27th May 2005, 16:51
Hi. I'm from Argentina (so excuse my english) and new in the forum.
Let me say the backup guides are nice and people here really knows what they're doing.
Well, the thing is that I, somehow, manage to do the Big3 backup method on my Steve Vai's DVD.
In the end, when I used ifoupdate, the chapters starts 5 seconds earlier. :(
I configured ifoupdate the following way:
Orig Ifo Path=..\VaiFinal\VIDEO_TS\VTS_01_0.IFO
Authored IFO=..\Vai\0\VIDEO_TS\VTS_01_0.IFO
Options marked: transfer.., copy color table.., autocorrect vts.., autoanalize orig ifo.
Before I press update, I check the times and they're OK.
I know my Q must be kind of lame, but I can't solve it, I checked the forum and didn't find a similar problem. So if someone can give me a hint, I'll appreciate it.

3rd June 2005, 04:12
hi enzito and welcome to the forum!

so let me understand this correctly ... you can not get your Steve Vai DVD backed up?!??!! :eek: :eek: :eek:
THIS is something we will have to remedy! :D
i have only managed to see him perform once live but i have been a HUGE fan since the zappa days!

okay first things first:
what programs are you using in your big 3 method?
and what is your workflow? dif4u > scenaid > batchcce ? what?

although it sounds unlikely that the cause of your problems is ifoupdate (at the moment i am thinking maybe its incorrect usage), i would seriously recommend you try out Trahalds "batchifoupdate" - it really does make life easier, and supports additional features which ifoupdate does not.

if this doesnt fix the problem, could you also post the relevant segments of your original and re-authored/updated .ifo for the vts which is giving you grief.



btw, any mods reading this, could you please move this post to the dif4u/batchcce/scenaid/numenu forum?

30th June 2005, 21:03
:thanks: for the reply and the welcome jel.

I'm using dif4u > scenaid > BatchCCEWS > Scenarist > IFOUpdate
I also tried BatchUpdateIFO but the result its the same.
I zipped the 3 IFOs in:
removed link to copyrighted material

And thanks again!.

PS: I think Scenarist blanks the original VTS_01_0.VOB w/the FBI warning. I read that shouldn't be done, because of compatibility problems.

1st July 2005, 05:04
hey enzito,

good to see you haven't given up on mr vai :)

to be honest, i am still thinking that you havent performed the ifoupdate stage correctly.

try this:

1. after compiling your re-authored dvd in scenarist, create a new folder on your computer and name it something obvious eg STEVE_VAL_FINAL

2. then COPY your entire VIDEO_TS folder from your demux directory

3. open batchifoupdate and for 'original ifo pathname' point it the VIDEO_TS.ifo in your final folder eg: C\:STEVE_VAI_FINAL\VIDEO_TS\VIDEO_TS.ifo
and for 'authored ifo pathname' point it to the VIDEO_TS.ifo in your scenarist compiled folder, eg:

4. select ALL options in batchifoupdate, except for "Copy Command Tables" ( i also deselect "copy audio tables / subtitle tables / colour map"

5. make sure that ONLY the .ifo files for the vtses you demuxed/re-encoded/re-authored are selected in the 'batch - Batch mode' dialog box.

6. hit 'update'

7. test files in STEVE_VAI_FINAL folder in a s/w player - eg. ifoedits dvd_play

let us know how you go!

PS: I think Scenarist blanks the original VTS_01_0.VOB w/the FBI warning. I read that shouldn't be done, because of compatibility problems. are you using numenu4u to process your menus?
i think you may be getting confused in that, the contents of your compiled scenarist folder - C\:DEMUX_FOLDER\0\ - is NOT the final product. you HAVE to follow the above procedure to get everything back together again


PPS: i removed your link to the ifo files, as generally it is considered inapropriate to distribute .ifo files in a public forum. when i asked for the relevant .ifos, i meant the information you see when you open them in ifoedit.

rock on!

3rd July 2005, 05:29
Hi jel!. Good to see you haven't give up on me. :D (thanks a lot!!!)
First, sorry for posting the IFOs, good thing you saw it fast.
The stages you mention, I did them just like that.
Except I don't have the option "Copy Command Tables" in BatchUpdateIFO (v beta). And I tried several times checking and unchecking the options but the problem continues.
Here is some lines from BatchUpdateIFO after hit update:
Updating VTS_01_0.IFO
Original and Authored PGC quantity matches
There are 2 PGCs:
PGC 1 has 25 cells
Old PGC Duration 02:20:48:09 New 02:20:48:14
Old Cell Duration 00:02:05:05 New 00:02:05:05
Old Cell Duration 00:04:18:05 New 00:04:17:26
Old Cell Duration 00:08:41:16 New 00:08:40:25
Old Cell Duration 00:04:21:18 New 00:04:21:09
Old Cell Duration 00:01:58:22 New 00:02:07:06
Old Cell Duration 00:00:00:25 New 00:00:00:25
PGC 2 has 2 cells
Old PGC Duration 00:00:01:12 New 00:00:01:01
Old Cell Duration 00:00:00:12 New 00:00:00:16
Old Cell Duration 00:00:01:00 New 00:00:00:15

I redone the SceneAid > Scenerist process and I noticed the following warning:
Warning Cell "VTS1_Title2_PGC2_PG2_C1" has only one VOBU and is connected to Cell "VTS1_Title2_PGC2_PG1_C1" seamlessly. "PGC:<VTS1_Title2_PGC2> (Title:<VTS1_Title2> VTS:<VTS_1>) "
Warning Some DVD players have problems with this limitation.
Info No VTS Language found.
Info Creating VTS "VTS_1" Title

At the begining, in doitfast4u I unchecked the PCM Stereo (main audio). I planned to do the proper fixes later. Don't know if that caused some trouble.

I opened the Reauthored IFO (..\0\VIDEO_TS) in IFOEdit and I noticed the times are already wrong in there. But in scenarist in "Track Editor" the track times are ok. :(
I redone that stage a few times but I get the same IFO.

Any ideas? (hope so, I'm clueless).

3rd July 2005, 22:32
are you letting Scenaid call BatchCCEWS or are you manually doing it?

Your chapter locations aren't that far off except for a couple which would lead me to believe the I-frames are off (usually a result of not using the Scenaid-CCEData.txt file when encoding)

either way, most seem to be off by around 15 frames which is < 1sec and i doubt will effect playback

3rd July 2005, 23:11
ScenAid calls BatchCCEWS automatically.
The difference between the actual chapters and the ones in the final result of the backup are 5-7 secs (starts earlier).

3rd July 2005, 23:25
send me your original ifo and the one from scenarist (pre update)

as well as the scenaid.log / scenaid-ccedata.txt / scenarist.scp

we'll see what's going on

I'm assuming of course that you hadn't modified the AVS scripts at all?

4th July 2005, 00:58
I hadn't modified the AVS scripts.
I sent the files to sceneaid mail under the subject "wrong chapters".
Thanks a lot man!.

4th July 2005, 03:58
Now the chapters are in the right time.
Its seems that Scenarist 3.01 was not working as it should.
I installed Scenarist 2.7 instead and problem solved.

:thanks: you guys for your help. You rock!. ;)

5th July 2005, 06:32
hard to argue with that! :p

good to see you got mr flex-ables dvd working
rock on