PDA

View Full Version : no audio in Virtual VCR


henningdalgaard
28th March 2005, 15:26
Using a terratec TValue and soundblaster audigy on XP. Capture work fine using terratecs own Cinergy software.
In virtualVCR I can get the preview to show video but not audio. I have selected analog mix/line in.
What am I missing?

henningdalgaard
28th March 2005, 15:32
Also, I have installed the PICVideo M-JPEG v.3 codec but when I have to select codec under capture, I see there is like 3 or 4 codecs from PICVideo. Which one do I use? I am using it as an alternative to Huffyuv.
Is there better codecs out for capturing TV

boban10
28th March 2005, 16:00
use PicVideo Mjpeg Codec.

henningdalgaard
28th March 2005, 16:12
Thanks boban10

I see the following:

PICVideo M-JPEG 3 directshow compressor
PICVideo 3 Directshow M-JPEG compressor
PICVideo M-JPEG 3 VfW codec
PICVideo Wavelet 2000
PICVideo lossless jpeg codec
PICVideo lossless jpeg compressor

It looks like I have installed it twice but I havent. I guyess any of the two first ones are okay?

I have selected Yuv2 and 320x240 (any higher than that gives me horisontal lines on moving objects). I have set the quality to 18, but what about the other settings such as "encode normalized yuv", "subsampling", "2 fields if more than 240", and "swap fields" ?

Also, If I burn the M-Jpeg capture to a DVD, will it play in a standalone player? My guess is no but which is the most userfriendly program to convert it to a dvd?

Boulder
29th March 2005, 17:43
Originally posted by henningdalgaard
I have selected Yuv2 and 320x240 (any higher than that gives me horisontal lines on moving objects).

That's interlacing, nothing wrong with the video. You should definitely capture at a higher resolution, preferably at 704/720x480. For your final destination, either deinterlace (for viewing on the PC) or encode as interlaced (for TV). You won't see the combing on the TV.

I have set the quality to 18, but what about the other settings such as "encode normalized yuv", "subsampling", "2 fields if more than 240", and "swap fields" ?

Enable encode normalized YUV (also enable the similar setting in the decoder section) and "2 fields...", use subsampling 4:2:2. Disable "Swap fields".

Also, If I burn the M-Jpeg capture to a DVD, will it play in a standalone player? My guess is no but which is the most userfriendly program to convert it to a dvd?
There's plenty of programs. You should learn some Avisynth, and there are good free MPEG2 encoders available, such as QuEnc and HCEnc.

Search will give you much more information;)

henningdalgaard
29th March 2005, 18:24
thank for the reply.
Is it still a problem to capture yuy2 with PICVideo M-jpeg?

Boulder
29th March 2005, 18:55
You should use YUY2 with PicVideo. If you use Avisynth to frameserve the video to the final encoder, you must ensure that you get YUY2 output. By default the codec outputs YV12 data.