PDA

View Full Version : Problems with audio and Video


jimarick
16th April 2004, 12:33
Hi,

Basically Ive been having some troubles with GK and AutoGK. I have installed the Gordian Knot Codec Pack 1.6 and GK 0.28.8 and AutoGK 1.17b.

The first problem was that all videos encoded in GK had audio dramatically out of sync. They are from Episodic DVDs ripped using file mode in DVD decrypter, which i then put through robot4rip which basically just used the Vstrip function to extract each seperate PGC into its own 2 vobs. I have the newest Xvid 1.0 Build4 installed.

I eventually realised that the Variable MP3s that GK encoded during the ripping process were 1-2 minutes shorter than the AC3 they were encoded from. I attempted to join the original ac3 with the film_movie file and hey presto, it was all in sync. To attempt to correct this problem, i reinstalled GK and the codec pack. It worked for a couple of files and then had the problem again. So I then installed the new BeSweet version into the GK directory... i think it has worked but have only encoded 2 files so far. However, this problem did NOT occur when using AutoGK instead of GK. What was i doing wrong? In GK I selected the AC3 file, and made sure the delay was ok, made it recalculate video bitrate and delete wav. I selected either expert parameters OR mp3 128kb/s average bitrate. Neither worked.

Second problem which happened is that since GK wasnt working i resorted to AutoGK, a great piece of work, but little too simple for me. Anyway, it encoded the audio and video in sync, but AutoGK failed to recognise the DVD was interlaced so the encoded AVI does have some lines at parts where there is a lot of movement, only noticeable when it is white and a colour moving over one another. The funny think is usually if i encode without deinterlacing then it is VERY noticeable in the encoded AVI, but this was only at parts with a dark colour or white over one another. I hazard a guess that this is a problem with AutoGK's coding routines itself, and how it recognises the VOB as Interlaced or Progressive.

The final problem is that now GK has decided to get the audio in sync (i think) the video it encodes in a 350mbAVI. (Xvid - only chroma motion and VHQ1 and MSP 6 - Ultra High.) has i think a reduced framerate, well it looks flickery when anyone on the screen moves. I tried a select 10 seconds of the start of the same troubled dvd2avi project and there was no flickering. So it is just in the 350mb version, both with the same Xvid Settings. This is all after I reinstalled GK and deleted all the old registry settings.

Any ideas would be very welcome... if you have got to this part of the post I thank u already:)

Hope anyone can help,
James

len0x
16th April 2004, 14:21
Originally posted by jimarick
Second problem which happened is that since GK wasnt working i resorted to AutoGK, a great piece of work, but little too simple for me. Anyway, it encoded the audio and video in sync, but AutoGK failed to recognise the DVD was interlaced so the encoded AVI does have some lines at parts where there is a lot of movement, only noticeable when it is white and a colour moving over one another. The funny think is usually if i encode without deinterlacing then it is VERY noticeable in the encoded AVI, but this was only at parts with a dark colour or white over one another. I hazard a guess that this is a problem with AutoGK's coding routines itself, and how it recognises the VOB as Interlaced or Progressive.


Please post the log file. I want to see statistics for the analysis step.

KE
16th April 2004, 19:52
I also have a problem with Audio since installing GK 0.28.8. Audio is out of Sync by a few seconds. If I manually mux the exact same Video and MP3 files produced by GN (using VDubMod) sound is perfect.
Everything else works perfect.

jggimi
16th April 2004, 22:09
Originally posted by jimarick
...ripped using file mode in DVD decrypter.... Have you tried using IFO mode, per the guide(s)?

KE
16th April 2004, 22:47
Yes used IFO Mode.
The problem seems to be in the final mux by GN. If there was a problem with the MP3 file it would not work with manual mux.

PS: The final video by GN with the sync problem is 697MB. The manual mux video is 699MB.

Veky
16th April 2004, 23:04
Originally posted by KE
I also have a problem with Audio since installing GK 0.28.8. Audio is out of Sync by a few seconds. If I manually mux the exact same Video and MP3 files produced by GN (using VDubMod) sound is perfect.
Everything else works perfect.

Get the new BeSweet. (date 15/4/04)

KE
16th April 2004, 23:58
Thanks. Will try.

Copied all files in BeSweetv1.5b26 Beta to GK.
Problem solved. Thanks.

jimarick
18th April 2004, 10:47
Hi,

In regards to my 1st post, i think the reason for the slow frame rate (which was exactly 20fps)is because I didnt make the D2V file using gknos dvd2avi. I used one created by AutoGK on a previous pass.
The sound problem seems to have dissappeared using the new BeSweet, and the only problem left is that one with AutoGK and the interlacing.

This is the Log file for the file that I encoded that DVD2AVI does see as interlaced but AutoGK's analysis claims it is progressive, hence lines in the completed file.

===========================================================
[18/04/2004 06:20:47] Input dir: C:\DVD Rips\West Wing\Season 3\Disk 5\Encodes\3
[18/04/2004 06:20:47] Output file: C:\DVD Rips\West Wing\Season 3\Disk 5\Encodes\S3D5E3.avi
[18/04/2004 06:20:47] Audio: English
[18/04/2004 06:20:47] Subtitles: none
[18/04/2004 06:20:47] Codec: XviD
[18/04/2004 06:20:47] Target size: 350Mb
[18/04/2004 06:20:47] Custom audio settings: VBR MP3 with average bitrate: 128Kbps
[18/04/2004 06:20:47] Started encoding.
[18/04/2004 06:20:47] Demuxing and indexing.
[18/04/2004 06:21:55] Analyzing source.
[18/04/2004 06:21:55] Writing the following script to C:\DVD Rips\West Wing\Season 3\Disk 5\Encodes\gk_tmp\lastjob.vcf
===========================================================
VirtualDub.Open("C:\\DVD Rips\\West Wing\\Season 3\\Disk 5\\Encodes\\gk_tmp\\_.avs",0,0);
VirtualDub.RemoveInputStreams();
VirtualDub.video.SetDepth(24,24);
VirtualDub.video.SetMode(0);
VirtualDub.video.SetFrameRate(0,1);
VirtualDub.video.SetIVTC(0,0,-1,0);
VirtualDub.video.SetCompression();
VirtualDub.video.filters.Clear();
VirtualDub.subset.Delete();
VirtualDub.SaveAVI("C:\\DVD Rips\\West Wing\\Season 3\\Disk 5\\Encodes\\gk_tmp\\_.avi");
===========================================================
[18/04/2004 06:24:56] Source has percentage of interlacing in motion areas: 1.54
[18/04/2004 06:24:56] Source is considered to be progressive.
[18/04/2004 06:24:56] Found 62660 frames
[18/04/2004 06:24:56] Encoding audio.
[18/04/2004 06:32:14] Audio size: 38,381,888 bytes (36.60 Mb)
[18/04/2004 06:32:14] Overhead: 2,506,368 bytes (2.39 Mb)
[18/04/2004 06:32:14] Video size: 326,113,344 bytes (311.01 Mb)
[18/04/2004 06:32:14] Running compressibility test.
[18/04/2004 06:32:14] Writing the following script to C:\DVD Rips\West Wing\Season 3\Disk 5\Encodes\gk_tmp\S3D5E3_comptest.avs
===========================================================
LoadPlugin("C:\PROGRA~1\AutoGK\filters\mpeg2dec3dg.dll")
LoadPlugin("C:\PROGRA~1\AutoGK\filters\autocrop.dll")
LoadPlugin("C:\PROGRA~1\AutoGK\filters\undot.dll")

function getOrder(clip c) {
order = GetParity(c) ? 1 : 0
return order }

movie = mpeg2source("C:\DVD Rips\West Wing\Season 3\Disk 5\Encodes\gk_tmp\S3D5E3.d2v")
cropclip = autocrop(movie,mode=0,wmultof=4,hmultof=4,samples=10,aspect=0,threshold=35)
c_width = width(cropclip)
c_height = round(height(cropclip) / 1.09401709401709)
input_par = float(c_width)/float(c_height)
fixed_aspect = input_par > 1.4 ? 1.09401709401709 : 1.06666666666667
c_height = round(height(cropclip) / fixed_aspect)
input_par = float(c_width)/float(c_height)
out_width = 640
out_height = round(float(out_width) / input_par)
hmod = out_height - (floor(out_height / 16 ) * 16)
out_height = (hmod > 4) ? (out_height + (16 - hmod)) : (out_height - hmod)
new_aspect = (float(out_width) / float(out_height)) / fixed_aspect
autocrop(movie,mode=0,wmultof=4,hmultof=4,samples=10,aspect=new_aspect,threshold=35)
Undot()
===========================================================

Hope all this can help
James

len0x
18th April 2004, 17:09
I don't believe it's interlaced. Very often TV series start as interlaced in the first seasons and then switch to progressive FILM source (especially if its widescreen), but the credits for instance still shows moments from previous seasons and hence have some interlaced bits. Are you sure that you constantly see interlaced artifacts all over the episode ?