PDA

View Full Version : VCR Capture


Rene_Voodoo
29th November 2003, 18:14
I looked in every resources to find how to solve my problem, and didnīt find, so I can write here without putting equal messages. :D

Well, my name is Rene and I live in Brazil

I recently have bought a MSI GeForceFX 5600 VTD-256 (with VIVO) and the problem is this: I want to capture videos from VCR, but they has no color when the image appear in the Virtual DUB, I tried several versions of the virtualDUB, and didnīt changed the final image... Iīm usind the verion 1.22 of the WDM Drivers, and tried to install the version 2.13 of the WDM drivers, and again... no difference (black and white captures). The color system here in Brazil is PAL based... the true or exact system here is PAL-M, and I donīt believe that the color system of my VGA can only accept NTSC system.... what I need to do, to have colored video capture? please!! somebody help me... cause I really want to capture videos from my VCR with color! I sent e-mail to MSI requesting a solve for my problem... and nobody gave me an answer! :(

Iīll wait for an answer from you, and it will be really apprecite! :rolleyes:

ppera2
29th November 2003, 23:49
You need capture driver which is capable to capture PAL at 30 fps - according to specs of PAL-M. If your card is with BT 8x8 chip, you may try BTwincap drivers.

Rene_Voodoo
30th November 2003, 13:45
thank you!

but, how do I know if my card is based on this chip (BT 8x8) ? and, where do I find these drivers.. and after install it will capture in full COLOR ?!

Arachnotron
1st December 2003, 18:11
From other cards like this I think your card has either a separate Philips SAA7114 chip or capture is an integrated part of the NVIDIA chip.
If it is the philips you should be able to recognise by visual inspection since capture chips rarely need a heatsink

In either case you are pretty much limited to what the drivers that came with the card will allow you to do. You might try generic nvidia drivers from www.nvidia.com.

Perhaps you have an NTSC_M setting? don't know if this is the same.

(M/PAL is NTSC timing with PAL colour coding)

edit
NTSC_M is the other way around, PAL timing with NTSC color. So no joy there

ppera2
1st December 2003, 21:20
Originally posted by Arachnotron
From other cards like this I think your card has either a separate Philips SAA7114 chip or capture is an integrated part of the NVIDIA chip...
Perhaps you have an NTSC_M setting? don't know if this is the same.
(

No Nvidia chip with integrated capture. Inspecting is easiest way, except when your case is sealed due to warranty.
There is no NTSC_M. It is PAL because color encoding is PAL (Phase Alternate Lines), framerate is 30 fps and vertical lines are 525 - this is mixture of PAL and NTSC, but name of system 'talks' about color encoding...

Rene_Voodoo
2nd December 2003, 13:49
Firstly thank you to the answers! In all these cases, Iīm capable of making coloured captures? Every card can do this? because I bought a card to do the captures and it can only capture in NTSC? Iīt not possible dindnīt it? I canīt find these generic drivers at www.nvidia.com so if am I donīt boring you, the help is very welcome :D

thank to all!!

Arachnotron
2nd December 2003, 15:09
go to:

http://www.nvidia.com/content/drivers/drivers.asp

select
- Multimedia Software
- Personal Cinema
- (your windows version)

Nvidia uses the same installer for all cards. This bundle includes the video drivers, the capture drivers and some capture software.

Of course, you might have to de-install the drivers and software that came with your card first. And of-course, no guarantees. I have had no problems with NVIDIA drivers replacing the drivers that came from my card manufacturer, but you never know. And I don't own a VIVO version, so what these drivers can do is unknown to me.

From the .inf file in the driverset I get the impression that these card use Philips chips and CAN do PAL_M

By the way, often philips chip based cards are set to autodetect by the driver. If so, your card will probably jump back to NTSC when there is no signal, and switch to PAL_M only when there is input.

Success!


I2C address only important if
VideoDecoder != AUTO
"D1" (8 bit) or "DMSD16" (16 bit)
"SAA7111", "SAA7111A", "SAA7112V0",
"SAA7112", "SAA7113V0", "SAA7113",
"SAA7113A", "SAA7114", "AUTO"
"NTSC", "PAL", "SECAM",
"NTSC_433_50", "NTSC_433_60",
"NTSC_N", "PAL_433_60", "PAL_N",
"PAL_M", "AUTO"

Rene_Voodoo
2nd December 2003, 20:23
I tryed to install the unique drivers avaible in this link.. and by 2 times trying to install.. unsucessful.. didnīt installed any drivers... I donīt know what happening

again, help will be very welcome :D

thanks!

Arachnotron
2nd December 2003, 22:10
Sorry, I can't help you any further. There is no reason why this card shouldn't do PAL-M or why the reference drivers shouldn't install. I suspect another problem. By the way, did you try any other capturing programs?

Also: this card needs directX9, so since you are in Brazil I assume you installed the tuner update from Microsoft fould here (http://www.microsoft.com/downloads/details.aspx?FamilyID=8dfd1b6d-e177-4a0e-91d0-b4310675b02b&displaylang=en)

Rene_Voodoo
6th December 2003, 03:31
thanks Arachnotron, you, together with the others, gave me a great help!

Iīm trying to capture with the VirtualDUB and MSI Media Center Deluxe II, I had an answer from MSI... Iīll paste here the answer by e-mail:

"...Hi,
For the capture, You may want to use the Winproducer/Wincoder by intervideo which came with the card. This program work with the card for the capture.
Thanks..."

But in the package that my VGA card has, this program didnīt came together with it!! so I need to capture with other options of programs, and VirtualDUB seems to be a very good tool to make those captures. I have no reason to having this problem, indeed. But, do you think that this answer from MSI is an answer to be given to a customer??? cīmon! they must tell me everything to do because this products arenīt cheap, and more, providing me some drivers or something that can do PAL-M... or some more complete and attentive answer!

thanks a lot for all you! and Iīll continue this neverending FIGHT
:D hehehe

(please, tell me about my english, if its too poor, or itīs good! so I can write more clean and unconfusing! hehe)

Arachnotron
6th December 2003, 15:00
Since this is a modern card with wdm drivers, a vfw based app like virtualdub might not be the best choice.

Virtualdub is still the first choice for editing video, but the capture part will often not work with many cards/drivers.

Try virtualVCR, or one of the many freeware directshow based TV/capture programs floating around on the web instead.

Included software is often crap anyway, since the primary goal is not to produce the best picture possible, but to produce some sort of picture even on underpowered systems.

Rene_Voodoo
6th December 2003, 17:39
Sorry, I told the wrong name of the program that Iīm using to try captures.. the correct name of it is VirtualDub1492VCR+SYNC, is it the virtual VCR? and which program to try or is better to capture with WDM drivers with this card??

thanks!!

Arachnotron
6th December 2003, 17:44
That is a virtualdub modification. You can find virtualvcr here (http://virtualvcr.sourceforge.net/)

Dropped Frame
27th January 2004, 03:23
Had the same problem with my MSI GeForce4 MX460.
It took me a while until I realized that the card is set to NTSC by default and so far, I haven't found an option in the drivers to switch to PAL (big THANKS to the manufacturer).

Solution:

open registry editor: exchange all NTSC values (in my case: total of 6) to PAL, reboot.

Hopefully that solves your problem (if you haven't alread found a solution).

TheJez
30th January 2004, 08:53
I've had the same problem (only black & white) until I switched my input source from s-video to composite. This can be done somewhere in the wdm-driver configuration, where you select your capture driver in VirtualDub.
I'd suggest you stick to your modified VirtualDub with Sync-modification, because you need this when you capture long pieces of video. It assures that your audio and video will stay in sync.

Another tip: Use the WDM-driver version 1.08. It is the final driver that has no Macrovision protection implementation. Newer versions have, and they sometimes falsly think there is macrovision protection, and produce a white/grey bar accross the screen when capturing (not when viewing). You can find one here: http://driver.gainward.com.tw/VGA/Driver/nVidia/WDM/

Good luck,

TheJez