View Full Version : Problem comes one after another.

26th September 2003, 01:29
I used VobSub in VDub and I direct stream copy my movie with the subtitle filter so then I have a perfectly good movie file with everything sync and the subtitle display. However... I'm SURE it is not hardcoded. Hardcoded is like pictures, they look same no matter what and is part of the movie. With mine, Its totally different. I need NJstar to read it or else the symbols change. And when I use TMP, TMP made another layer of subtitle (same sub with the original size) so I have two subs and they are both same but one is bigger and the other one is "hardcoded" but can change. After TMP the small sub (original) doesnt change but the big one do. How do I use TMP and filter out the big one so I dont get two? Am I confusing?

26th September 2003, 11:51
About Chinese subtitles: I only ever used them as Vobsubs, so I don't really know why installing NJStar would prevent you from "making subs" (what do you mean exactly?).

About your "subtitle ghosts": I guess you installed Directvobsub, correct? What this will do (at least in auto-load mode) is whenever you open an .avi, it will look for subs with the same name in the directorys specified & will display them as an overlay (your "transparent layer"). You can disable this default behavior by clicking on the vobsub icon in the system tray and disabling subs.

Now, when you encode a movie from avi to vcd in tmpgenc (I guess you were talking about that) the dvobsub filter will load as well & tmpgenc will encode the movie plus the subtitle overlay & you will have your movie with hardcoded subs.

You might then experience the strange situation that you playback a movie with hardcoded subs now & dvobsub loads again and displays another copy of the same subs on top of it ... of course you can still change the font size etc. Disable the dvobsub overlay then.

Alternatively, you can use vobsub as an avisynth plugin to insert the subtitles you want (without the use of the dvobsub overlay). Check the vobsub docs for an example.

Sorry if this comes across as a bit confusing, I am away from home and I am only writing this from memory ...

NB: What do you mean w/ "installing Chinese language"? NJStar only? I would get a Chinese IME from MS, it comes with Chinese fonts and should get you started OK. Go here (http://www.andante.org/ime_install.html) for help with installing the MS IMEs ...

28th September 2003, 16:40
I used VDub Sub filter and it turn to some direct thing. Is that cuz I used direct stream copy when really I should use full processing? Whats the difference between fast, and full processing? Anyway I tried full processing but resulted in a 70 GB file... And I also found in VDubMod there is a stream list. I can add stream but it wont execpt my SRT. It say something about error loading it or something or invalid SRT file. Maybe cuz its chinese?

29th September 2003, 09:44
Direct stream copy uses the same codec as the source. With fast and full processing one can use another codec. And guess what? The default is lossles or some form of it. As you found out, that takes quite some space.

With fast processing one can encode in yv12 color space, but can't use any additional filters in vdubmod itself. Therefore we use avisynth.

With full processing one encodes in yuv or rbg, don't know for sure. But you can use the internal filters of vdubmod.

30th September 2003, 00:30
K, I got it all figured out. Maybe I should make my own guide because I speak easy language so newbies like me can understand.