PDA

View Full Version : Computer can't see new ATA/133 HD at startup


BoNz1
19th July 2003, 05:53
Ok, I am having a problem with a new hard drive that I installed into my brothers old computer. He is running a 333MHz AMD K6 processor, the motherboard is an Asus P5A-B, and there seems to be no way to update the BIOS on this board which is part of the problem. Now, I installed a Maxtor Ultra ATA/133 PCI Adaptor card because the motherboard is so old that is no serial ATA. Then I installed a Maxtor 40GB 7200RPM hard drive. And the computer cannot find the hard drive when it starts up but the BIOS on the PCI Adaptor card does find it but it never actually works. Believe me everything is configured correctly from the hardware side of things, if I install another HD and install Windows 2000 Pro onto it then it will see the HD from Windows but not when I start up the computer. So once the new hard drive is installed then I try to install Windows 2000 Pro onto it and of course it doesn't work. Does anyone know how to deal with this? It is certainly annoying I've been trying to get this to work for several hours now. If it could just find it when it starts up it would work. I also have another problem, I also installed 128MB of SD-RAM and it can only find half of it I suppose a newer BIOS might help but maybe there is another way hopefully someone can help. Thank you.

Ramirez
19th July 2003, 20:57
Well, it should be very easy flashing your MB BIOS, you only need to D/L BIOS update ROM file and a flashing utility (AWFLASH.exe) and then execute one short command in a dos prompt "awdflash.exe biosname.005".

<Download>

P5A-B (With Audio) Beta BIOS 1011.005 (http://www.asus.com/pub/ASUS/mb/sock7/ali/p5a-b/1011b005.zip)
P5A-B (Without Audio) Beta BIOS 1011.005 (http://www.asus.com/pub/ASUS/mb/sock7/ali/p5a-b/1011bn005.zip)

BIOS Flashing Utility (http://www.asus.com/pub/ASUS/mb/flash/aflash221.zip)

Give it a go, might solve your problem.

BoNz1
20th July 2003, 03:05
Thanks Ramirez but actually this was the first thing that I tried, though I should have made this a little clearer in my first post so you didn't have to go hunting for all those files, ;). I just tried it again and it says that the flash memory is unknown so when you try to flash the BIOS it says of course "Error Flash Memory Unknown."

Ramirez
20th July 2003, 22:14
Hmm... Either your MB BIOS chip isn't programmable (highly unlikely) or a particular version of awflash utility needed to flash it.

Have a look at this page > Unknown Flash Type Message (http://www.asus.com/support/english/techref/monthly/mb051999.aspx#q6)

As your last resort you might want to try UNIFLASH (http://www.softnews.ro/public/cat/15/2/15-2-31.shtml) , supposedly this little tool will flash every exiting BIOS chip on the planet. (might completely destroy it as well) ;)

erbuk
21st July 2003, 08:03
Your computers bios will never find drives connected to a separate controller. It only identifies the controller card. When the computers bios has finished executing it starts up the bios on the controller card. Then the controller cards bios identifies the drives connected.

The drives will not be detected by your operating system like the drives connected to the motherboard. You need to install drivers for the controller card to make them accessable. In newer os (like 2000) the drivers are included but in older ones like DOS you need to install/load them manually from Maxtors driver disc.

To install windows on a blank drive connected to the controller you must first make driver-disks for the controller. How you do that is decribed in the installation guide for the card (Option C: installing drivers during a new...").

An easier alternative is to keep the os on the old harddrive (connected to the motherboard) if it still works and use the new one for programs and data.

erbuk
21st July 2003, 11:50
I forgot the memory problem. I've had that a few times too, especially with newer single sided modules with only two memory chips (but also with a few other). I'm afraid it has to do with the chipset, not the bios. So updating your bios will probably not help.

You should try to get the memory module replaced by another type/brand.

BoNz1
28th July 2003, 02:16
Ok guys thanks a lot for pointing me in the right direction. I have got the hard drive to work. I sort of assumed that the drivers I loaded from the cd for the hard drive and for the card should have been enough but I guess I was wrong. Since, this is a knowledge base of sorts I think I should share what I did, I downloaded these drivers Ultra ATA Driver (http://www.maxtor.com/en/support/downloads/atadrvr.htm) and put it on a floppy then when windows 2000 started up I hit F6 and it installed it off the floppy. Actually, it was really easy. As for the RAM the manual for the mobo says it supports up to 256MB single and double sided but this is for PC100 RAM, I put PC133 RAM into it. Could be that this is the problem. Anyhow thanks for all the help again, sorry I was a little late replying I have been working like crazy and haven't had the time till today to even look at it.