PDA

View Full Version : VFAPI reports .d2v file is invalid


technolog
22nd February 2003, 12:35
Since I upgraded DoItFast4U! to v.1.0.9.0 (not saying that's the cause, just the only thing I can think of that's changed) when I try to load a .d2v file into VFAPI to convert to .avi for re-encoding in CCE, VFAPI gives the error message '*.d2v file is invalid'.

Can anyone offer any help please.

TIA

technolog

hakko504
22nd February 2003, 13:02
A few things come to mind: First check that you still are using v1.76. Then make sure you haven't moved anything, filepath's are hardcoded into the .d2v. And finally make sure you have RGB scale selected in DVD2AVI when you creat the .d2v. AFAIK vfapi is the only application that actually checks this setting before using the file.

Hint: open the .d2v in notepad. The first few lines will tell you both path and colorspace.

technolog
22nd February 2003, 14:30
Thanks hakko.

I'm afraid I'm not knowledgeable enough to see a problem with the .d2v file in Notepad but I included the first few lines here. If you, or anyone else for that matter, can spot anything wrong, I would be very grateful if you could post the info here:

DVD2AVIProjectFile
1
21 VTS__02_P01.4~3_1.M2V

Stream_Type=0,0,0
iDCT_Algorithm=2
YUVRGB_Scale=1
Luminance=128,0
Picture_Size=0,0,0,0,0,0
Field_Operation=0
Frame_Rate=25000
Location=0,0,0,32F89

7 0 0 2 2 2 2 2 2 2 2 2 2 2 2 2 2
7 0 28 2 2 2 2 2 2 2 2 2 2 2 2
7 0 9B 2 2 2 2 2 2 2 2 2 2 2 2
7 0 103 2 2 2 2 2 2 2 2 2 2 2 2
7 0 152 2 2 2 2 2 2 2 2 2 2 2 2
7 0 1C3 2 2 2 2 2 2 2 2 2 2 2 2
7 0 233 2 2 2 2 2 2 2 2 2 2 2 2
etc. etc.

The path is g:\WINDTALKERS\VIDEO_TS\VTS02\VTS__02_P01.4~3_1.d2v
and the .m2v file is in the same folder.

I'm still using DVD2AVI 1.76 manually and looking at the DIF4U! folder the special version (CLI) version it uses is still 1.76.

Where should the VFAPI files be installed? I have sub-folders READER & CODEC in the DVD2AVI folder with VFAPI files in them.

technolog

hakko504
22nd February 2003, 15:02
I see one strange thing: there is no path on line 3, just the file name. Try changing this to 21 g:\WINDTALKERS\VIDEO_TS\VTS02\VTS__02_P01.4~3_1.M2V and see if it helps. And the only file that is needed should be DVD2AVI.vfp and it should be in the main folder of DVD2AVI, assuming vfapi is correctly installed. And in DVD2AVI under the help menu you should find a vfapi option: make sure it is checked.

Or you can try AviSynth instead. It will be faster than vfapi, but there is some quirks when you feed the script to CCE. Read more here (http://www.avisynth.org).

Eyes`Only
25th February 2003, 20:23
Due to user requests, all files DoItFast4U uses are now kept in the install directory. This confuses VFAPI. The easiest solution is to copy your VFAPI executable (ie. VFAPIConvEN.exe) to the install directory and use it for all *.d2v created from DoItFast4U projects.

This is now in the FAQs section of DoItFast4U's home page.