PDA

View Full Version : XVid Editor?


Chain
17th February 2003, 21:01
Is there a program out there that is capable of editing XVid avi files? All I really want to do is split the file in half, but Premiere will not let me load the file. Thanks for the help, Chain.

seewen
17th February 2003, 21:03
VirtualDubMod http://sourceforge.net/projects/virtualdubmod

rpiepoli
18th February 2003, 15:01
See OGMCutter from http://cyrius.bunkus.org/index.html

Chain
19th February 2003, 07:40
VirtualDubMod and VirtualDub both give me the same results when trying to cut the movie in half. Basically I deleted the half of the movie I didn't want, then went to save as avi file. The result always came out that the video pauses for a split second in spots, where as the audio continues playing smoothly even while the video was pausing. It was not long before the audio was 3-4 seconds ahead of the video.

I chose 'direct stream copy' since I don't want to change from the XVid compression. All of the other methods produce files that are much too large. Any idea what would be causing the video to 'pause' like it is?

Koepi
19th February 2003, 07:45
Rename your movie to *.avi, open it in oggmux, choose a splitsize, hit Mux and "ok" all error messages (no soundfiles to mux blabla).

Rename the resulting peaces to *.ogm again.

Should work fine.

EDIT: hm. Maybe you should really head for an OGM container instead of avi container ;)

Regards
Koepi

NuclearFusi0n
19th February 2003, 08:07
Originally posted by Chain
VirtualDubMod and VirtualDub both give me the same results when trying to cut the movie in half. Basically I deleted the half of the movie I didn't want, then went to save as avi file. The result always came out that the video pauses for a split second in spots, where as the audio continues playing smoothly even while the video was pausing. It was not long before the audio was 3-4 seconds ahead of the video.

I chose 'direct stream copy' since I don't want to change from the XVid compression. All of the other methods produce files that are much too large. Any idea what would be causing the video to 'pause' like it is?

Audio > Interleaving (or just press CTRL + I)

change preload to 96
change interleave audio every to 96 ms, NOT FRAMES.

hit ok, set both audio and video to direct stream copy, and go for it.

Selur
19th February 2003, 13:03
"that the video pauses for a split second in spots,"
only cut at I frames

Chain
19th February 2003, 20:37
Hrm, well thanks for the help guys however its still bugging out on me, I think I'm about to give up heh. As an experiment I load one of the original XviD files and didn't edit it at all, just said direct stream copy and save as avi. The same thing happened, pauses in the video every few seconds and the file was 2 MB smaller. At first I wasn't using key frames to mark so I thought that was gonna be an easy fix, but no luck. The audio interleaving settings didn't work either.

Basically my plan was to split my 700 meg XviD files in half and create SVCD's using nero. I've tried to go through some other avi-svcd guides but no luck, I get errors in programs. If someone pointed me in the direction of a good XviD to SVCD guide that would be great, since I guess that is what I am really looking for.

The Edge
19th February 2003, 23:09
If someone pointed me in the direction of a good XviD to SVCD guide that would be great, since I guess that is what I am really looking for.

http://www.doom9.org/mpg/dvd2svcd-avi.htm

Edge

Liisachan
20th February 2003, 04:46
this may be an irrelevant answer for your case,
but just in case:

1) if the audio part is vbr mp3, Vdub / VdubMod cannot edit it correctly, even w DirectStreamCopy (the same is true for AviUtl)

2) in that case, vdubMP3 / nandub should work fine.

NuclearFusi0n
20th February 2003, 05:21
Originally posted by Liisachan
this may be an irrelevant answer for your case,
but just in case:

1) if the audio part is vbr mp3, Vdub / VdubMod cannot edit it correctly, even w DirectStreamCopy (the same is true for AviUtl)

2) in that case, vdubMP3 / nandub should work fine.

just check on the "nandub VBR compatibility" box in the open dialog.