PDA

View Full Version : How do keep the menu on WB titles after reencode?


AlainDelon
12th August 2002, 12:46
In order to reencode Warner Bros dvd's you have to strip out logo,trailers or other junk at the beginning of the FIRST 0.99gb vob file of the movie but when everything is reassembled,the menu will point to the wrong part of the movie since you deleted part of the first vob.It seems that when you press "play movie",it starts a couple of minutes in.Can you edit the start point in the Ifo file?

AlainDelon
16th August 2002, 11:31
Anyone?

snidely
16th August 2002, 20:40
Chances are that you stripped out more than just the logo. You have to be very careful when you strip out the VOB ID that contains the logo to make sure that the VOB ID doesn't contain more than you thought. If it does, you need to use VobEdit to break the VOB down into cells, delete the one cell that contains the logo, and then rejoin the remaining cells.

AlainDelon
17th August 2002, 10:21
Are you saying that i have to keep the logo(id1)& the trailer(id2) in order for it to work?I stripped those out with IfoEdit before reencode because the logo messes up rempeg2 & save 200MB space(trailer).I would like to just keep the original menu+movie,no extras.

snidely
17th August 2002, 16:16
No, what I am saying is that you need to be careful that ID 1 and 2 contain only the logo and the trailer, and do not contain any of the actual movie. Also, how did you strip out IDs 1 and 2? If you give me the name of the particular movie, along with your EXACT procedure, then maybe I can tell you where you went wrong. I have done well over a hundred movies, including many WB titles (which I have successfully ReMPEG'd), and this has never happened to me, so there must be something wrong in your procedure.

AlainDelon
17th August 2002, 21:16
The movie is Miss Congeniality and ID1 is WB logo,ID2 is the trailer & ID3 up is the movie.I stripped out ID1 & ID2 with IfoEdit,rempeged the movie to 4.21Gb.It play's fine as movie only but i would like the original menu since it's only 4,88Mb big so i copied all menu related files including title2 but exempting the 851Mb vts_02_1 vob.Every thing works including navigating the menues exept if you start the movie it doesn't start from the beginning.This make sense since the logo & trailer aren't there anymore so i was thinking maybe you can edit the ifo file somehow when you know exactly what you took out.

snidely
17th August 2002, 22:44
Hmmm...I don't have that movie, but I can probably experiment with another WB title. You have tried something that I have never tried...ReMPEG'ing the movie and keeping the menu. Whenever I ReMPEG a title, it is because it is too big, so I always dump the menus, extras, etc. On WB titles, I strip out the logo at the beginning and then ReMPEG the movie only, with no menus, so I let IfoEdit create new Ifos, and the movie always plays fine after that.

Here are some ideas:

1. When you strip out the logo and the trailer, does the movie itself start right on a chapter point? Or do you have an extra cell preceding the first chapter? The menu might be looking for the first chapter, and if the first chapter is not the new beginning of the movie (since you have now stripped out some stuff), that might be why it starts late.

2. What version of IfoEdit are you using? If you used 0.932, it should have fixed the above problem, but if you used an earlier version, it wouldn't have fixed the problem.

3. If the movie is too big, why are you keeping the menu? You must have discarded any extras, so what purpose does the menu have? If numbers 1 and 2 above are not the cause of your problem, then I would recommend taking your original full DVD rip and using IfoEdit 0.932 to rip out the movie only (using the top menu "movie only/strip streams") and then checking the box "strip VobID's", keeping all but Vob IDs 1 and 2. This will cause IfoEdit to create new Ifos, yet the logo and trailer will be removed. Now you can ReMPEG the movie, remux, and it should work fine, and maybe if you add the menus back (do not replace the new Ifos, though), it might start in the right place. Or I might try just replacing VIDEO_TS.IFO with the original, but not any of the other Ifos.

AlainDelon
19th August 2002, 10:49
I spent the better part of a day on this adding back the logo & trailer in front of the first vob.It sort of worked at the start but got progressivly worse as the film goes along because the chapters just don't line up anymore.No amount of re-Ifoing would correct this.One reason i like Rempeg2 is that it's so simple & that chapter and subtitle information is still there after re-encode.The reason to keep the menu would be because it's small(4.88Mb),nice looking & contains cast & crew info that's cool to have.But my final thought is that it's not worth the trouble.

tomti
9th October 2002, 23:52
Hi

I'm trying to copy dirty harry region2 to DVD-R
I've deleted the WB logo and a trailer. In order to do do i've demuxed the VTS_O2_1.vob by cell id. Then i deleted the 1st and 2nd id.
Then i've remuxed my vob file. When i play this vob file back in a software player it is ok : it starts from the beginning. When i start the complete movie (still with the software player) in file mode, the menu appears and when i hit the play button the movie begins but not from the start. It starts not even at ID3 but somewhere after the beginning of ID4 of the remuxed vo file.

I've been successful with other WB movies. But with this one i surely have to modify something else to tell the player where to begin. I replaced "jumpTT to title 2" by the usual "jumpSS to VMG title menu" and this time it is not enough.

Sorry for my bad english. Thanks if you can help. I thinks I've read all the WB posts and didn't find the solution.

Thanks a lot.

pornstar
10th October 2002, 03:40
Hey guys,
I've done the same thing you have done with WB titles
and it works just fine. Did you remember to press the
Get VTS Sectors button???

I do recall mine starting a bit into the movie before
I pressed this button and then afterwards it worked
perfectly.

Just a thought.

-p0rnstar

tomti
10th October 2002, 08:02
yes i did it. doesn't work ;(

Chumboy
11th October 2002, 19:35
tomti,

you cannot delete the first and second vob_id's. you MUST not touch the 1st and last vob_id. you can only rempeg the 2nd through the second to last vob_id. something about time codes in the first and last vob_id that need to be left untouched.

hope this helps.

see mpucoders "how-to" on this at his site.

tomti
11th October 2002, 19:50
I'll try to find a post there so...Because i really need to delete these things...If i don't delete the WB logo, rempeg will behave badly. And the following trainer is taking some precious place.

thanks