PDA

View Full Version : Can't register avisynth.dll (again!!)


droolian01
10th August 2002, 03:37
I really hate to post this in a new thread, but have done a quick search and got no joy.
Just built my new encoding bos yesterday and a very keen to get it going but tried running the 'register' with no luck, even tried dropping avisynth.dll onto regsvr32 and came up with the error:

c:\windows\system32\avisynth.dll was loaded, but the DLLRegister server entry point was not found.

This is the first time i have used win xp (in win 98 i have no difficulty registering new avisynth versions. I resorted to installing GordianKnot so now i can edit .avs scripts in vub, but would like to know how to get the lastest version of avisynth registered.

sorry again for asking this, i feel quite stupid but i am a total win xp virgin, and am desparate to see how fast my new xp2100+ asus a7v333raid system works.

Thanks.

trbarry
10th August 2002, 05:07
I thought there was an install.reg file you should click on. But maybe this is a different version.

- Tom

Schultz
10th August 2002, 05:19
trbarry you are right you don't run Regsvr32 on avisynth.dll you just put it in your system/system32 dir and double click the install.reg file that comes with the zip file..

Richard Berg
10th August 2002, 05:39
I've never had to register the DLL either. Sticking the appropriate bits into the registry is good enough to make Avisynth show up next time VCM modules are enumerated; ditto for its hijacking of the file associations, etc. etc.

droolian01
10th August 2002, 10:49
Did all the above and still 'version()' showed 1.0 beta 5

UNTIL

DOH! - did a restart now shows 2.04

Sorry for being stupid!:stupid: :rolleyes:
Please kill this thread