PDA

View Full Version : SVCD Sound Question


Hacksaw
20th June 2002, 00:53
Howdee peoples,

I have a quick question on SVCD audio. How would I know if my DVD player doesn't support 48 KHz audio? The reason I am asking is that when I encode an SVCD from a DVD using DVD2SVCD it plays fine on my PC, but on my DVD player the voices sound a little deeper than normal, almost like the audio is playing slower than it should but it never gets out of synch. For example, Buzz Lightyear sounds like a male porn star.

I would like to avoid ripping the DVD again just to try down sampling. Anyone know if this is what I am experiencing?

Thanks!

gerti67
20th June 2002, 01:18
Hello Hacksaw,

welcome to the forum. ;)

You could try to only encode a small chapter of the DVD with the downsample option checked to see if this cures the problem with your player - this will take only a few minutes and not hours. See the Q&A (Q46) on how to do this if not already done.

In addition, you can search www.vcdhelp.com and their compatibility list for your standalone model and see the comments of the other owners. Perhaps this will give you some hints.

Hope that helps,
Gerti

Hacksaw
20th June 2002, 01:48
Wow - now that was fast service!

Checked vcdhelp.com and there were no notes with respect to my specific SVCD audio question. I don't have a problem with standard SVCDs so I assume it is the sampling rate.

I still have all the files from the original rip - would it be easier to re-encode the audio and then join it with the already processed video?

Thanks for the warm welcome and the speedy reply :)

gerti67
20th June 2002, 13:39
Hi Hacksaw,

if you still have all the files the please proceed like this:

1. Open the "Encoded_audio_1.log" in Notepad.

2. Now edit the BeSweet command line and add the following parameter: " -ssrc( --rate 44100 )" right before the "-mp2enc" parameter. So it should e.g. read like this:

D:\Programme\DVD2SVCD\BeSweet\BeSweet.exe -core( -input G:\Conversion\Test2\Extracted_audio_1.ac3 -output G:\CONVER~1\Test2\Encoded_audio_1.mp2 -logfile G:\CONVER~1\Test2\Encoded_audio_1.log ) -azid( -L -3db -c normal -g max ) -ota( -d -128 ) -ssrc( --rate 44100 ) -mp2enc( -e -b 192 -m s )

3. Copy this edited command line to the clipboard

4. Open a DOS window, paste it over there and hit ENTER

5. Now BeSweet will transcode the audio again but now with 44.1 kHz

6. Now re-start DVD2SVCD and do a "Recover" from the "Muxing and Cutting"

So you will end up with some newly created images with 44.1kHz audio and it should only take about 30-60 minutes to finish.

Hope that helps,
Gerti

Hacksaw
21st June 2002, 03:30
Gerti,

Thanks so much. I spent two hours last night and figured it all out. Gotta love the extensive documentation that comes with these tools ;-)

Tried the downsampled audio in my DVD player - works perfectly.

Thanks again for all the help,
Hacksaw.