PDA

View Full Version : Access Violation


msorgen
1st June 2002, 11:19
I get an access violation at address 0049160c in module dvd2svcd.exe
The read of address chnages each time I tried a different movie. The last one was 02378001.

Whats causing this and how do I fix it.

mrbass
1st June 2002, 19:49
is this when you hit the cd icon while it's trying to authenticate the dvd? aspi drivers is my guess in the Q&A.

mdungan
1st June 2002, 20:10
hello..

the problem with acess violation can be that u dont have subtitles in
a dir named subs. or something they have to bee in a different dir.
that was the problem for me .
a little tip SEARCH THE FORUM
// morgan

msorgen
2nd June 2002, 00:49
This occurs after it has converted all but the last file.
I did search the forum first before I posted my question.
I found nothing related to access violations.

chainsaw135
3rd June 2002, 07:01
msorgen did you fix your problem, and if so what was the fix?

msorgen
3rd June 2002, 13:09
No. I still have the same problem. I download a movie using DVD Decrypter and then use DVD2SVCD to convert it to MPEG.
I have tried several movies, all with the same results.

Assuming I have 6 VOBs, when I reach VOB6, I get the Access violation.
When I look in the folder where it wrote the first 5, I see its still in VOB. I thought it was supposed to convert it to MPEG?

gerti67
3rd June 2002, 15:30
Hi msorgen,

please use the "Internal Routines" of DVD2SVCD first in "DVD Rip" tab, as ripping with other Rippers can cause some problems.

Greetings,
Gerti

markrb
3rd June 2002, 16:12
By any chance are you using Pop-up stopper?
I remember some posts about DVD2SVCD causing an access violation when run at the same time as this program. Try uninstalling it if you do have it.

Mark

msorgen
3rd June 2002, 19:36
I havent a clue as to what a stopper is, so I doubt if I used it.
If I may, I would like to explain what I do:
1) misc tab - I clicked on load settings and entered a name for the 5 choices.
2) ripping tab - I have 'use internal routines' on and "Activate DVD Ripping selected.
3)Conversion tab - I select the IFO of the movie I want to create.
I then click GO.
It then displays two english subtitles and one french. One english tab is already selected. I press enter and off it goes.

I asked a question before - when does it convert itself into MPEG?
I'd be willing to see it cut a CD just for the heck of it with the 5 VOBs written during the conversion.

Jason28
5th June 2002, 00:09
@msorgen
1) misc tab - I clicked on load settings and entered a name for the 5 choices.

What does this mean? You should read the guides on how to rip and how to convert a DVD to SVCD. This would answer your question about when it gets converted into a MPEG.

It then displays two english subtitles and one french. One english tab is already selected. I press enter and off it goes.

I dont know if you are trying to rip subtitles if you arent then this shouldnt appear there.

A pop up stopper is a program that stops pop up ads when you are surfing the interweb. :P

msorgen
5th June 2002, 01:46
I read the forum and the DVD2SVCD rules and it specifically states that you should put names in the MISC tab. If you read the rule you wouldnt be asking the question.

chainsaw135
5th June 2002, 02:12
when this problem happened what exactly did you put in the folder structure under the misc tab?

Jason28
5th June 2002, 02:23
The load settings button is for when you save settings to do different types of encodes. I dont understand what you mean when you said that you clicked there and and entered a name for the 5 choices. All I am simply asking for is clairification so I can help you out. There is no need to insult me.

Here is a quote from the guide: If you want to store the files all in the same place you can go to Misc settings press the Set default output folder option and all files will be stored there.

If that is what you did its much different then pressing the load settings button.

msorgen
5th June 2002, 03:12
I didnt mean to insult you. In the default output folder, I set the
SOURCE FOLDER, AUDIO FOLDER, VIDEO FOLDER, MUXED FOLDER and SUBS FOLDER to their respective names. I tried it just about 20 minutes ago and erased all the names I entered, and tried it again and got the same identical failure.
Please advise.
Thanks

Jason28
5th June 2002, 03:16
When exactly does this error occur? Is it when D2S is ripping the *.vob files or is it when a different part of the program is running? I think the best thing that you can do at this point is post your log file and we will see what is going on.

markrb
5th June 2002, 06:04
I am also confused as to what you are doing. The load settings is for loading the different .ini files(SVCD.ini, VCD.ini, etc), not for creating anything by selecting the top of the two choices(select defualt folder)

I think you are confusing set default output structure that is one button above the loading of the settings. For starters just set on directory to do everything. Have a look at the following picture.

Just to be safe select the load settings and direct it to the DVD2SVCD directory and pick the SVCD.ini file to load. This will reset the settings to original.

Also do as Gerti67 said if you read the Q + A you would have seen that other rippers are not supported and especially DVDdecrypter. Until you re-rip with the internal routines don't ask for more help on the access violation.


Mark

msorgen
7th June 2002, 13:36
My first reply is to Jason28. You requested that I send a log file.
I had sent 3 log files before I started writing to the forum. I never received a reply to any of them and now I am being punished with a strike because I sent a private message to someone. (why is the option available then?)

To Gerti67 - I have read and reread how to use DVD2SVCD and the way the instructions are written (for a newbie like myself), I would still do the same as what I had been doing.

To Markrb - I followed your instructions to the letter. I put in SVCD.ini, took the original DVD and ran it from there instead of from DVD Decrypter. The movie had 5 VOB's. As it started the third VOB my system crashed with a fatal error. Thinking it was something I did, I rebooted my PC and ran it again. Again, after the second VOB was completed, the system crashed again. So now I'm back to square one.
I either run from DVD Decrypter or something like it and get an Access Violation or run it from the DVD itself and the system crashes.

I would really like to solve this and start copying away.
Thanks to all of you for your continued help and support.

chainsaw135
7th June 2002, 21:51
@msorgen just so you know that you should always use internal routines first and vstrip second, and after that if you have a problem after using that then post your problem. We at doom9 have put these rules in to place not to be mean or better then you attitude, but to better serve you and of course ourselves. If your mad because you got a strike then i would go re read the rules and the Q+A so you dont get another one.

markrb
8th June 2002, 00:18
Try these things in this order.

1. Make sure you have as little as possible running. Shut down as much as you can from the system tray. Make sure to shut off your virus scanner and if you have Norton installed shut it off as well.
2. Re-install the force aspi drivers you can find linked in the Q&A.
3. Run Prime95 torture test and mem test 86. You will find both linked in the Q + A (Q53).
4. Start up SmartRipper and watch to see if it goes into Aspi mode or Win mode. If it goes into Win mode there is a problem with your Aspi drivers.

What OS are you using? DVD2SVCD has not been fully tested on 95,98 or ME. It has only been fully tested on 2000 and XP.

You may want to wipe your OS and re-install a clean copy making sure to install as little as possible at first.

Do NOT use DVDdecrypter. It has known issues with DVD2SVCD. Use the included rippers first. If internal fails try Vstrip if that also fails as a last resort try SmartRipper.

What are your computer specs? CPU, memory, motherboard etc...

Mark