PDA

View Full Version : xmpeg audio setup problem


codeMosaX
26th May 2002, 03:01
My setup
WinXP Pro
Xmpeg 4.5
Divx Pro 5.02

I followed doom9's guide for xmpeg. I'm testing a small segment of a movie, but i can't get the audio setting correct. It works with PCM, but with MP3 I get this error message.

An error occured when trying to generate the file. Check that you're not using the output file or the programs is setup correctly.

I've tryied different MP3 codecs (radium, lame, creative mp3, i don't have full range of Fraunhofer MP3)and done a couple of re-installs.

Side note: Flask .60 works with aviout, but not odmlavioutput. Don't know if thats useful or not.

Selur
26th May 2002, 08:41
read:
http://forum.doom9.org/showthread.php?s=&threadid=22576&highlight=An+error+occured+when+trying+to+generate+the+file

codeMosaX
26th May 2002, 21:26
I cleared the MP3 codecs then rebooted. Then installed just LAME MP3 ACM codec. I still have the same problem.:confused:

Selur
27th May 2002, 07:24
U also might want to check that u really deinstalled DivX;)Audio and AngelpotionAudio some forget to delete these,..

Cu Selur

codeMosaX
28th May 2002, 00:31
I cleared divx audio also because i figured i never use it, and i never had angelpotion audio. It still doesn't work. Selur do you need anyother bits of info?

Selur
28th May 2002, 21:00
Strange,.. should work,.. what other audio codecs are installed on your system,... anything unusual? I just remember one time when the normal deinstalling and reisntalling didn't work and that was when the guy had soem strange audio codec installed that he didn't even know (didn't know what it was good for) ;)

Cu Selur

Ps.: also be sure that u are an administrator when u encode, could also be a problem with userrights ;)

codeMosaX
28th May 2002, 23:53
my audio codecs:

Windows Media Audio
MS PCM converter
IMA ADPCM
ADPCM
CCITT G.711 A-Law & U-Law
GSM 6.10 audio
G.723.1
DSP Group TrueSpeech(TM)
Sipro Lab Telecom ACELP.net
Indeo(R)audio software
Ogg Vorbis Audio (for some reason this will not uninstall)
Voxware Compression Toolkit

Selur
29th May 2002, 05:23
Try if it helps if u uninstall the "Sipro Lab Telecom ACELP.net" Codec, checked my systems I since I don't have it, this might be the one causing problems ;)

Cu Selur

codeMosaX
31st May 2002, 10:46
:confused: hmmmm still having problems

Selur
1st June 2002, 19:14
strange,... another strange think is that u can't deinstall the ogg audio acm codec,...maybe there's the problem or with the Voxware Compression Toolkit,..

Cu Selur

codeMosaX
2nd June 2002, 22:04
Don't know whats wrong with ogg audio codec, it still won't uninstall
i wonder if theres any relationship using odmlavioutput on flask and xmpeg, because they produce the same error message.

anyway any ideas on how to remove ogg?

Selur
2nd June 2002, 22:39
No, but maybe some folks over in the audio encoding section can help ;)

Cu Selur

chipzoller
5th June 2002, 16:52
Maybe instead of uninstalling, have you tried to move the priority of the codec you want to use to the top??? Contrary to popular belief, WinNT(XP/2000) can change the priority of the codec. You can do this under the device manager, go to audio codecs, and select the one you have installed that you want to use (radium comes up as the Fraunhoefer codec but in the properties it shows the radium info) and up the priority of it to '1'.



Chip

codeMosaX
7th June 2002, 07:28
i was aware that the priority of the codec can be changed. i have experimented with changing the priorities a little bit. i'm using LAME rather then radium. but trying your suggestion moving LAME to 1 the outcome still gets me an error.

thanx anyway