View Full Version : ASPI 4.70 problems

stevie d
12th March 2002, 13:42
Dunno if this has been documented elsewhere, but I couldn't find it.

I've had big problems with the new-ish public release of Adaptec's ASPI drivers. It causes my WinXP box to blue-screen when I run DVD Decrypter, and this computer has been solid as a rock for ages (this is a fresh Windows installation too). As soon as I revert back to version 4.6 of the ASPI drivers (with ForceASPI) it's fine.

I didn't try any other ASPI-related programs (my IDE drive works fine for everyday stuff), but I'd be surprised if it was just DVD Decrypter that had the problem.

Anyone noticed any similar behaviour?

- steve

12th March 2002, 15:24
Yeah, I had the same problem. Im not entirely sure why it happens...when I get a bit more time, I'll look into it a little more. There might be a 'work-around' for DVD Decrypter, but I tried several ASPI programs when I noticed the problem, and they all blue screened the machine.

Now I just use Ahead's WNASPI32.DLL instead.

16th March 2002, 19:38
I had also the same problem, but not only with DVD Decrypter, but Smartripper as well (it reverts to WinIO mode). What is the best option, installing ForceASPI 4.60 again or sticking with third party ASPI (like Ahead's)?

19th March 2002, 21:50
Hi Lightning...

I've had even more problems...

I have used several older ASPI Layers, than i moved to 4.60, 4.70.
DVD Decrypter .11 & .12 & .13 doesn't work properly with all of these ASPI's.
But if i take DVD Decypter V2.40 all works fine.It seems that these version doesn't need the ASPI Layer's.
Also Smartripper runs only in these "special" mode.

Maybe it would be a solution to put this feature from V2.40 back to the new versions .13 :)

Btw. i use XP Professional with an really old (but still working so far) Intel 450 Mhz PII.

20th March 2002, 00:03
> I have used several older ASPI Layers, than i moved to 4.60, 4.70.
DVD Decrypter .11 & .12 & .13 doesn't work properly with all of these ASPI's

Define 'doesnt work properly'. Do you get an error message? if so, what.

v2.4 only uses aspi for authentication. v3 uses aspi for everything.

Ive never had any problems my end. And you're the first person to complain about the older aspi versions. perhaps I overlooked something.

20th March 2002, 00:33
I tried now a old version...
V4.01 (ASPI Layer)
Believe it or not...
It works now

If i install newer versions the following error occurs from dvd decrypter .13 (also .12 etc. except V2.40) :

UDF Parsing not found
(and in the log the message says that i wouldn't found a device through the ASPI Layers)
This Error occurs only to my Internal SCSI Drive

If i switch to my Pioneer Burner from DVD Decrypter than it works fine with all newer versions of Adaptec's ASPI Layer (old ones too).
I preferr my internal DVD Drive coz its much faster than the lame Pioneer Burner.

So my conlusion is now:
with my SCSI internal DVD Rom it only works with those old ASPI Layer V4.01 and than with all DVD Decrypter Versions
If i install new versions it shows the above errors and only the DVD Decypter V2.40 works

with my internal ide/atapi pioneer burner all ASPI Layer Versions work fine and all DVD Decrypter works also fine

And still i dont know why it not works with new ASPI Layers :)
Maybe you have now a better understanding what should be happen...

But anyway... thx for this great Proggy

Final Questions:
Is it very important to have the newest version of DVD Decrypter for the ripping process ?

Does it play a role for the ripping process to have the latest ASPI Layer (4.70) ?

20th March 2002, 09:01
IF your drives are missing under some aspi layers (ie the new ones), then you have a problem somewhere. Check the FAQ in this forum....I added the answer to that problem in there the other day.

Can you please be a little more specific as to the error. 'UDF Parsing not found' is not an error message DVD Decrypter would EVER say. :-)

Why not give the nero wnaspi32.dll a try....download it from ftp://lightninguk.dns2go.com/wnaspi32.dll and put it in the same folder as dvddecrypter.exe - I think it only works under NT / 2000 / XP though.
If it all works ok, move that dll into your windows\system32 folder and overwrite the one that is there.

20th March 2002, 10:42
I check the .ddl today...
At the moment all works fine so i don't want "test" the other ASPI Layer Versions to see the exactly error message :) .

And thx for your replys