PDA

View Full Version : * Help with GraphEdit...


jcauldren
27th February 2002, 20:11
I may be guilty of cross-posting here, but I've received no responses from my previous post (in "newbies"). Eh, that my have had something to do with not having the "*" before my subject.

anyway...

I've read thru the guides and have successfully extracted the video that I want and am now trying to get the audio. I've used, in order, Smart Ripper (2 .vob files and 3 .ac3 files), DVD2AVI (1 .d2v file), VFAPIConf (1 .avi file) to get the video.

To get the audio, im using the "Graphedit & Vob2audio Guide" from the guides page. I've registered the VFAPIConf and GraphEdit components and am now running GraphEdit to generate a .wav file. However, after opening the graph, the "MPEG2 Splitter" does not have 3 .ac3 nodes available. There is only one and upon playing in GraphEdit, it is not the right language for what I need. The guide states that you should be able to delete the connecting line and re-join from a different ac3 node, but no other ac3 nodes exist.

Can anybody help?

Thanks for your time,
Jamie

MaTTeR
27th February 2002, 21:05
It's much easier for you to extract the AC3 files using DVD2AVI. It also names the file with the correct delay.

Tes
27th February 2002, 21:59
After you demux the audio with DVD2AVI you can then transcode the resulting AC3 file to Vorbis (check out the Ogg Vorbis guide).

At least that is what I would do. ;)

jcauldren
27th February 2002, 22:44
MaTTeR:

I did use DVD2AVI to extract the .ac3's. I do get the .ac3's named with the correct delay. Im at the point in the guide where you generate a .wav from the .ac3 file(s). Also, I did use the search button to find my way to the guide that Im using now:

"Graphedit & Vob2audio Guide - last updated 5/24/01
How to convert a VOB to WAV/p>"


Tes:

Thanks for the advice, I'll try the Ogg Vorbis guide.


Im just concerned that I'll still get a .wav that wont be in the language I want (I'd like engligh, I keep getting french; i think). This whole process did work for the 1st chapter of the DVD, I've skipped ahead to another chapter and am only now having this problem.

Thanks,
Jamie

MaTTeR
27th February 2002, 22:54
@jcauldren

The easiest way to ensure you get the proper AC3 track is to use stream processing in Smart Ripper. Turn off all the subs and foreign language tracks you don't need and then rip. After that use DVD2AVI to demux the AC3. Here are the audio settings I use in D2A-

Track Number- None
Channel Format- Dolby Digital
Dolby Digital- Demux all tracks
48->44kHz- Off

That's it! To transcode your AC3 you can use HeadAC3he or BeSweet. I use HeadAC3he to transcode the AC3 to Vorbis:)

Acaila
27th February 2002, 23:02
If you use stream processing in SmartRipper already then you don't need DVD2AVI to demux the AC3. All you have to do is tick "Demux to extra file" instead of "Stream copy" in SmartRipper and it will do the same thing as DVD2AVI.

Saves you the extra step.

MaTTeR
27th February 2002, 23:29
@Acaila

I had problems with corruption while using that method in the past. Azid would always complain of improper frames. Perhaps I need to try it with Azid 1.8 now.