View Full Version : Major problem with directvobsub...

21st February 2002, 15:24
I've reinstalled my computer, this time using Windows XP. So I download a lot of software I need, one being directvobsub. Problem is, it can't seem to register with the system. After running vobsub209 installer everything seems ok. So I launch ZoomPlayer and load an AVI. When I try to activate the subs, nothing happen. I try to load the properties of the directvobsub filter, nothing happens. What's wrong? How can I force dvobsub to register? There's no .inf file anymore to load...

I tried to install this on another computer aswell. (Also running XP, but this one upgraded from Win2K which had DVobSub 1.07 installed previously). Everything works on that computer, I even get a nice little systray icon with properties for DVobSub and some other directshow filters...

Hope someone can help me fix this...

PS: Yes, I am running with administrative rights...

21st February 2002, 22:30
Is the movie a Oggmovie?I have problem to activate subtitles if the movie is in the Oggformat.

22nd February 2002, 09:36
Install v2.03. Or may be that subtitle doesnt work. If sub file is large (~5M) you need also idx file or try to change language.

23rd February 2002, 18:31
It's a standard DivX file, and the subfile is not large. The problem is with DVobSub. It won't register AT ALL. It's not there! I can't access the config, and it won't show up as a filter in ZoomPlayer. On another machine I tested this with, I got a little icon in the systray to enabled properties and stuff for the filters, but NOT on my computer.

It copies the files, and that's about it. Nothing happens!!!

24th February 2002, 19:44
Did U try to tell XP to install in compatibility mode ?
Some progs only install that way....
XP behaves in a strange way...specially the corporate edition.
It seems there are a lot of "corporate editions" :-) :-) :-)
(all of them are different)
Home edition has no prob with registration....(yes I know I am stupid but I bought it...)

25th February 2002, 12:17
Try running "regsvr32 DVobSub.ax" in System32 directory, it should register filter.

26th February 2002, 20:47
Originally posted by Roger
Try running "regsvr32 DVobSub.ax" in System32 directory, it should register filter.

Yeah, I know, I tried that :-( Didn't work. What I really find WEIRD is that it worked on the other computer... both PCs were installed from the SAME CD. Only difference being one was upgraded and the other was a fresh install. I'm really ticked off at this OS, it keeps killing my wireless bridge aswell :-/.

28th February 2002, 15:53
Old problem, with DirectX8.1 (and XP) all those problems started.

Try to open up the sub.avi graphs from _inside_ the wmp, then he finds the correct directory. It's a nasty workaround, but at least it usually works.

5th March 2002, 09:21
Now you lost me totally, how do I open a graph in wmp?

Are you people saying theres no fix for this? Maan...

5th March 2002, 09:50
hmmm..i wish i had read your post earlier before i had posted mine ...i have the same problem....everything worked fine on my old instillation now i reinstalled and everything has gone bezerk:)...i hope someone has some tips for us!!

5th March 2002, 09:55
gojensen: Usually graphs are made so that you can run a subtitled second track with the default avi. Therefore, you create a graph and save it as movie.sub.avi. And by opening this movie.sub.avi in wmp, you get to replay things.

All I'm saying is that you have to open this movie.sub.avi from _within_ the wmp using File/Open from the pulldown menu and NOT by doubleclicking on it in the file explorer.

5th March 2002, 09:57
Hmnm..i have tried thata s well mentar ..but never seems to pick up the subs with it...:(...the movie plays however no subs:(..while all sub files are in the same folder!!

5th March 2002, 10:01
caprioles9000: Do the subs show up in graphedit? When you play the movie there?

5th March 2002, 10:20
hmm havent tried grapedit !!! will try it!!

7th March 2002, 19:55
Mentar; I'm still not following you. Why would I make a new avi? (And how???) I have three computers here. One with W2K, one with XP upgraded from W2K with vobsub preinstalled, and one with plain XP. Everything works fine on the first two, I get the avi, create the .srt files and pop them into Zoom Player (or wmp). On the third computer nothing happens... It's almost like dvobsub.ax wasn't there, though it is, and I've registered it multiple times. Check all computers, there are registry settings on the two that work, but not on the one that doesn't. The problem is of course that the one that doesn't work is the one I want to use... :-(

7th March 2002, 20:42