PDA

View Full Version : VobSub in VirtualDub, really making me mad


kev0ut
3rd February 2002, 21:11
I followed the guide on this site exactly. I've searched the forums for solutions to this stupid problem. But no matter what I try, I can't get these f#$&ing subtitles to work.

I'm using VobSub 2.08, it opens the ifo fine, it indexes it fine, but the subtitles just don't show up. I get no errors, no crashes, but no subtitles either. WTF could I possibly be doing wrong? Keep in mind that for some reason, following the guide step by step does not work.

FactorM
3rd February 2002, 22:32
do you want to burn in the subtitles?

kev0ut
3rd February 2002, 22:44
yes i want to burn them into the avi.

i'm only making small clips of kung fu movie fight scenes, so i don't want to have a separate subtitle file.

kev0ut
5th February 2002, 03:16
...anyone?

gabest
5th February 2002, 06:52
Look into the idx file and check if the timecodes aren't way out of the range of your small clip. And also check the langidx: entry, may be it isn't pointing to a valid track.

AsPiRiN
5th February 2002, 14:35
:D
I had the same problem and i got a "wrong verion" error sometimes
If it is the same with you, you have wrong version of vobsub and directvobsub. The trick is to have the same version, so download the full package and just install it!
Hope it works.

kev0ut
6th February 2002, 05:02
i cant find this "full package" anywhere. all i can find is the vobsub 2.08 package. i already have that and thats what im having problems with. whats the right one?

kev0ut
6th February 2002, 06:13
ok im back again. still doesnt work. i'm using the following file versions:

smartripper: 2.41
dvd2avi: 1.74 (shouldnt matter)
vfapi: 1.04 beta (shouldnt matter)
virtualdub 1.48
vobsub 2.08

im still seeing no subtitles at all. this is a region 2 PAL dvd. is vobsub incompatible? i am at a wall here.

AsPiRiN
6th February 2002, 09:18
Just open vobsub and directvobsub and check if they are the same version. If yes, then the problem is elsewhere...(I have region2 pal too,that doesnt matter)
(you can find vobsub 2.09 here: http://vobsub.edensrising.com/vobsub.php

gabest
6th February 2002, 11:06
The .idx file versions should be backwards compatible. If anybody has a problem opening something with the latest vobsub release, then send me those files.

kev0ut
7th February 2002, 03:25
OK, still doesn't work so I copied the contents of the idx file below and attached the .sub file. Just rename it from txt to sub. The reason there are so few subs in the list is because it is only a 4 minute clip, its own vob file. Maybe something in here can tell you wtf is wrong and why these subs won't show up. If not, I'll just give up on vobsub.

# VobSub index file, v7 (do not modify this line!)
#
# To repair desyncronization, you can insert gaps this way:
# (it usually happens after vob id changes)
#
# delay: [sign]hh:mm:ss:ms
#
# Where:
# [sign]: +, - (optional)
# hh: hours (0 <= hh)
# mm/ss: minutes/seconds (0 <= mm/ss <= 59)
# ms: milliseconds (0 <= ms <= 999)
#
# Note: You can't position a sub before the previous with a negative value.
#
# You can also modify timestamps or delete a few subs you don't like.
# Just make sure they stay in increasing order.


# Settings

# Original frame size
size: 720x576

# Origin, relative to the upper-left corner, can be overloaded by aligment
org: 0, 0

# Image scaling (hor,ver), origin is at the upper-left corner or at the alignment coord (x, y)
scale: 100%, 100%

# Alpha blending
alpha: 100%

# Smoothing for very blocky images (use OLD for no filtering)
smooth: OFF

# In millisecs
fadein/out: 50, 50

# Force subtitle placement relative to (org.x, org.y)
align: OFF at LEFT TOP

# For correcting non-progressive desync. (in millisecs or hh:mm:ss:ms)
# Note: Not effective in DirectVobSub, use "delay: ... " instead.
time offset: 0

# ON: displays only forced subtitles, OFF: shows everything
forced subs: OFF

# The original palette of the DVD in PGC#1
palette: 101010, 2b2b2b, ebebeb, ec460d, 7d7d7d, b4b4b4, 0cb4ea, ec15ec, ebff0b, 0e007f, 0c7b0c, 7e2a0e, 0d637c, 7e127e, 7d960c, ebebeb

# Custom colors (transp idxs and the four colors)
custom colors: OFF, tridx: 1111, colors: ec460d, ebebeb, 2b2b2b, 2b2b2b

# Language index in use
langidx: 0

# Nederlands
id: nl, index: 0
# Decomment next line to activate alternative name in DirectVobSub / Windows Media Player 6.x
# alt: Nederlands
# Vob/Cell ID: 1, 1
timestamp: 00:00:16:880, filepos: 000000000
timestamp: 00:00:18:480, filepos: 000001000
timestamp: 00:00:39:440, filepos: 000002000
timestamp: 00:00:49:160, filepos: 000003800
timestamp: 00:00:51:520, filepos: 000004800
timestamp: 00:01:00:760, filepos: 000005800
timestamp: 00:01:03:760, filepos: 000006800
timestamp: 00:01:06:440, filepos: 000007800
timestamp: 00:01:09:200, filepos: 000008800
timestamp: 00:01:30:160, filepos: 000009800
timestamp: 00:01:31:600, filepos: 00000a800
timestamp: 00:03:50:080, filepos: 00000c000
timestamp: 00:03:54:880, filepos: 00000d000
timestamp: 00:03:57:120, filepos: 00000e000
timestamp: 00:04:06:920, filepos: 00000f000
timestamp: 00:04:10:440, filepos: 000010000

kev0ut
7th February 2002, 05:31
ok 1 more update to give you more info towards trying to help me figure this out...

i tried another dvd, the subtitles worked fine.

i played this clip that i'm trying to rip in the dvd player, and it turns out that these are forced subtitles. does that make a difference, and is there a setting to fix this so vobsub displays them correctly?

kev0ut
8th February 2002, 05:08
well, after bullshitting with vobsub for the past 3 nights i have officially given up on it. i decided to use subrip, then the srt->ssa converter, then the ssa plugin for vdub...it worked perfectly my first try. (as a nice bonus i get to choose the font)

gabest, your program works perfectly for my region 1 ntsc dvd's. however i have many hong kong legends region 2 PAL dvd's, and vobsub does not work on any of them. i have no idea why, but maybe those files i gave you can help you figure it out.

but thanks for all your suggestions everyone, even though none of them worked :)

brett
23rd February 2002, 20:38
I'll bet there was just a problem with your .ifo file. When you use SubRip, it doesn't use the .ifo file.