PDA

View Full Version : Graphedit+Vobsub Configuration Help


oeran
26th January 2002, 09:06
Hmm before my computer crashed, everything was working fine. I would create a new sub.avi with a new audio track then the video.avi file that plays subtitle.

Now that I reinstall my system win2k and added in directx 8.1 and media player 7.1, and installing graphedit an vobsub 2.08, everything isn't working anymore. All my previous playable sub.avi when I double click it to play would show error message of unknown file format with
WMPlayer., and when I go and try to make new sub.avi with graphedit,
I get error message "wrong file version!" when I try to load the .idx file with the vobsub filter for graphedit, and so I can't create a new sub.avi file. I can't play old files, can't create new files, man this really suck :(.

This giving me a headache. Anyone know what i'm missing or what I need to fix this problem. Vobsub have not been really good at compatiability issue with new version. It seems idx,ifo,sub file created with an older vobsub version don't mix well with new vobsub version thats' install.

Any help really appreciated.

gabest
26th January 2002, 15:52
If you get a "Cannot open. Please verify that the path and filename are correct and try again" message then it was sent from the file source filter after it fails to locate its source avi. Unfortunately this seems to be a bug (or rather microsoft's dirty move :rolleyes: ) in dx81.

oeran
27th January 2002, 13:21
I get the "Cannot play back file. The format is not supported"..

any suggestion?

gabest
27th January 2002, 13:29
I already posted a letter to the DXAV mailing-list about this problem, but got no answer...

Mentar
31st January 2002, 13:54
Try opening the sub.avi from inside the wmp after opening it empty - this may enable you to view it, even though it's inconvenient. But sure better than nothing.

Zarxrax
31st January 2002, 17:29
I've asked this question around here once or twice and never got an answer. It seems to be some weird problem that noone has an answer for :\

gabest
31st January 2002, 17:41
As I already said, the "File Source (async)" filter in DX81 can't find the given files without their path (because the path was edited out by the releasers). Instead searching for the files in the directory where it was opened from, it is looking at the root folder. You can test this by moving the main avi and the external wav to c:\

If you are looking for the answer how to open these files anyway, there is no proper way yet.

oeran
2nd February 2002, 01:21
http://msdn.microsoft.com/library/default.asp?url=/library/en-us/dx8_c/directx_cpp/htm/directshowgraphfileformat.asp, interesing to read, wonder if graphedit has those renderfilter available..

so basically what you saying Gabest is to not remove the filepath
option in vobsub while creating the sub.avi file with Graphedit and Vobsub?

That would mean my sub.avi and all files will have to be same location if I want to play it? I have tried opening wmp and then
doing file open my sub.avi file but it didn't work then.

gabest
2nd February 2002, 06:55
Originally posted by oeran
so basically what you saying Gabest is to not remove the filepath
option in vobsub while creating the sub.avi file with Graphedit and Vobsub?

No! That option is basicly unimportant now. DVobSub will search the filename and its path opened by the "File Source (async)" anyway, and look for the subtitles according to that. I'm saying that removing the path from the "File Source (async)" filter will make the things broke when using with dx81.

Taranli Maren
5th February 2002, 22:01
Is there any way to uninstall the file source filter in 8.1 and register the file source filter from 8.0 into it? might that solve our problem?

Taran'li Maren

gabest
5th February 2002, 22:32
Wow, this last question just gave me an idea! Now I only need quartz.dll from DX8. Anybody has this file for me?

Mentar
5th February 2002, 22:44
gabest: Mailed the file to you.

Mentar
5th February 2002, 23:13
Correction.

gabest: Your chosen mail account won't take the file. Instead, I mailed you where and how to download it instead.

Good luck.

gabest
5th February 2002, 23:17
Hm, I received both of your emails.

Mentar
5th February 2002, 23:23
64.4.49.135 failed after I sent the message.
Remote host said: 552 Requested mail action aborted: exceeded storage allocation

this is what I got back on the first try ...

the correct file size is 961024 bytes ...

InfoCynic
25th February 2002, 02:51
Has there been any progress on a work-around for the removepath bug? It would be nice to be able to put graphs on my CDs. :)

Mentar
25th February 2002, 10:08
InfoCynic: You can do it already, all you need to do is to open the sub.avi graph from _inside_ the WMP. This is a workaround for the path bug. If it still doesn't work, the problem lies somewhere else.

InfoCynic
26th February 2002, 05:50
I tried this on a bunch of graphs with no luck. I took a couple AVIs I had roaming around, used graphedit's "Render Media File" operation, and saved the graph. To make sure I had done that correctly, I opened that graph in MP 6.4 and it worked fine, although it took almost a minute to open. I then ran "removepath movie.grf" and launched MP 6.4 again and tried to open the file. After about a minute, it told me it could not find the file. I asked my friend to help test using his system, and as near as I can tell, he did everything right. He said he could open the output graph just fine, even by double-clicking on it (if renamed .AVI), and I had him check it in graphedit to verify that it had no path. He also said his files weren't in C:\. Can you guys think of anything that might fix this, or at least throw some completely random ideas as to what might be wrong, because I'm out of ideas. I'd reinstall DirectX, but I'm running WinXP which already comes with DX 8.1 (so is he).

Thanks again!

Mentar
26th February 2002, 09:04
InfoCynic: So what error do you get with "no such luck"? If it's "System can't locate this file" or so (don't know the exact wording, have a German version of XP), you're having just the well-known problem.

However, I wonder how comes that you run wmp 6.4 on XP, because the default install is wmp 8.0. I don't know if this is the source of your problem - possibly so. With wmp 8.0 here is how it works:

1) Open wmp "empty"
2) Choose "File" and "Open" from the pulldown menu
3) Change into the directory containing both the sub.avi graph and the remaining necessary files
4) Choose sub.avi and enjoy

I haven't found a single XP install yet where this trick didn't work. If it still fails with you, please post the exact error message.

divxdede
14th March 2002, 10:21
Any advance on this problem !

i have he same probleme, i create shortcut for a BivX but when i use it for launche the movie in WMP
it say me: Can't open this file, format not supported !!!


how i can solve this problem easily ?

KingMichi
21st March 2002, 02:23
I also have this problem!

But I tried two other possibilities:

- I uninstalled DirectX 8.1 by using DirectX-Buster ( www.directxbuster.de ) and installed 8.0a again, but still it doesn't work properly (I work under Win98 SE)

- I changed my quartz.dll to an older version and WMP 6.4 gave me another error message: "Not enough memory". But this message is not depending on the type of AVI I want to play. Every AVI-File causes this error in WMP 6.4, so I changed my quartz.dll again...

CU, KingMichi

PS: Please find a solution to this problem, cause I have many movies using this method of multilanguage in MicroDVD...

InfoCynic
21st March 2002, 16:16
Well, I did a system upgrade and as a result formatted my system partition and reinstalled WinXP, haven't installed anything additional related to DirectX or Media$layer since then, and everything works 100% correctly, including multiple-audios AVIs using graphs in MicroDVD.

So... if reformatting your system partition and installing WinXP is an option for you... :)

divxdede
21st March 2002, 16:20
For me it's not a solution, i'm developp a tool (AutoRun) that use GraphEdit shortcut, if it doesn't work i can't make a faq that say: HEY GUY !! FORMAT YOUR HARDRIVE AND MAYBE MY FREEWARE WILL WORK !!

:mad: :devil: :mad: :devil: :mad:

So i had implement a Morgan Média Switcher alternative :)

DosR
1st June 2002, 19:18
I have the same problem.

I mux the two audio without problem and then change from one to the other with the Morgam Stream Switcher. But when I want to use the graphedit way (to use diferents shortcuts in a menu to each language) it does not work.

The removepath recomended in the guide is not a valid solution. Anyway you got the same by puting the graphedit in the same folder that the avi and opening it with the render url option.

The morgan have a default stream option in the mss file but it must have the same name that the avi so you are not able to put to diferent mss in the CD.

I use the old media player 6.4. and if you double clik the avi you get the error, but if you use right click in it and Open (not play) then it works.

Maybe it is a solution to change the default option of the Wmp from play to open.

Any solution there?


PD.: Divxdede what is your morgam work-arround

divxdede
1st June 2002, 22:27
So now, in my launcher i implement only the detection of Morgan media, but i do nothing for the stream selection, i let the user to use the filter directly


http://divxdede.fr.st

DosR
17th June 2002, 12:44
Well, after countless trials, I have got a workaround that allow you to play in wmp2 the graphs of one of the languages and work in the CD.

It is a manual process for every graph (maybe a little hard to be done, but not a Dx change nor a OS reinstall) and you will need to include just an additional file (400 kb) in the CD.

If somebody is still interested I will try to explain how (As you already know, for my is a little dificult to writte English)

Bye