PDA

View Full Version : Interlaced DVD playback


Ramscoop
27th July 2009, 01:38
As I stated in a recent thread, I'm working through to encode my Anime collection and I came across a DVD that gives me those horizontal line/interlacing right from the raw DVD playback (:confused:that doesn't seem right to me). I tried playing it under WMP, VLC, and Nero Showtime under Windows XP. I ripped the main movie with DVDFab and the interlacing was still present.

I was wondering if there is a way to eliminate the interlacing's visual effect before I encode the video, or is that something Ripbot264 can take care of?

Inspector.Gadget
27th July 2009, 02:48
Most encoder GUIs offer deinterlacing options. Ripbot264 should do it, though I haven't ever used it. What MPEG-2 decoder are you using in your Directshow playback software? FFdshow doesn't automatically deinterlace true interlaced DVD content (versus throwing away pulldown flags) so unless you need to also do postprocessing on DVD playback you're probably better off for ease of use with the Microsoft, Cyberlink, etc. decoders. (Plus you can use DXVA where available).

Ramscoop
27th July 2009, 02:57
I am using the Combined Community Codec Pack. I just thought that it was strange I was experiencing the visual effect of interlacing straight from DVD playback.

Oh well, Ripbot264 will be done here in 20 minutes so I'll see how it came out.:thanks:

Inspector.Gadget
27th July 2009, 03:22
That doesn't tell you anything about the actual DECODER you're using (and this is part of the problem with codec packs...). You're either using the ffdshow decoder or Gabest's decoder if the CCCP installation set the merit to default; please find out which using Graphedit etc. If it behaves anything like the built-in MPC decoder, Gabest's should do deinterlacing OK on properly flagged DVD material. That said, you've got no guarantee the material is properly flagged and you may still be using ffdshow.

Uninstall the CCCP and install only the latest ffdshow-tryouts and Haali's Media Splitter. Make sure ffdshow is NOT set to decode MPEG-2. Directshow players including WMP should then use whatever codec is the default on your system. What OS are you running? Do you see the same issues when you use MPC for playback with the internal MPEG-2 filter disabled or enabled? MPC will also show you what filters are in use so you can spot the problem.

Ramscoop
27th July 2009, 04:08
Ok, uninstalled CCCP

Installed MPC 6.4.9.0, ffdshow tryouts beta6 rev2527 and Haali Media Splitter 1.9.42.1 and the original ripped VOB files from the DVD play great now! No interlacing issues. :)

I'm running Windows XP Pro SP3, I ran Graphedit which shows I am currently using the "MainConcept (Adobe2) MPEG Video Decoder"

BTW, the previous Ripbot264 job of the last encode (before CCCP was uninstalled) still contained the interlacing blemishes so, I'll try again under this new configuration.

Ramscoop
27th July 2009, 06:51
Well Ripbot264 finished and the final MKV still contains the interlacing blemish.

Also, I stated earlier that the interlacing was not apparent at all if I used MPC to play the raw VOBs however, the interlacing blemish is still very apparent if I use VLC or Showtime to play the VOBs.:(

Inspector.Gadget
27th July 2009, 12:27
Showtime may well be broken, I dunno. VLC, like ffdshow's mpeg-2 decoder, doesn't handle true interlaced DVDs automatically: you must pick a deinterlacing option on playback. That said, I prefer MPC anyway.

Ripbot264 probably requires that you set a deinterlacing option explicitly. Every other GUI I've used requires that; make sure to poke around in every config screen and look for one. Yadif() should be fine for most purposes unless you know you want a greater time/quality tradeoff by e.g. using one of the motion-comp'ed bobbers.

RunningSkittle
27th July 2009, 13:33
are you sure its interlaced and not telecine?

Ramscoop
27th July 2009, 16:21
yeah, I think it might be Telecine, I need to find a better way of identifying it. (Still seems odd that I'm seeing the Telecine blemish from DVD playback on certain players).

BTW, trying Handbrake's "detelecine" filter.

Ramscoop
27th July 2009, 19:14
Well, here's my results:

- Handbrake (using the "detelecine" filter, two-pass, animation profile) produced an MKV with the telecine blemishes gone, however the video playback was stuttering.

- Ripbot264 (using two-pass) produced an MKV that played back very smooth, however the telecine blemish was still very apparent.

- Staxrip (using the "Anime: Good Quality" profile and the "Yadif" filter) produced the same MKV as Handbrake (no telecine blemishes, but stuttering playback)

I can deal with the Ripbot264 MKV and just use a deinterlacing profile (during playback) for a semi-decent solution to the blemishes, but I'd really like to figure out how to solve this if I keep running into the same problem.

Inspector.Gadget
27th July 2009, 22:38
Post a sample of your DVD source. ffdshow's video decoder discards soft telecine information so it's likely to be either hard telecine or true inerlaced.

Ramscoop
27th July 2009, 23:34
I'd like to post a video sample, but I think that's going to fall under copyright infringement. It's the anime version of Blood The Last Vampire.

Inspector.Gadget
28th July 2009, 00:30
Short samples fall under fair use exceptions to most copyright regimes. Posting them is routine practice for this forum. Worse comes to worse, Doom9 gets a DMCA complaint and deletes the link.

Ramscoop
28th July 2009, 00:46
Here are some screenshots, I highlighted the blemishes. Seems to occur in areas of sudden movement. These visual blemishes are consistent whether through VOB or the encoded MKV (unless I play the VOB using MPC).

http://usera.ImageCave.com/eigen_bro/BTLV-Telecine01.JPG

http://usera.ImageCave.com/eigen_bro/BTLV-Telecine02.JPG

http://usera.ImageCave.com/eigen_bro/BTLV-Telecine03.JPG

http://usera.ImageCave.com/eigen_bro/WB-Telecine01.JPG

http://usera.ImageCave.com/eigen_bro/WB-Telecine02.JPG

http://usera.ImageCave.com/eigen_bro/WB-Telecine03.JPG

Inspector.Gadget
28th July 2009, 00:48
We need a VIDEO SAMPLE. Screenshots tell us only about particular frames. Cut a VOB with DGIndex and put it on rapidshare or another upload site.

Revgen
28th July 2009, 02:15
You may have blended fields. This is not uncommon in Anime. You can try this function in avisynth and see what you get.

http://forum.doom9.org/showthread.php?t=138305

Ramscoop
28th July 2009, 02:26
Ok, I uploaded a sample at:

http://rapidshare.com/files/260818090/BTLV.Sample.rar.html

I'm pretty sure it's soft telecined 23.976 source to 29.97 as some of my other Anime was identified in a psuedo-related forum (http://forum.doom9.org/showthread.php?t=148233).

@ revgen, thank I'll give it a shot right now!

manono
28th July 2009, 12:03
It doesn't have blended fields. You work with anime and can't tell when you need a simple IVTC?

Ramscoop
28th July 2009, 19:13
Hmm, I did try the "detelecine"(IVTC?) option in Handbrake's GUI(above) however some of the flick's more expansive scenes (CGI?) produced a very stuttery playback.

Guest
28th July 2009, 19:59
Then you should have posted a sample that includes the "expansive scenes" as well!

So you probably have hybrid film/video.

SeeMoreDigital
28th July 2009, 20:12
In MPC, try the following: -

Go to "Options..." -> "Internal Filters" -> "Transform Filters" -> "MPEG-2 Video" and under "Deinterlacing", try manually selecting "Bob".

Ramscoop
28th July 2009, 20:31
I think the AnimeIVTC (http://forum.doom9.org/showthread.php?t=138305) will be my solve-all solution. I've never worked directly with Avisynth, but many of the Telecine/Interlacing scenarios are ringing true throughout AnimeIVTC's documentation (http://www.mediafire.com/download.php?nmwmemm1m3o). Much appreciated!

manono
28th July 2009, 21:14
Yeah, I don't use Handbrake and don't really know what their detelecine does, although it does sound like an IVTC. As neuron2 said, we can only analyze what's provided for us and in this case you may have a hybrid. I was also next going to suggest animeIVTC as a possible solution. That and a better sample.

When dealing with anime, nothing beats AviSynth and nothing beats your own eyes for figuring out what you have. Just blindly trying this and that to solve your problems wastes time and solves nothing. Good luck with animeIVTC. It's not really meant for AviSynth beginners, but you'll learn a lot while working with it.

SeeMoreDigital
28th July 2009, 21:31
I ran the sample thru' VirtualDub... Using the IVTC filter it produces progressive frames.

Ramscoop
28th July 2009, 23:17
Yeah, I'm just going around collecting the required software and plug-ins. I'll probably put some serious work into AnimeIVTC this weekend.

BTW, doom9 (download section) links the Virtual Dub download to a 1.8.1 release. Is there any reason for that? 1.9.4 is the most recent version from the authors site.

EDIT: I spoke too soon, looks like it was released yesterday, probably to soon to update the link(?)

Ramscoop
2nd August 2009, 02:00
Sat down today (Saturday) and AnimeIVTC has been nothing but a god-send. I'm producing beautiful Anime encodes now! Thank you so much!:thanks: