PDA

View Full Version : x264 suddenly is not working properly


twazerty
21st June 2009, 00:56
From 1 day to another I get the following:
After pass 1 is done x264.exe stopped working. When I close the Windows message it will continue with pass 2. After pass 2 completed Windows pops up the same message again. When I hit the solve button Visual Studio 2005 debugger pops up. Very strange. All versions of x264.exe has this problem. Tried different versions and also different versions of ffdshow. I have a set of files I always test. Tested with exactly the same script but it still gives me the problem. What is going on here?

Very frustrating because in no software has been installed that could mess things up.

Edit:

Running on Windows Vista 64 bit.
X264 32 bit
ffdshow 32 bit
avisynth 32 bit
haali media splitter
No codec packs.

Edit 2:
http://i41.tinypic.com/14cquet.jpg
The message is in Dutch but it's about this:
x264.exe doesn't work anymore.
A problem occured. Program will be killed and you get a message if a solution is available.

When I hit something like "Trace error" I get the debug window.

Windows events gives me this:
"Toepassing met fout x264.exe, versie 0.0.0.0, tijdstempel 0x4a1cb013, module met fout DirectShowSource.dll_unloaded, versie 0.0.0.0, tijdstempel 0x494eb91d, uitzonderingscode 0xc0000005, foutmarge 0x00302be0, proces-id 0x16d8, starttijd van toepassing 0x01c9f20668e071a6."

- EventData

x264.exe
0.0.0.0
4a1cb013
DirectShowSource.dll_unloaded
0.0.0.0
494eb91d
c0000005
00302be0
16d8
01c9f20668e071a6

bob0r
21st June 2009, 02:21
Did you update x264 revision?
Post your commandline.
Post your AVS script.

Maybe provide a reproducable sample for others to try?

Dark Shikari
21st June 2009, 02:27
Does it still crash if you input directly via a yuv file rather than via Avisynth?

twazerty
21st June 2009, 12:26
Found the problem. Somehow the avisynth folder was messed up. Did reinstall avisynth but thAat wasn't enough. Had to remove the files by hand and installed avisynth again. Now it works correctly.