PDA

View Full Version : Subtitles w/ Godfather Trilogy Collection


Gerbopel
15th January 2002, 04:04
Hi. I'm new to DVD ripping, but I've been using the following method to great avail for my entire DVD collection so far (about 12 titles):

[latest versions of all software referenced]
cladMdec (take .VOBs to hard drive)
dvd2avi (convert .VOBs into an .AVI and .WAV file combo)
vdub (combine .WAV and .AVI to one .AVI)

- When converting to .AVI (w/ DVD2AVI), I'm using the DIVX 4.12 codec.

My system:
P3 1.8ghz
384MB RDRAM
Visiontek Geforce3 64MB
Pioneer DVD-116 (version 1.22 - original firmware)
75GB IBM Deskstar IDE
Windows XP Professional

That has worked perfectly for every single movie I have (all region 2). I haven't bothered with any subtitles, but they've all worked fine. I even ripped Scarface without a problem, and Alberto's lines in the movie are all in Italian, subtitled in English (within the default movie I guess) and those are copied properly (cause it's a part of the video I'm guessing).

However, now I'm trying to rip my copies of The Godfather 1, 2 and 3 and I'm having a REALLY hard time figuring out how to get the damn English subtitles going for the parts that are in Italian (which should be the default, like in Scarface).

I downloaded and installed Vobsub for Vdub and started using SmartRipper instead of cladMdec (so I can get the .ifo files as well). However, I have been unsuccessful so far. Whenever I try and index the subtitles (key searching goes fine) through Vobsub, I get an error message stating:

"Cannot read, either locked dvd or truncated/missing files!"

I've tried everything:

- ripping the full movie and selecting only one subtitle language from the top list (http://www.doom9.org/vobsub.htm 2nd picture from the bottom).

- ripping a single scene, selecting one (or all) of the subtitle languages and then selecting only the .vob files (id's) that I have in the directory.

If I select "I've stripped the source files...", it completes without error, yet there are no subtitles in the resultant movie.

I'm sure it's something small that I'm missing, but to be honest, I have NO idea what it is! Hopefully my goal can be accomplished using the tools I currently am using (Smart Ripper, DVD2AVI + VDub) as every time someone recommends new tools: (start loop) I end up having some sort of problem which I am then told can only be solved by using a different tool (end loop) :(

If anyone would be willing to shed some light on my mistake(s) here, I would be very grateful indeed.

Thanks for your time,
Gerb.

seoulsteve
15th January 2002, 16:35
Gerbopel, i've got the same problem with Godfather Part I. I think the reason is that the English subs during the Italian conversations (especially when Michael is in Sicily) are part of the black borders at the bottom of the movie. ie, they are NOT a bitmapped image or part of any subtitle file on the DVD.

watch the movie carefully. i think you'll be able to see that there are two shades of black at the top and bottom of your screen: one black border created by the playback program, and one black border which is actually part of the movie. the black border that is actually part of the movie is where those English subs reside.

when you crop the black borders out of the movie, i think you are also cropping out the subtitles in question.

i think your choices are clear: don't crop your movie or learn Italian..:)

also, something that intrigued me in your post, i get the same message: "Cannot read, either locked dvd or truncated/missing files!" when i try to rip subs. i'm stumped here too...:(

Yusaku
16th January 2002, 01:14
also, something that intrigued me in your post, i get the same message: "Cannot read, either locked dvd or truncated/missing files!" when i try to rip subs. i'm stumped here too...

Well, it seems you either have locked DVD or truncated/missing files :)

Locked: run some software DVD player, it will unlock the drive, and only then run the ripping program

truncated/missing: try cleaning the DVD disc, but it is most probably the first error. If the disc really is damaged, you wouldn't be able to rip the movie from it, not just subs...

Gerbopel
16th January 2002, 02:15
Thanks for the help guys, let me respond one by one:

- Steve, are you saying that you've managed to successfully rip Godfather 1 (from the 5 disc DVD collection) with the partial-English subtitles?

I tried not cropping it at all and it didn't do anything. Actually, it would appear that it hasn't been cropped the whole time. I'm not sure if DVD2AVI automatically crops certain parts, as I have no control it seems over the default widescreen black border sections.

- Yusaka, this error message only occurs partially through the subtitling (indexing) process, not right from the start. Additionally, the info is not being read from the DVD drive at this point, it's on the hard disk.

Any other ideas? Thanks so much for your help so far! Hopefully together we can win the war against The Godfather series!

Thanks,
Gerb

Yusaku
16th January 2002, 02:26
Ok, I've re-read the first post, sorry for my previous one :)

Well, it seems that there is some mastering bug on DVD (or you ripped with bad ripper/changed the stream with vStrip), but as long as "I've stripped source & etc..." magic button works, it should be OK.

Try checking the VOBSUB subtitles - after you rip VOBSUB files, look at the .IDX file - it should show timestamps for every subtitle (and file position).
If it is, and it is correct, you are doing something wrong in VDub.
If it is there, but times are totally off, use subresync from VobSub package to fix times.
And if it is nearly empty file, something is really wrong.

Anyway, try to post as much info you can...

Gerbopel
16th January 2002, 04:09
No problem ;)

Ok, I looked at the .idx file for the Godfather 2 scene I'm trying to convert (rather than trying with the whole movie each new step).
I have no idea how to read this file and what any of the info means, here a sample from it ( last 4 lines ):

LBA | Frame# | Type
----------|----------|-----------------------
.
.
.
026446 | 007669 | IBBPBBPBBPBB (12)
02653D | 007681 | IBBPBBPBBPP (11)
----------|----------|-----------------------
| 007692 |

I ripped Chapter 15 (of 16) from disc 1 of the Godfather 2 using Smartripper (latest). Here are the files that I have created thus far:

vts_02.d2v
vts_02.idx (sampled above)
vts_02.lst
vts_02_0.ifo
vts_02_0.sub
vts_02_1.vob
vts_02_7.vob
vts_02_INFO.txt

I'm not positive about which files were created by Smartripper and which ones have been created since I've been trying to run Vobsub a few times (partially successful as mentioend). If it helps one way or the other, I'll do it again from the start and list which files are created at which points.

Since it might be informative, here's the full contents of vts_02_INFO.txt:

*************
* Main Info *
*************

Name: UK_101122
Size (B): 321943552
Frames: 7692
Title: 1
Angle: 1
MinDataRate (B/s): 950056
AvgDataRate (B/s): 1046358
MaxDataRate (B/s): 1153113


**************
* Video Info *
**************

Compression: MPEG-2
TV system: PAL
Aspect ratio: 4:3
TV system: not specified
Display mode: 720x576
Resolution: no
Letterboxed: Camera
Mode:


***************
* Stream Info *
***************

Stream[001] X=[[0xE0] Video PAL 720x576] [PTS 1757:22:40] [Delay 0 ms] [@1] []
Stream[002] X=[[0x80] Audio English AC3(6Ch) 48kHz ] [PTS 1757:19:20] [Delay -200 ms] [@10] [40 kb/s]
Stream[003] X=[[0x81] Audio English AC3(2Ch) 48kHz ] [PTS 1757:20:24] [Delay -136 ms] [@11] [384 kb/s]
Stream[004] X=[[0x20] Subtitle Dansk ] [PTS 1759:30:40] [Delay 7680 ms] [@3901] []
Stream[005] X=[[0x21] Subtitle English ] [PTS 1759:30:00] [Delay 7640 ms] [@3870] []
Stream[006] X=[[0x22] Subtitle Nederlands ] [PTS 1759:22:00] [Delay 7160 ms] [@3628] []
Stream[007] X=[[0x23] Subtitle Norsk ] [PTS 1759:24:40] [Delay 7320 ms] [@3709] []
Stream[008] X=[[0x24] Subtitle Suomi ] [PTS 1759:30:00] [Delay 7640 ms] [@3872] []
Stream[009] X=[[0x25] Subtitle Svenska ] [PTS 1759:30:40] [Delay 7680 ms] [@3905] []
Stream[010] X=[[0x26] Subtitle English ] [PTS 1757:46:00] [Delay 1400 ms] [@690] []
Stream[011] X=[[0x27] Subtitle English ] [PTS 1759:30:00] [Delay 7640 ms] [@3882] []
Stream[012] X=[[0x??] Others] [] [] [] []


****************
* Chapter Info *
****************

Chap#=Frame#
Chapter15=0

Chap#=@LBA
Chapter15=0

Chap#=Frame# Name
15=0 Chapter15

Chap#=Second
Chapter15=0

Chap#=Time
Chapter15=00:00:00.00


******************
* VOBFile Output *
******************

C:\dvd movies - ripping\Godfather 2 (divX)\vts_02_1.vob
C:\dvd movies - ripping\Godfather 2 (divX)\vts_02_7.vob


************
* Cut List *
************

001: Program Chain[1]->Angle[1]->Chapter[15]->Cell[001] VobID[1].CellID[16] [#0] [@0]

<*** end of file / rejoin post ***

Here's exactly what I'm doing in Virtualdub:

- Loading the resultant .AVI and .WAV files from DVD2AVI.
- Activating the Vobsub filter, picking "i've stripped..." (if I don't want it to fail) and clicking OK twice.
- Either by watching the movie, or saving it as a combined AVI (WAV+AVI), I cannot see *any* subtitles at all.

Thanks so much for your help! Is there any other info that you think might be pertinant?

Gerb

Yusaku
16th January 2002, 20:18
Uh huh.... Ok, it seems that VobSub is doing something wrong. Fire up VobSub, load it with vts_02_0.ifo and press "I've stripped...." (yes, you did - because you used SmartRipper). Select another directory and it should produce THREE files for you (.IFO - maybe not in 2.08; .IDX and .SUB).

If it will not, repeat above step, but load the IFO file directly from DVD (dunno, I'm using vStrip to have total control over decrypting to disk. It is possible that SmartRipper kills the sub streams in VOB files).

Anyway, the .IDX file you pasted is NOT from VobSub; and the file vts_02_0.sub is missing its .IDX sounterpart

Gerbopel
16th January 2002, 22:13
Ok, I took the .IFO file right off of the DVD (VTS_02_0.IFO). I now have an .idx file and a .sub file created by Vobsub, but not another .IFO file.

Implementing the filter on an .AVI file though has absolutely no effect, there is no subtitle text to be seen anywhere. I'm lost.

Gerb

Yusaku
16th January 2002, 22:37
Ok, if you want, send the two files (COMPRESSED) to yusaku at anime.cz. I'll take a look at them

seoulsteve
18th January 2002, 11:13
gerpobel, to answer your very old question (sorry for the late reply) no, i haven't been successful at all with ripping the Michael-Corleone-in-Sicily subtitles..

i thought the cropping thing was the answer.. but maybe not.

Gerbopel
18th January 2002, 11:15
Ok, just in case I'm doing something wrong in the last stage here, can someone tell me exactly what I should be doing in Virtualdub?

I open a video file (.AVI created by DVD2AVI), and then open the .WAV audio (also created by DVD2AVI).

Then I go into VIDEO - FILTERS and select Vobsub. I click open, select the .IFO file created by Smartripper and tell Vobsub to create the new files in a different dir than the other files. I then pick the option saying that "I've already stripped the files and crossed my fingers".

It does the indexing and then I'm in a position to save the resultant .AVI file. What should I do here? If I simply preview the movie now there's no subtitles, but maybe there's some switches I need to set, like Direct Stream Copy for VIDEO or something...

Anyone?

Thanks,
Gerb

Gerbopel
18th January 2002, 19:30
Ok, I have finally managed to find the subtitles! By listening to the advice of everyone so far, and using the "I've stripped..." option in Vobsub, I am now able to see the subtitles in the output window in VirtualDub when the VIDEO menu has "Full Processing Mode" selected.

(At this point, I've loaded the .AVI file and the .WAV file given to me by DVD2AVI).

However, when I go to "Save AVI" and attempt to combine them all into one file, it is MASSIVE! First of all, it tells me that it's going to take 9 hours to do it, second of all, the resulting file is 1.5GB in size after only 10 minutes! I don't have enough hard drive space for that, but that's beside the point as I'm obviously doing something wrong.

I tried "Save AVI" while the VIDEO menu has "Direct Stream Copy" selected, but then the resulting .AVI file has no subtitles in it... of course the file size is normal when I do it with this option (the way I've done all the rest of my movies).

Now that I have the subtitles loaded and setup properly, how do I combine them into the .AVI without the filesize going over 1000GB in size?

I'm so close I can taste it! Thanks so much for your help everyone!

Gerb

Yusaku
19th January 2002, 16:29
That is because VirtualDub by default saves uncompressed AVI file - go to Video>Compression menu (I think...), select DivX4 compression and you're done (look up Doom9's guides on saving DivX4 in VirtualDub at http://www.doom9.org/divx4.htm )

FreeZe
14th November 2002, 15:28
I just backed up this excellent trilogy an found the same problems with the forced English Subs in the Italian dialogue scenes being missing when DVD2SVCD had finished.
It seems the forced Subs are actually just an extra Subtitle stream which only shows in the Italian Dialogue areas.
I've just redone Part II with Permanent Subs on and chose only the last English subtitle stream in DVD2SVCD. (There are 3 on the DVD, I guess one for 4*3,16*9 and the forced)
Seems to have done the trick. Gonna redo Part I too.
This is the PAL version btw.

Capiche?
:sly: