PDA

View Full Version : Huffyuv Bug Fixed. Read All About It.


Mark Fredrickson
10th January 2002, 05:44
The Huffyuv bug that caused all capture programs (except VirtualDub) to crash when it encountered heavy static video has been fixed. You can read all about it at the link below.

http://rilanparty.com/vbb/showthread.php?postid=65146#post65146

Say Luke, check this out. I think it would be really nice if we published this fix somewhere so others don't go through the pain I've been through these last few months.

Cart
14th January 2002, 00:48
Nifty, it's nice to see people working together. I've never experienced the bug personally, but I'm sure someone will benefit from the fix.

I can't help with the the publishing though because I don't even have enough bandwidth for my own site as it is.

-Cart
http://www.geocities.com/lukesvideo/index.html

Mark Fredrickson
16th January 2002, 05:59
Luke,

How about asking Doom9 if he would be interested in publishing this fix?

Mark.

mkanar
18th January 2002, 04:35
That's really great work!

Now, any volunteers to optimize the huffman decompression speed? Well, I had to ask.... :)

Cart
19th January 2002, 23:32
Mark,

I don't know Doom9 any better than you, but I suspect he'd publish the fixed version. Go on, take a little credit and ask him yourself.

-Cart
http://www.geocities.com/lukesvideo/index.html

catback
2nd July 2004, 22:11
Originally posted by Mark Fredrickson
The Huffyuv bug that caused all capture programs (except VirtualDub) to crash when it encountered heavy static video has been fixed. You can read all about it at the link below.

http://rilanparty.com/vbb/showthread.php?postid=65146#post65146

Say Luke, check this out. I think it would be really nice if we published this fix somewhere so others don't go through the pain I've been through these last few months.


Bringing an old thread back. Anyone know what the solution to this problem was and if a revised Huffyuv codec was issed? The link mentioned above no longer works.

bastel
7th July 2004, 10:12
Originally posted by catback
Bringing an old thread back. Anyone know what the solution to this problem was and if a revised Huffyuv codec was issed? The link mentioned above no longer works.

It's fixed in the (buggy) huffyuv revisited (v2.2) and in the old huffyuv cce patched versions, when you enable the full outputbuffer thingi in the settings dialog (forgive me, i can't remember the correct name).

You might want to read the documentation about pros and cons using this setting.

bas