PDA

View Full Version : wintvpci / vdub / dropped frames - helpless


((( atom )))
6th January 2002, 14:42
i am having massive trouble with dropped frames in virtualdub.

involved:
duron (morgan) 1ghz
512mb ram
elitegroup k7vza mobo
ibm hd 7200 u/min, 40gb
wintv pci with latest vfw-drivers
windows xp
virtualdub 1.4.8
picvideo-codec @ 18
soundblaster live!
tv-system is pal

whenever i capture above 400x300 i get a couple of hundred dropped frames on a 2h-capture, while cpu-usage doesnīt exeed 50%.

most strange is, that i used to capture with a k6II 400 @ 640x480 using picvideo with 0 dropped frames. so my machine should handle this easyly.

i checked every possible bios/system-setting and i have no idea left anymore.

Cart
6th January 2002, 19:53
Are you sure that DMA is enabled for your hard drive? Do the dropped frames occur in bunches or separately from each other? Have you tried capturing with audio disabled? Have you tried capturing XXX by 288 or 576 lines?

Go through the VirtualDub capture guide on my website if you haven't already.

-Cart
http://www.geocities.com/lukesvideo/index.html

((( atom )))
6th January 2002, 21:35
Are you sure that DMA is enabled for your hard drive?
-> yes: udma100.

Do the dropped frames occur in bunches or separately from each other?
-> they come one by one.

Have you tried capturing with audio disabled?
-> nope. i will.

Have you tried capturing XXX by 288 or 576 lines?
-> yes, xxx by 288 works, xxx by 576 doesnīt.

Go through the VirtualDub capture guide on my website if you haven't already.
-> i have already ages ago. i never had problemīs with capturing until i switched to windows xp and a new mobo (old one broke). i also tried using different settings for the hd i/o in virtualdub. nothing helps.

((( atom )))
7th January 2002, 21:37
ok, i finally nailed it down: it droppes frames, when i capture with audio @ "cd-quality" wich i definitely want.

cart, you mentioned the audio-thing before, do you have any idea what could cause this behaviour?

Cart
8th January 2002, 06:45
Perhaps its one of those infamous SB Live! problems.
By "cd-quality", do you mean 16-bit 44.1 KHz stereo uncompressed PCM audio? If so, try capturing with 48 KHz audio.

Also, if you have a VIA chipset, you could try one of the many patches. For example, there's the 4-in-1 kit and a latency patch if I remember correctly.

-Cart
http://www.geocities.com/lukesvideo/index.html

((( atom )))
8th January 2002, 11:55
i tried it with my onboard ac97-codec as well - same problem.
-but it looks like i got it to work last night tuning the cache for audio and video in virtualdub. didnīt have the time to capture a whole movie yet, but for some 5 mins it worked @ full pal res without dropping any fame.

thanx and c u in next thread ;)

/jc