PDA

View Full Version : Donald Graft. I have a question about dgmpeg


Jeremy Duncan
28th June 2007, 21:33
Using the software in the first post in this thread.
Link (http://forum.doom9.org/showthread.php?t=115727)

When I rip a dvd I own, using dvdfab decrypter. A standard definition dvd, 2 of them.

When I open the .ts file using Media Player Classic, it's not interlaced.
I use FFDshow too, not sure if that's important.

But it's not interlaced. When I ripped it using ripit4me and dvddecrypter, I'm sure it was interlaced when I opened the .ts file.
So maybe dvdfab decrypter is doing something to keep it from being interlaced.

Anyway, the reason I'm posting this is because when I use dgIndex.exe and make the .d2v, then make a .avi using virtual dub and wmv9 video compression in virtual dub, then add the audio using AVI-Mux_GUI, the video is interlaced when I open it with MPC.

This is the avs script.
LoadPlugin("C:\Program Files\AviSynth 2.5\plugins\DGDecode.dll")
setmtmode(2, 0)
mpeg2source("VTS_01_1.d2v")

I tried using FFDshow 5 tap lowpass deinterlacing, but it's not quite working.
So If I make a .avi I would need to use decomb.

So why does making a .avi make the video interlaced, but If I play the .ts it's not interlaced.

I'm using the dvdfab decrypter from the doom9 software page.

Leak
28th June 2007, 21:46
Errr... by default, DGIndex will honor the pulldown flags in the stream, if there are any, while media players usually won't.

Try setting "Video > Field Operation" to "Ignore Pulldown Flags" (or "Forced Film" if you want to make totally sure there'll only be 24 frames per second).

np: The Orb - Ralph's Cupboard (Orb Sessions Volume 2)

Jeremy Duncan
28th June 2007, 22:21
Errr... by default, DGIndex will honor the pulldown flags in the stream, if there are any, while media players usually won't.

Try setting "Video > Field Operation" to "Ignore Pulldown Flags" (or "Forced Film" if you want to make totally sure there'll only be 24 frames per second).

np: The Orb - Ralph's Cupboard (Orb Sessions Volume 2)

That fixed it. Thanks, Leak. Problem solved