PDA

View Full Version : Help muxing POTC BR into Matroska


Roscoe62
20th June 2007, 02:25
After using AnyDVD HD to backup POTC Ė Black Pearl to my HDD, I have managed to mux the main M2TS file into a mkv file Ė but there are problems, and I wondered whether anyone can help me out?

First off, I used GDSMux to grab the main H264 video and the LPCM audio track and put them into a new matroska file. This seemed to work OK. (NB: I wanted the LPCM track in order to keep the audio quality as high as possible - I have a soundcard upgrade coming which will change things a bit).

The next step I would normally do (and I have successfully done so on my HD-DVD backups) is to remux the matroska file with a ďtimecodes.txtĒ file with MKVMerge to force 23.976fps.

ERROR1. When I tried to add the timecodes.txt file and remux, MKVMerge spat out an error message Ė sorry I didnít note it, but if required I can try it again and post the exact error message here.

I then built a graph in graphedit to play back the file. For video I used Haali Media Splitter > CoreAVC 1.2 > VMR9 Video Renderer. For audio I used Haali > AC3 Filter > Default Directsound Device. (Iím currently using AC3 Filter to recode to SPDIF). This seemed to work OK.

ERROR 2. When playing back the file in Theatertek 2.4 using the graph, I note the picture is VERY DARK. With my backed up HD-DVDs the picture is fine. (although Iím not using CoreAVC for those).

ERROR 3. While playing back the file with Theatertek, if I try to seek within the file Theatertek freezes Ė thatís it Ė game over. I have to kill TT and restart the movie again.

ERROR 4. Slowly over time the audio gets further and further out of sync. The audio lags further and further behind the picture. So far Iíve only watched about 20 minutes of the movie, but the audio is NOTICEABLY out of sync by this time. I would look further into the file but, remember, I canít seek!

Iíve tried to find some answers elsewhere in the forum but havenít been able to find anything that explains this. This is my first backed up BR disc so maybe that is a problem? However, I see others havenít had any problems playing back POTC, or if they have, they havenít posted any problems here. So maybe itís something obvious I'm doing wrong.

Iíd be very grateful for any help with this. Backing up my HD-DVDs was relatively easy compared to this! :confused: