PDA

View Full Version : Lost XviD - plain decode


jolson
23rd March 2007, 11:47
:confused: (Yes, I'm confused. Probably because I'm getting old. And probably because things work "too" well nowadays, so when something fails you have forgotten how to lok for faults and solutions...)

I have had XviD (Koepi's XviD-1.1.2-01112006.exe) running on my machine for a while without problems. I could watch XviD AVI's in MediaPlayer Classic as well as converting to DVD using DVD2SVCD. I'm running on a portable with XP.

Then, (of course), I tested installing a couple of programs/codecs mainly for matroska/h.264. After that (the installation of those programs/codecs seems to be the culprit), XviD doesn't work. I have tried both uninstalling those new codecs/programs as well as reinstalling XviD, to no avail.

The files play in VLC (which I believe has the XviD decoding internal?), so there's nothing wrong with them.

The problem is that it was a long time ago I had to do anything with this, "XviD - Configure decoder" gives no interesting options. I guess there's some other place I can configure which filter to use, I thought there should be someplace in Control Panel where I could affect filter orders, used decoder and such. But I find nothing about DirectShow or similar anywhere...

Playback of other codecs, like DivX, works.
Any pointers?

unskinnyboy
23rd March 2007, 15:02
This "doesn't work" means what? Nothing happens? You get some error message? Your PC explodes?

Load your XviD file into GraphEdit and post the screenshot here.

jolson
23rd March 2007, 15:30
Sorry, with "doesn't work" I meant that the file couldn't be rendered with mpc or GSpot. I will download GraphEdit and have a look, it's a new machine I have setup because the old PC exploded.

foxyshadis
23rd March 2007, 16:03
Graphedit won't render it either, in that case. Try downloading CCCP Insurgent, and see if it gives you any information about lingering codecs. You might need some harsh registry-hacking methods to remove them. Another option is reinstalling directshow; the most basic step is running the command "regsvr32 quartz.dll"

jolson
23rd March 2007, 17:57
I will download Insurgent, though CCCP gives me some "bad vibes" since their pack was one of the two things (the other one was a video conversion program trial) that I know to have installed between when everything worked and now. But that program should do nothing but checking status...

Reinstalling DirectShow might very well be my next step.

jolson
23rd March 2007, 18:06
In the Codec Pack column it only shows: "Combined Community Codec Pack" (Uninstalled), no other packs. One system class, "DirectShow Filters" and 216 filters.

Insurgent can't (obviously) render the file either
DirectShow Error: 0x80040218: Couldn't find a filter combination to render the stream.

jolson
23rd March 2007, 20:46
I "looked around" among all the filters with DirectShow Filter Manager, but could never force the video codec I wanted to be used (the one used wasn't in the directshow filter - or any other - list, so I couldn't lower its' merit). Reinstalling DirectX, XviD and ffdshow didn't help either.

Avi Splitter (http://www.free-codecs.com/Avi_Splitter_download.htm) seems to get me on the right track, however. It takes a long time now to open a movie in mpc (re-indexing?) but it's possible to play the movie now.

It's not as before, but getting usable anyway...

jolson
23rd March 2007, 23:19
Installing Gordian Knot codec & ripping packs fixed it all :)

It would had been better to know exactly what was wrong and how to do a least-impact fix of the situation, but I think this was the second-best.

Thanks for the suggestions.