PDA

View Full Version : Spliting problem in Gordian Knot


acebrain
25th February 2007, 05:19
I dont know with which setting in GK i am messing .After complete riping i always having problem with spliting , i am always getting three files of size 699 Mb , 698 Mb and 10 Mb .
In XviD setting.... My traget size is 1433600 kbytes .

ukb008
25th February 2007, 14:04
Hi

Put your target size in Custom in the AGK, and make the figure 1399 or 1401 MB.

You should get one file.

Regards.

jggimi
25th February 2007, 17:43
ukb008:

This is a GK, not an AGK issue for acebrain. :)

acebrain, could you :logfile: for us? It might help, and couldn't hurt.

HeadBangeR77
26th February 2007, 20:55
I dont know with which setting in GK i am messing .After complete riping i always having problem with spliting , i am always getting three files of size 699 Mb , 698 Mb and 10 Mb .
In XviD setting.... My traget size is 1433600 kbytes .

Looks like you're getting a small oversize, and the splitting option in GK is checked (just uncheck it). A logfile wouldn't hurt, as well. ;)

aldaco12
27th February 2007, 16:04
If interested, I had the same problem.
It seems this is an issue of last Xvid codec.
That is: once installed, making on VirtualDub: Video___Compression, I saw TWICE the voice Xvid MPEG-4 codec, one associated to :
driver name: xvidvfw.dll
FourCC code: 'xvid'
and another one associated to the same driver but having a different FourCC code (excuse me, I don't tremember which one).

I don't know how I did, but I uninstaled the Xvid codec using Control Panel , then I reinstalled it and finally only one Xvid voice appeared. This time the AVI splitting was correct.

I think that installing XviD 1.2 over an existing version made those doubling, and AutoGK chooses the wrong one.
If you manage to uninstall completely XviD codec (one using the Xvid unnstall , once trying to use Control Panel) , you can then install XviD 1.2 (the one now present in XviD site).
From then you'll manage to use XviD correctly.

acebrain
2nd March 2007, 19:22
Looks like you're getting a small oversize, and the splitting option in GK is checked (just uncheck it). A logfile wouldn't hurt, as well. ;)

if i will uncheck then how will i cut file into 700 MB each coz i tried by VDM didnt got the exact size .

P.s : i am using XviD 1.2 Final

CWR03
2nd March 2007, 19:50
if i will uncheck then how will i cut file into 700 MB each coz i tried by VDM didnt got the exact size .
VirtualDubMod can only cut in on an I-frame, so you would need to undersize the video by 10-20 MB to make sure you can still split it without one half being more than 700 MB. Another option would to be to split the movie with DGIndex and encode the two halves at exactly 700 MB.

acebrain
4th March 2007, 11:39
VirtualDubMod can only cut in on an I-frame, so you would need to undersize the video by 10-20 MB to make sure you can still split it without one half being more than 700 MB. Another option would to be to split the movie with DGIndex and encode the two halves at exactly 700 MB.

i decreased the size but still i am getting small size 3rd part .

HeadBangeR77
4th March 2007, 19:57
i decreased the size but still i am getting small size 3rd part .
Your target size is 1433600 KB, which is ideally 1400 MB. It's not so easily predictable in which point (I-frame) VDub/VDubMod will cut, so we must take a margin of error into consideration.
However, if your three parts together (I've just reread your first post) are larger than 1400MB, then VDuBMod behaves fully normally - it's because you're getting oversized encodes! Check our section Undersizing/Oversizing in XviD forum for more information.

PS. You can always cut it manually on an I-frame somewhere in the middle of the film, or if end credits are long (low bitrate, even if encoded at the same quality as the rest), then I would rather try to cut near the end of the first half, but not exactly in the middle.

good luck ;)

CWR03
4th March 2007, 20:09
i decreased the size but still i am getting small size 3rd part .
My advice regarding that was aimed toward manually splitting the file.

aldaco12
6th March 2007, 14:30
Yes , you can split it in 2 (creating more or equal halves) , but if the file is 1430 MB you won't get 2*700 MB but 2*715 MB, and probably also the overburning will fail to fit such a file in a 80' CD-R.

A check you shoulld do is:
1) open VirtualDub (free!)
2) make video__Compression
3) look if , at the bottom, you see 2 'Xvid MPEG-4 Codec' possible choices (wrong) instead of only 1 (correct)
4) if you see two choice, uninstall Xvid (with the application uninstaller and from the Contol Panel, if possible) until you don't see any XviD voice, then reinstall it , repeating it until you notice that only one is available, now.

If I'm right, the problem is XviD's, not AutoGK's.

acebrain
6th March 2007, 15:06
Yes , you can split it in 2 (creating more or equal halves) , but if the file is 1430 MB you won't get 2*700 MB but 2*715 MB, and probably also the overburning will fail to fit such a file in a 80' CD-R.

A check you shoulld do is:
1) open VirtualDub (free!)
2) make video__Compression
3) look if , at the bottom, you see 2 'Xvid MPEG-4 Codec' possible choices (wrong) instead of only 1 (correct)
4) if you see two choice, uninstall Xvid (with the application uninstaller and from the Contol Panel, if possible) until you don't see any XviD voice, then reinstall it , repeating it until you notice that only one is available, now.

If I'm right, the problem is XviD's, not AutoGK's.

there is only one Xvid MPEG - 4 codec .
when i rip dvd into 700 MB it is not given me etra size .
only when i m riping 1400 MB this problem happens .

aldaco12
7th March 2007, 07:39
Ah I see. It's not a problem like mine, then.