PDA

View Full Version : .srt files won't play


oRBIT
15th February 2007, 16:20
I've ripped a few episodes from my startrek voyager collection, however 2 of 4 subtitle files won't play. I use directvobsub, and the icon appears when I try one of the avi's but the subs(.srt) won't appear on them anyway.
I've tried it on my stand-alone dvd-player and the subs don't work there aswell.
I've tried saving the srt file in several formats (unicode/utf-8/ansi) but no luck. The 2 subs that do work are saved as ANSI and they play fine.
And yes, the filenames are spelled just like the avi-name.
Hints?

smiller667
18th February 2007, 17:26
Did you check the timestamps in the srt files? Alternatively, post a couple of lines of the non-working subs (just copy-paste, no need to make an attachment).

Steve

NB: The subtitle forum might have been more appropriate for your question, btw.

jel
19th February 2007, 00:14
agreed - moved to subtitle forum.

good luck!

Adub
19th February 2007, 01:41
I didn't even know that standalones supported srt files. Also, what sort of splitter are you using?

setarip_old
19th February 2007, 06:12
@Merlin7777

Hi!I didn't even know that standalones supported srt files.Many DivX-compatible standalone players (Philips among others) will accept .SRT format subtitles for playback...

Adub
19th February 2007, 07:37
Really? Well, then I may have to look at getting a Divx/xvid compatible dvd player. Thanks for the info.

oRBIT
23rd February 2007, 17:53
Here's a few lines for a Sherlock Holmes episode. Playing this actually causes mediaplayer to lock up(!) when using directvobsub 2.37. The same happens with a few of my star trek voyager episodes.
I really appreciate any hints whats causing this. I'm using subrip to rip the subtitles and haven't modified the files manually in any way.

EDIT: I tried editing the .srt file so I used only subtitle entry 1 (below) but it still causes the mediaplayer to lock up. I'm getting mad! :)

1
00:01:19,600 --> 00:01:21,591
(Bumping)

2
00:01:21,680 --> 00:01:23,636
Psst.

3
00:01:27,000 --> 00:01:29,070
Got you.

4
00:01:42,680 --> 00:01:46,309
- (Knives clatter)
- Now, look here...

dwm4444
24th February 2007, 14:24
This has happened to me a couple of times.

In SubRip save the .srt as ANSI, then open it in Subtitle Workshop, then Click on "Tools", then "Information and Errors..." then "Fix all errors". This has worked for me in the past. Some of the newer subtitle programs may work for this, too, but I've never used them.

Good luck.

oRBIT
24th February 2007, 15:49
Thanks for the tip. The subtitle I tried had about 250 errors and all of them are fixed now. But still the video won't play. I've changed the settings in subtitle workshop to check for all kinds of errors (it returns "0 errors") but the movie is still refusing to play. :-(
Is .srt a crappy fileformat for subtitles, is there a better alternative?

dwm4444
24th February 2007, 16:54
.srt is supported by more standalones than any other format. However, some players, like my Philips 5960, also support vobsubs (sub/idx). I don't know what you're encoding your AVIs with, but if you use AutoGK, you can click on "Advanced Settings" and tick the "use external subtitles" box. It will give you a warning about them not being supported by standalones, but no big deal. After it finishes you can find the subs in the subfolder beneath your AVI (I think that's where they are, anyway). IIRC, the sub part is rar compressed. If your player can't use them in that form, you can convert them to .srt with subrip (I used to do that for my old Philips 642; just point subrip to the idx file. You'll need to unrar the sub part). Don't know if that will help any but might be worth a shot.

If all else fails, there's several good subtitle download sites around.

Good luck.

maja_ldm
24th February 2007, 19:39
I'll use the post for my problem:

I forced an .srt file in an .mp4(xvid) I was encoding with staxrip,
but now the VLC player doesn't even recognize the file got some subs.

what I've done wrong?
the subs square in the staxrip gui was checked...

ukendt
24th February 2007, 19:47
Sometimes the position of the subs are to far below the visible edge and they will disappear. Keep also in mind whether the dvd rip was letterbox or 16:9.
Forcing the dvd player to show 16:9 istead of letterbox will reveal(ususally) whether the subs are visible or not

maja_ldm
24th February 2007, 19:56
well, the screen was 16:9, but I made the subrip from the same source and the player doesn't even show a subs tray in its menus..:( :confused:

-------------------------------------------------------

anyway,
said I want a single file, if I mux the subs in the file after video&audio have been muxed in a container there should be no loss of quality, right?