PDA

View Full Version : Audio/Unsynched In VDub w/non-commercials captures


Socko
26th December 2001, 21:02
I have a winxp 1ghz athlon with a ati tv wonder pci card, Ive been caputuring tv shows with the ati software mmc 7.1, at 320x240 (cuz the vcd format distorts the length, making faces look too fat) and Ive had no problems, I edit the commercials out in Premiere 6 and then encode with divx3 in vdub, ive got tons of shows in divx that i did and theyre perfect and such

recently, i got digital cable here (in california) and hooked it up to my comp, when i capture regular tv shows with it, and edit, process them to divx...they work fine just as before.

the problem I have is when I capture things with NO commercials on the "premium" channels (ie. sopranos, oz & stargate sg1) using the digital cable box...it comes out fine but when I try to encode to divx, the result is the audio being totally unsynched with the video! Ive tried it several times with no luck, so i opened up Premiere and tried to save it using the same settings as I do when I edit the other stuff

When i played the mpg from preimere, it was EXTREMELY slow and choppy, i checked my settings and tried again but still the same! the normal regular type channels work fine when captured/edited/encoded, but i cant get the series/original tv movies that I want off the hbo/tmc/cinemax/starz variety

Anyone know why this happens and how i can fix it, is the streams or something totally different than the normal ones to screw this up or what?

Cart
27th December 2001, 09:09
Are you using the exact same capture, processing, and encoding settings as you did for non-digital shows? What are those settings?

It's very possible that the digital shows are using a protection scheme like Macrovision. However, this usually affects more than just the audio. Did you try using VirtualDub to change the frame rate of the video so it matches the audio length? Also, you could try capturing with VirtualDub instead of MMC.

-Cart
http://www.geocities.com/lukesvideo/index.html

Socko
27th December 2001, 19:23
im using the exact same setting for the digital cable shows i record (ie. simpsons) and the premium channels (ie. sopranos). i capture at 320x420 mpg-1 1.06mb/s 44 audio stereo. I encode using divx3 low-motion at 778k & 128k mp3.

i havent tried either of those, but i will

Socko
27th December 2001, 21:37
ahhh, sweet success! I opened up the avi in vdub and messed around a bit with the frames per second, the audio was a tiny bit slower than the video, so i started slowing it down, and i got it right on the second try! i went down buy .005 each time and so the final PERFECT setting (for the specific file i did) was 29.960

i checked dif parts in the avi and it all works fine, hopefully the same setting will work on future avi files as well! its too bad i didnt keep the old unsynched ones, cuz i could have fixed em now!

thanks man!

Socko
1st January 2002, 10:30
the fps settings work for me, except it seems they dont on avis over 1 hour or so, cuz ive captured a few movies that are 1.5 hours long (from the same channels used to get the sopranos that were unsynched)

i change the fps settings and when i get it sounding right at one point i use to tell, the rest of the file is still unsynched its weird...ive used the fps settings to synch a divx file thats over 2 houts long (from a dvd rip) and it worked out fine

help would be much appreciated

Cart
1st January 2002, 15:45
How big are the captured files that are having problems with the synch? Does the loss of synchronization occur at the same time in each video?

If possible, try using AVI_IO or VirtualDub instead of ATI's software. Both of them (especially AVI_IO) are likely to produce better audio synch.

-Cart
http://www.geocities.com/lukesvideo/index.html