PDA

View Full Version : DV to Mpeg2, problems using CCE and avisynth


Mistwalker
10th July 2006, 20:31
Alright, I'm having big troubles encoding DV -> Mpeg2. The problem is that I think that I get "blocky" results. I've been using CCE earlier when I made another DVD, and then the results were great. But I can't remember what version that was, but It was 2.68 or 2.70, can't remember which one :(

Another problem is that I can't use CCE properly since it won't load the AVS file that the DV -> Mpeg2 guide gives me. I get the error: "Frame size 852x56 is not supported. Supported frame size is up to: 720x576."

When I remove:

odd=SelectOdd.Convolution3D(1, 6, 10, 6, 8, 2.8, 0)
evn=SelectEven.Convolution3D(1, 6, 10, 6, 8, 2.8, 0)

I can open the AVS, and the error goes away. I don't know what those lines do, but I bet they are important :P

Here's the whole script for CCE that the guide tell me to use:

AviSource("C:\MyDVFiles\DV_type2_file.avi")
SeparateFields()
odd=SelectOdd.Convolution3D(1, 6, 10, 6, 8, 2.8, 0)
evn=SelectEven.Convolution3D(1, 6, 10, 6, 8, 2.8, 0)
Interleave(evn,odd)
Weave()
DoubleWeave.SelectOdd()


I'm a quality freak, so I do need the very best quality I can get out of my DV stream. I've been getting a little better results by increasing the bitrate to avg 6000kbps. But I think that's far to high to get rid of the little blocks that are shown when encoding at 3-4000kbps.

I'm filming a lot, and I've been coding to XviD and DivX without any problems at all, but now I'm going to make a couple of DVDs for me, my friends and sometimes customers. So I need the videos be in really good quality, that's why I'm so concerned about the blockiness.

Thanks for any help at all, and if anyone have any tips how to handle DV streams in a special way to get some kick ass results, please tell me! I've been searching this forums like a maniac, but not too many are handling DV streams :(

And one more thing, is it impossible to get interlaced streams when encoding to mpeg2? Because I can see that the stream is interlaced when viewing the DV stream, but not when it has been encoded. I've tried all interlaced settings there is, and I've also tried using Canopus ProCoder 2, and I can't see that the mpeg2 stream is interlaced there either.

Or is it the DV stream that makes it look like it's interlaced so much, or vice versa? Or can't you see that the footage is interlaced when it's in mpeg2?

Thanks for anything! :D

manono
11th July 2006, 11:23
Hi-

As you know, there's a problem with the .avs, but CCE doesn't give good error messages. It's always a good idea to open your scripts in VDub(Mod) before sending them to CCE, to make sure they're OK. VDubMod will give you a much more helpful error message. I suspect it has to do with colorspace problems. Your AVI is most likely some variety of RGB, and, depending on which version of C3D you're using, C3D requires YUY2 or YV12.

Although that's not how I filter interlaced sources, that script does produce an interlaced stream (something else to check once you get it to open in VDubMod). If you're not seeing it after encoding, perhaps you're using a player that is deinterlacing it. Open the MPV/M2V in VDubMod to see the unprocessed results.

As for the blockiness; maybe your source is hard to compress. You might open the blocky result in Bitrate Viewer to check if the Average Quant is high. About all you can do is to throw bits at it, that and use a lower bitrate matrix and AviSynth and/or CCE filtering.

Kisa_AG
12th July 2006, 17:36
Alright, I'm having big troubles encoding DV -> Mpeg2. The problem is that I think that I get "blocky" results. I've been using CCE earlier when I made another DVD, and then the results were great. But I can't remember what version that was, but It was 2.68 or 2.70, can't remember which one :(

It may depends on your bitrate and filter settings. As I remember, the quality of CCE was almost the same since version 2.6.4.

Another problem is that I can't use CCE properly since it won't load the AVS file that the DV -> Mpeg2 guide gives me. I get the error: "Frame size 852x56 is not supported. Supported frame size is up to: 720x576."


It's a problem of Avisynth. Framesize like 852x56 means that you are trying to encode Avisynth error message to mpeg-2. Use VirtualDub to veryfy your AVS file before encoding to mpeg-2.


When I remove:

odd=SelectOdd.Convolution3D(1, 6, 10, 6, 8, 2.8, 0)
evn=SelectEven.Convolution3D(1, 6, 10, 6, 8, 2.8, 0)

I can open the AVS, and the error goes away. I don't know what those lines do, but I bet they are important :P

It seems to me that you forgot to load Convolution3D plugin to the script. I don't see "LoadPlugin(..)" string in your script.
I would recomend you to go to Avisynth Threads. And to read it's manual carefully.

Thanks for any help at all, and if anyone have any tips how to handle DV streams in a special way to get some kick ass results, please tell me! I've been searching this forums like a maniac, but not too many are handling DV streams :(

Home-made DV movies are the most terrible footage for every encoder due to noice and handshake. Actually, you need to use the maximum possible bitrate for the good quality. Let's say, not less that 7500kbit/s. ANd if you want to use CCE than it's better to apply powerfull anti-noice filters like VagueDenoiser, DeGrainMedian or FFT3DFilter from Fizick. I don't like Convolution3D because it's quite coarse.
Very good mpeg-2 quality can be achieved with Procoder even without input filtering.

And one more thing, is it impossible to get interlaced streams when encoding to mpeg2?

It's possible. Moreover, if you use interlace settings in mpeg-2 encoder and don't do deinterlacing in avisynth script than you will get interlaced mpeg-2 footage. But on computer monitor it may looks like deinterlaced due to viewing decoder properties.