PDA

View Full Version : How to fix wrong timecode in vob?


punchball
28th January 2006, 17:33
I've made a DVD with my DVD recorder, with TV episodes. Each episode is in its own vob. When playing the DVD normally, the timecode is correct, but when playing a vob directly the timecode is wrong. This only happens to episodes where there is a chapter break. The episodes without a chapter break always have the right timecode.

I want to author a DVD (using DVD-lab PRO) containing these episodes and some other content. I've done it, but the problem is the timecode on these episodes. What I did was just copy the VOBs from the original DVD and into DVD-lab, because this has worked before. I see in IfoEdit that the timecode on the chapters is all wrong, and also the frame count. It doesn't seem like there's any way to just correct this in IfoEdit. Is there any tool that will correct this in the original VOB? Thanks.

jeanl
28th January 2006, 19:26
What is it that you call the time code?
jeanl

punchball
28th January 2006, 21:31
Here is how two of the titles in the original DVD (from the DVD recorder) shows up in IfoEdit:

VTS overview:

Menu attributes:
Video: MPEG-1 720x480 (NTSC) (NTSC 525/60) (4:3) (pan-scan & letterboxed)

Title Set (Movie) attributes:
Video: MPEG-2 352x576 (PAL) (PAL 625/50) (4:3) (not specified perm.display)
Audio 1: Not Specified (Dolby AC-3) 2ch 48Kbps DRC (ID: 0x80)

PGC_1 (program chain): [Title(TTN): 1] [00:40:57.03 / 25 fps] (Programs: 2) (Cells: 2) (uses VOB-IDs: 1,2)
[Ch 01] [Pg 01] [Cell 01] [V/C Id: 1/ 1] : time: 00:24:01.23 / 25 fps [Pos: 00:24:01.23] [Frames: 36048] SP/ILVU/DISC/SA:[ no/ no/yes/ no]
[Ch 02] [Pg 02] [Cell 02] [V/C Id: 2/ 1] Layer Br.: time: 00:16:55.05 / 25 fps [Pos: 00:40:57.03] [Frames: 61428] SP/ILVU/DISC/SA:[ no/ no/yes/ no]

Menu Language Units: 1
Language Menu Unit 1: []

Language Menu Unit 1: []
Menu 1: [Root-Menu] (entry PGC) (Programs: 0) (Cells: 0)VTS overview:

Menu attributes:
Video: MPEG-1 720x480 (NTSC) (NTSC 525/60) (4:3) (pan-scan & letterboxed)

Title Set (Movie) attributes:
Video: MPEG-2 352x576 (PAL) (PAL 625/50) (4:3) (not specified perm.display)
Audio 1: Not Specified (Dolby AC-3) 2ch 48Kbps DRC (ID: 0x80)

PGC_1 (program chain): [Title(TTN): 1] [00:40:07.05 / 25 fps] (Programs: 2) (Cells: 2) (uses VOB-IDs: 1,2)
[Ch 01] [Pg 01] [Cell 01] [V/C Id: 1/ 1] : time: 00:18:24.24 / 25 fps [Pos: 00:18:24.24] [Frames: 27624] SP/ILVU/DISC/SA:[ no/ no/yes/ no]
[Ch 02] [Pg 02] [Cell 02] [V/C Id: 2/ 1] Layer Br.: time: 00:21:42.06 / 25 fps [Pos: 00:40:07.05] [Frames: 60180] SP/ILVU/DISC/SA:[ no/ no/yes/ no]

Menu Language Units: 1
Language Menu Unit 1: []

Language Menu Unit 1: []
Menu 1: [Root-Menu] (entry PGC) (Programs: 0) (Cells: 0)


Here is how they show up in my new DVD. The two titles from above are PGC_3 and PGC_4:

VTS overview:

Menu attributes:
Video: MPEG-1 720x480 (NTSC) (NTSC 525/60) (4:3) (pan-scan & letterboxed)

Title Set (Movie) attributes:
Video: MPEG-2 352x576 (PAL) (PAL 625/50) (4:3) (not specified perm.display)
Audio 1: Not Specified (Dolby AC-3) 2ch 48Kbps DRC (ID: 0x80)

PGC_1 (program chain): [Title(TTN): 1] [00:41:38.22 / 25 fps] (Programs: 1) (Cells: 1) (uses VOB-IDs: 1)
[Ch 01] [Pg 01] [Cell 01] [V/C Id: 1/ 1] : time: 00:41:38.22 / 25 fps [Pos: 00:41:38.22] [Frames: 62472] SP/ILVU/DISC/SA:[ no/ no/yes/ no]

PGC_2 (program chain): [Title(TTN): 2] [00:40:03.21 / 25 fps] (Programs: 1) (Cells: 1) (uses VOB-IDs: 2)
[Ch 01] [Pg 01] [Cell 01] [V/C Id: 2/ 1] : time: 00:40:03.21 / 25 fps [Pos: 00:40:03.21] [Frames: 60096] SP/ILVU/DISC/SA:[ no/ no/yes/ no]

PGC_3 (program chain): [Title(TTN): 3] [00:16:55.05 / 25 fps] (Programs: 2) (Cells: 2) (uses VOB-IDs: 3)
[Ch 01] [Pg 01] [Cell 01] [V/C Id: 3/ 1] : time: 00:00:00.00 / 25 fps [Pos: 00:00:00.00] [Frames: 0] SP/ILVU/DISC/SA:[ no/ no/yes/ no]
[Pg 02] [Cell 02] [V/C Id: 3/ 2] Layer Br.: time: 00:16:55.05 / 25 fps [Pos: 00:16:55.05] [Frames: 25380] SP/ILVU/DISC/SA:[ no/ no/ no/ no]

PGC_4 (program chain): [Title(TTN): 4] [00:21:42.05 / 25 fps] (Programs: 2) (Cells: 2) (uses VOB-IDs: 4)
[Ch 01] [Pg 01] [Cell 01] [V/C Id: 4/ 1] : time: 13:15:21.21 / 25 fps [Pos: 13:15:21.21] [Frames: 1193046] SP/ILVU/DISC/SA:[ no/ no/yes/ no]
[Pg 02] [Cell 02] [V/C Id: 4/ 2] Layer Br.: time: 00:21:42.06 / 25 fps [Pos: 13:37:04.02] [Frames: 1225602] SP/ILVU/DISC/SA:[ no/ no/ no/ no]

PGC_5 (program chain): [Title(TTN): 5] [00:41:57.03 / 25 fps] (Programs: 2) (Cells: 2) (uses VOB-IDs: 5)
[Ch 01] [Pg 01] [Cell 01] [V/C Id: 5/ 1] : time: 00:06:00.24 / 25 fps [Pos: 00:06:00.24] [Frames: 9024] SP/ILVU/DISC/SA:[ no/ no/yes/ no]
[Pg 02] [Cell 02] [V/C Id: 5/ 2] Layer Br.: time: 00:35:56.04 / 25 fps [Pos: 00:41:57.03] [Frames: 62928] SP/ILVU/DISC/SA:[ no/ no/ no/ no]

Menu Language Units: 1
Language Menu Unit 1: [English]

Language Menu Unit 1: [English]
Menu 1: [Root-Menu] (entry PGC) (Programs: 0) (Cells: 0)

As you can see, the first chapter has a totally wrong "time" and "frames" in both those titles. PGC_1 and PGC_2, and PGC_5 (althought it does have two chapters), are all fine - they're unchanged.
The two problem-titles will have problems during playback, searching doesn't work right, you can only watch the titles straight through.

jeanl
28th January 2006, 21:40
Well, it sure looks wrong, but apparently, more than just the chapter times are wrong (if you can't search etc). Is this a DVDLab problem?
For example, your VCID 3/1 in the output DVD seems to have 0 frames! You should check whether that VCID indeed has 0 frames in the vob file (I doubt it!). YOu can check with pgceditpreview (which is in the bin directory where you install pgcedit). Drag/drop your vob on it, then click the "Info" box, and try to scroll to VCID 3/1 and see if you have the video.
I'm guessing that if you process the full dvd with vobblanker, in place for example, making sure you process all VTS, this will be fixed for you. It's easy, and worth the try.
The fact that you can't search might be because you have a PUO that forbids you to (check that with PGCEdit). Try enabling that in pgcedit, and see if you can fast forward.
jeanl

punchball
28th January 2006, 21:58
Thanks for your response.
I don't think it's a DVDLab problem, because as I said if I play the original VOBs (just play the VOB directly) then the player reports that the length is 17 minutes (for title 3) or 13 hours (for title 4). Actually I can fast forward, but if I jump to a specific point, it doesn't work, obviously because of the wrong timecode. This is true both if playing the original VOB and of playing the new DVD. I know that all the frames are there, so 0 frames is indeed wrong. That's why I originally thought it would be great if I can just edit the timecodes somehow!
If I demux the VOBs in DVDLab, the timecodes are ok, but the .mpv file gets too long, resulting in sync problems!
I'll try your suggestions now.

punchball
28th January 2006, 23:13
I tried using VobBlanker, but the resulting vob had the same problem. Just to be clear, no frames are missing, neither in the original vob or the new DVD. The problem is with the timecode/framecount. I've also tried ripping the original DVD with DVD Decrypter first, no difference.
I'm going crazy here...

jeanl
28th January 2006, 23:15
OK, can you post your IFOs? Zip them all up in a zip file and send them to us, for example via www.yousendit.com, or email to me at least jeanldvd at free dot fr...
jeanl

jeanl
28th January 2006, 23:42
OK I got them. Indeed the playback time is bad in PGC 3 and 4. This seems to be a problem with DVDLab, but that seems hard to believe.

FixVTS can fix that for you (just run it in-place, not removing unreferenced material) on the output DVD. But this has almost no impact on playback (the time is only used for the DVD player display I think).
I don't see any PUO (in the IFO) concerning fast forward. What happens when you try to fast forward? It simply does not?
There might be PUOs in the vob, but DVD decrypter normally removes them. Are you sure you had that option checked when you ripped the vobs? You could possibly open the VOB in VOBEdit and then go to a navpack and look at offset 0035...
jeanl

jeanl
28th January 2006, 23:45
BTW, I just checked, the time is wrong, but the number of frames is exact: If you count the two chapters in the output DVD, you get the same number of frames as in the original title in the original DVD... So you're not missing anything!
jeanl

jeanl
28th January 2006, 23:47
And another BTW: If you look at your output, DVDLab did not put 2 chapters in PGC 3 and 4 even though you had 2 chapters in the original. This means you can't skip to the second part as you could in the original. That's something you can fix with PGCEdit as well.
jeanl

punchball
29th January 2006, 00:44
I used FixVTS as you said, but nothing changed.

Fast forward does work, no problem. What doesn't work is skipping to another point in the episode. For example clicking the "playback bar" in PowerDVD or any other player. If I do that, it just jumps back to the beginning or something. Also, the time shown when playing the title is wrong.

I can't see that the number of frames is right. Are you sure you're looking in the right file? In PGC 3 I see 0+25380 frames (should be 61428). In PGC 4 I see 1193046+1225602 frames (should be 60180).

I can't see that DVDLab changed the number of chapters either. There are still two chapters in PGC 3 and 4... Are we talking about different things?

Is there any tool I can use to rip/process the titles from the original DVD so that it's processed but not re-encoded, if you see what I mean? A tool that would join the chapters and get the timecode right. (I don't need the chapter breaks, they're just remnants from removing commercial breaks.)

jeanl
29th January 2006, 00:56
Yes, you can use TMPGenc DVD Author and rebuilt everything you need the way you like it. There's a 1 month trial period, but it will import your VOB without decoding/encoding.
Also, if it's the time-search that's not working, it's probably your time VTS_TMAPTI that's faulty in your IFO, normally vobblanker reconstructs that from scratch, so the vobblanker version of your DVD should work OK that way...
jeanl
P.S> OK, I remember now that FixVTS does not correct the playback time of the chapter but simply recomputes the total. Darn...

jsoto
29th January 2006, 02:03
Try demuxing the PGCs with pgcDemux, and remuxing again with Muxman. If the error is in the PTSs may be it will be fixed. Be careful with the celltimes.txt file, better use the original.

Check the Muxman created DVDs (single PGC) . If OK, you can replace the PGCs with VobBlanker

jsoto

EDIT: To calculate the cell duration, VobBlanker uses CellElapsedTime of the last Nav (Offset 0x045 in the Nav) to get the initial time of last NAv, and adds the VOBU duration.
so seems the elapsed time in Navs is completely broken...
Please Note that 2^32= 4294967296
and
13:15:21.21 = 1193096 frames and 1193096 *3600= 4294965600

Seems a problem between signed and unsigned integers...

EDIT2: Please check your Elapsed Time values inside the VOB with VOBEdit. You need to locate the cell and jump with VObEdit to the first Nav. Look into offset 0x45

jsoto

punchball
29th January 2006, 02:35
Yeah, I tried Vobblanker before and it didn't fix the problem...

Anyway, I fixed it in DVDLab. Like I said, demuxing the vob in DVDLab solves the timecode problem (and joins the chapters), but it was out of sync. I found out DVDLab has a tool that fixes this. What I had to do with each title was:
1) demux the vob
2) compile a temporary dvd with just this title (mpv+ac3)
3) open the resulting vob in DVDLab to read the audio delay
4) run the audio delay tool on the .ac3 file
5) use the fixed ac3 with the mpv file in the finished DVD

The audio delay on both of these was -80ms by the way. Now I have five more vobs from another DVD to fix... :/

jsoto
29th January 2006, 02:55
VobBlanker does not fix bad elapsed times (well, there is a trick to do that, but...). The problem is which program has a bug if the elapsed time show 13 hours!. Could you confim that your VOB was wrong in this point?

BTW, I recomend you to use pgcDemux and MuxMan
-80 msec delay is probably false. That is due 2 B frames not correctly processed. An old a very known bug of many progs.
You can easily check the delay in pgcDemux, after loading the IFO.

jsoto

punchball
29th January 2006, 03:23
The original VOB was wrong, but I made a mistake in what I wrote in post #5 above. For title 3, the length is reported as 16:55, but for title 4 it's 21:42. I.e. the length of the second chapter in each title. That's if I play the vobs in a player like BSplayer or Zoomplayer.

In the finished new DVD, the length for title 4 is reported as 13 hours...

I'll check out the progs you mentioned.

punchball
30th January 2006, 02:24
Ok, PgcDemux didn't seem to do much of a difference. Haven't tried re-muxing with MuxMan though, 'cause I haven't got that program. But it seemed to me that the sync problems happened during demuxing.

Anyway, after fiddling around with this forever I started checking out IfoEdit again, and it turns out this was easily fixable in IfoEdit, just liked I hoped at the start! (Only too bad I couldn't have figured this out sooner.)

So I compiled the DVD without demuxing the vobs, and just corrected the timecodes in the ifo afterwards.
The timecodes for the program chains can be found under VTS_PGCITI. Just click it and expand it. In the program chains to be fixed, two values had to be changed: Playback time, and Cell_1 playback time. (Cell_2 playback time was correct.) I just copied in the values from my original DVD, saved the ifo, and everything worked like a charm!

jsoto
30th January 2006, 07:38
I can not live w/o MuxMan in the DVD backup arena...
http://www.mpucoder.com/Muxman/

You can correct the IFOs, but I'm pretty sure your VOBs are still wrong...

jsoto

punchball
30th January 2006, 16:53
You can correct the IFOs, but I'm pretty sure your VOBs are still wrong...
Any suggestions on what I could do to test that? The titles seem to play perfectly. But I haven't tried burning the DVD files onto an actual DVD and played it in a standalone yet... Will do that now.

jsoto
30th January 2006, 19:07
To check the VOBs:
Use VobEdit and look into the Navs, Check if Elapsed Times or PTSs values are unusually high...

jsoto

punchball
30th January 2006, 21:08
The burned DVD seems to be working fine.

I just discovered your previous post with two edits, jsoto..! I missed it before somehow, so my next response (about Vobbblanker) was to jeanl...

Anyway, I downloaded VOBEdit, but having a little trouble using it. Are there any explanations somewhere? I'm pretty new to editing/seeing inside VOBs and IFOs. DVDLab put all five episodes in one VTS, which is split into four vobs. I don't know which vob to start looking in, and there are *a lot* of navigation packs. How do I find the right nav and the right cell..??

ron spencer
30th January 2006, 21:28
when you bring the VOBs into DVDLab it will offer to demux them....let it. Or use DVD Decryptor and let it demux your files, which is what I do from my DVD Recorder.

Then use the elemental streams into DVDLab and choose Tools->ReWrite GOP timecode....works for me never an issue ever.

Or you could use the Attach External VTS option in DVdLab and use PGCEdit to fix up VM commands later....all works like a charm

punchball
30th January 2006, 23:23
when you bring the VOBs into DVDLab it will offer to demux them....let it. Or use DVD Decryptor and let it demux your files, which is what I do from my DVD Recorder.

Then use the elemental streams into DVDLab and choose Tools->ReWrite GOP timecode....works for me never an issue ever.
I've tried demuxing with both DVDLab and DVD Decrypter, and I've tried Rewrite GOP timecode. Rewrite GOP did change the length of the mpv file, but it was still out of sync. DVDLab's Audio Delay function did seem to fix the sync problem though (although I had to use -160ms on some titles and -80ms on others.)

In the end I didn't demux, because using the vobs un-demuxed and fixing the timecodes in IfoEdit worked, like I wrote.
All testing indicates that the DVD plays perfectly so I'll just go with that method now. Thanks to all of you for your suggestions though.

ron spencer
31st January 2006, 01:01
dvdlab does not handle vob well without demuxing...author of it said so, so do not try...if you must then use attach external vts

dvd decryptor will tell you the audio delay use the audio delay tool in dvdlab to adjust....i do this all the time. using vob is the 100% wrong way to do things...check out the dvdlab forum for why as this has come up there. I never use VOB import ever....makes for a messed DVD

punchball
1st February 2006, 00:29
dvdlab does not handle vob well without demuxing...author of it said so, so do not try...if you must then use attach external vts
Well, sorry but I did try. :) I did this once before too, because demuxing intruduced sync problems (only tried demuxing in DVDLab that time). Anyway, both that time and now, using the vobs directly in DVDLab worked perfectly (except the titles with that weird chapter break, but there was something "special" with those vobs...) I don't know why it works when it's not "supposed" to... But I don't know how to do the things you suggest... to attach external VTS. What VTS is that? How do I "use PGCEdit to fix up VM commands"? Is this approach explained somewhere?

ron spencer
1st February 2006, 02:48
Goto File-->Attach external VTS.

Use this if you find your dvd recorder makes funky dvds..some do.

only problem with this is that DVDlab just copies the VTSs in, so you need to manually enter the VM commands to jump to them...e.g, jumptt 2 to jump to title 2.

then after your compile you would need to use PGCEdit to edit the pre and post commands of the external VTS to link back to the proper menus.

in general though with my 2 dvd recorders I demux all file via dvd decryptor (make sure you finalize your recorders shows first) and then just import them...never an issue

punchball
2nd February 2006, 00:57
Goto File-->Attach external VTS.
Yeah, that much I could figure out. :)
But what VTS do I attach?

in general though with my 2 dvd recorders I demux all file via dvd decryptor (make sure you finalize your recorders shows first) and then just import them...never an issue
Yes, I did that, finalized too. Guess my Pioneer recorder makes funky DVDs...